]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- rebuild with python 3.8
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        1.2.5
9 Release:        5
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  e3ab0e2c43bb6b28f29eced47cca8d67
14 Patch0:         %{name}-pylint.patch
15 URL:            https://github.com/abrt/abrt/wiki/ABRT-Project
16 BuildRequires:  abrt-gui-devel >= 2.1.7
17 BuildRequires:  asciidoc
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  gettext-tools >= 0.17
21 BuildRequires:  gtk+3-devel >= 3.0
22 BuildRequires:  intltool >= 0.35.0
23 BuildRequires:  libreport-gtk-devel >= 2.0.20
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 %{?with_tests:BuildRequires:    pylint}
27 BuildRequires:  python3-devel >= 1:3.4
28 %{?with_tests:BuildRequires:    python3-libreport}
29 BuildRequires:  python3-pygobject3-devel >= 3.0
30 BuildRequires:  rpmbuild(macros) >= 1.596
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  xmlto
33 BuildRequires:  xorg-lib-libX11-devel
34 Requires(post,postun):  gtk-update-icon-cache
35 Requires:       abrt-dbus
36 Requires:       abrt-gui-libs >= 2.1.7
37 Requires:       hicolor-icon-theme
38 Requires:       python3-dbus
39 Requires:       python3-libreport
40 Requires:       python3-pygobject3 >= 3.0
41 Requires:       python3-pyinotify
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A GNOME application allows users to browse through detected problems
46 and provides them with convenient way for managing these problems.
47
48 %description -l pl.UTF-8
49 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
50 zapewniająca wygodny sposób zarządzania tymi problemami.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %{__sed} -i -e 's#-pedantic##g' configure.ac
57 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
58
59 %{__sed} -n -e '/^%%changelog/,$' gnome-abrt.spec.in | tail -n +2 > changelog
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__automake}
66 %configure \
67         --disable-silent-rules \
68         %{!?with_tests:--with-nopylint}
69
70 %{__make}
71
72 %{?with_tests:%{__make} check}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gnome_abrt/wrappers/*.la
80 %py_postclean
81
82 # packaged as %doc
83 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnome-abrt/README.md
84
85 %find_lang %{name}
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %update_icon_cache hicolor
91
92 %postun
93 %update_icon_cache hicolor
94
95 %files -f %{name}.lang
96 %defattr(644,root,root,755)
97 %doc README.md changelog
98 %attr(755,root,root) %{_bindir}/gnome-abrt
99 %dir %{py3_sitedir}/gnome_abrt
100 %{py3_sitedir}/gnome_abrt/*.py
101 %{py3_sitedir}/gnome_abrt/__pycache__
102 %dir %{py3_sitedir}/gnome_abrt/url
103 %{py3_sitedir}/gnome_abrt/url/*.py
104 %{py3_sitedir}/gnome_abrt/url/__pycache__
105 %dir %{py3_sitedir}/gnome_abrt/wrappers
106 %{py3_sitedir}/gnome_abrt/wrappers/__init__.py
107 %{py3_sitedir}/gnome_abrt/wrappers/__pycache__
108 %attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.so
109 %{_datadir}/gnome-abrt
110 %{_datadir}/appdata/gnome-abrt.appdata.xml
111 %{_desktopdir}/gnome-abrt.desktop
112 %{_iconsdir}/hicolor/*x*/apps/gnome-abrt.png
113 %{_iconsdir}/hicolor/*x*/status/gnome-abrt.png
114 %{_iconsdir}/hicolor/symbolic/apps/gnome-abrt-symbolic.svg
115 %{_mandir}/man1/gnome-abrt.1*
This page took 0.03092 seconds and 3 git commands to generate.