]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- abrt-gui headers still required; release 2
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        1.3.1
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/System
12 #Source0Download: https://github.com/abrt/gnome-abrt/releases
13 Source0:        https://github.com/abrt/gnome-abrt/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  2529440838d44afe7c4696e2f76b4986
15 URL:            https://github.com/abrt/abrt/wiki/gnome-abrt
16 BuildRequires:  abrt-gui-devel >= 2.4.0
17 BuildRequires:  asciidoc
18 BuildRequires:  gettext-tools >= 0.17
19 BuildRequires:  gtk+3-devel >= 3.0
20 BuildRequires:  libreport-gtk-devel >= 2.4.0
21 BuildRequires:  meson >= 0.51.0
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig
24 %{?with_tests:BuildRequires:    pylint}
25 BuildRequires:  python3-devel >= 1:3.4
26 %{?with_tests:BuildRequires:    python3-humanize}
27 %{?with_tests:BuildRequires:    python3-libreport}
28 BuildRequires:  python3-pygobject3-devel >= 3.29.1
29 BuildRequires:  rpmbuild(macros) >= 1.596
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  xmlto
32 Requires(post,postun):  gtk-update-icon-cache
33 Requires:       abrt-dbus
34 Requires:       abrt-gui-libs >= 2.4.0
35 Requires:       hicolor-icon-theme
36 Requires:       libreport-gtk >= 2.4.0
37 Requires:       python3-dbus
38 Requires:       python3-humanize >= 2.4.0
39 Requires:       python3-libreport >= 2.4.0
40 Requires:       python3-pygobject3 >= 3.29.1
41 Requires:       python3-pyinotify
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A GNOME application allows users to browse through detected problems
46 and provides them with convenient way for managing these problems.
47
48 %description -l pl.UTF-8
49 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
50 zapewniająca wygodny sposób zarządzania tymi problemami.
51
52 %prep
53 %setup -q
54
55 %build
56 %meson build \
57         %{!?with_tests:-Dlint=false}
58
59 %ninja_build -C build
60
61 %if %{with tests}
62 %ninja_test -C build
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %ninja_install -C build
69
70 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
71 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
72
73 %find_lang %{name}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 %update_icon_cache hicolor
80
81 %postun
82 %update_icon_cache hicolor
83
84 %files -f %{name}.lang
85 %defattr(644,root,root,755)
86 %doc README.md
87 %attr(755,root,root) %{_bindir}/gnome-abrt
88 %dir %{py3_sitedir}/gnome_abrt
89 %{py3_sitedir}/gnome_abrt/*.py
90 %{py3_sitedir}/gnome_abrt/__pycache__
91 %dir %{py3_sitedir}/gnome_abrt/url
92 %{py3_sitedir}/gnome_abrt/url/*.py
93 %{py3_sitedir}/gnome_abrt/url/__pycache__
94 %dir %{py3_sitedir}/gnome_abrt/wrappers
95 %{py3_sitedir}/gnome_abrt/wrappers/__init__.py
96 %{py3_sitedir}/gnome_abrt/wrappers/__pycache__
97 %attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.cpython-*.so
98 %{_datadir}/gnome-abrt
99 %{_datadir}/metainfo/org.freedesktop.GnomeAbrt.appdata.xml
100 %{_desktopdir}/org.freedesktop.GnomeAbrt.desktop
101 %{_iconsdir}/hicolor/scalable/apps/org.freedesktop.GnomeAbrt.svg
102 %{_iconsdir}/hicolor/symbolic/apps/org.freedesktop.GnomeAbrt-symbolic.svg
103 %{_mandir}/man1/gnome-abrt.1*
This page took 0.054156 seconds and 3 git commands to generate.