]> git.pld-linux.org Git - packages/gnome-abrt.git/blame - gnome-abrt.spec
- rel 3; fix python 3.5 build
[packages/gnome-abrt.git] / gnome-abrt.spec
CommitLineData
03a042be
JB
1#
2# Conditional build:
11bdae2f 3%bcond_with tests # "make check" run (some pylint false positive?)
e4d779b7 4
03a042be
JB
5Summary: A utility for viewing problems that have occurred with the system
6Summary(pl.UTF-8): Narzędzie do przeglądania problemów, które wystąpiły w systemie
7Name: gnome-abrt
23131381 8Version: 1.2.0
da95b34b 9Release: 3
03a042be
JB
10License: GPL v2+
11Group: Applications/System
12Source0: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
23131381 13# Source0-md5: 9b2d3e364e735f6a7401a84462951232
11bdae2f 14Patch0: %{name}-pylint.patch
da95b34b 15Patch1: %{name}-python.patch
f4c1c4a3 16URL: https://github.com/abrt/abrt/wiki/ABRT-Project
a4b53cf6 17BuildRequires: abrt-gui-devel >= 2.1.7
03a042be 18BuildRequires: asciidoc
da95b34b
AM
19BuildRequires: autoconf
20BuildRequires: automake
b2c3a5da 21BuildRequires: gettext-tools >= 0.17
03a042be
JB
22BuildRequires: gtk+3-devel >= 3.0
23BuildRequires: intltool >= 0.35.0
77732c33 24BuildRequires: libreport-gtk-devel >= 2.0.20
da95b34b 25BuildRequires: libtool
03a042be
JB
26BuildRequires: pkgconfig
27%{?with_tests:BuildRequires: pylint}
23131381 28BuildRequires: python3-devel >= 1:3.4
44e1f915
JB
29%{?with_tests:BuildRequires: python3-libreport}
30BuildRequires: python3-pygobject3-devel >= 3.0
ad30d5d2 31BuildRequires: rpmbuild(macros) >= 1.596
e8510905 32BuildRequires: sed >= 4.0
03a042be 33BuildRequires: xmlto
23131381 34BuildRequires: xorg-lib-libX11-devel
ad30d5d2 35Requires(post,postun): gtk-update-icon-cache
5eec88c3 36Requires: abrt-dbus
a4b53cf6 37Requires: abrt-gui-libs >= 2.1.7
ad30d5d2 38Requires: hicolor-icon-theme
44e1f915
JB
39Requires: python3-dbus
40Requires: python3-libreport
41Requires: python3-pygobject3 >= 3.0
42Requires: python3-pyinotify
03a042be
JB
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46A GNOME application allows users to browse through detected problems
47and provides them with convenient way for managing these problems.
48
49%description -l pl.UTF-8
50Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
51zapewniająca wygodny sposób zarządzania tymi problemami.
52
53%prep
54%setup -q
11bdae2f 55%patch0 -p1
da95b34b 56%patch1 -p1
03a042be 57
da95b34b 58%{__sed} -i -e 's#-pedantic##g' configure.ac
e8510905
JB
59%{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
60
03a042be 61%build
da95b34b
AM
62%{__libtoolize}
63%{__aclocal}
64%{__autoconf}
65%{__automake}
03a042be 66%configure \
e8510905
JB
67 --disable-silent-rules \
68 %{!?with_tests:--with-nopylint}
03a042be
JB
69
70%{__make}
71
72%{?with_tests:%{__make} check}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76%{__make} install \
77 DESTDIR=$RPM_BUILD_ROOT
78
44e1f915 79%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gnome_abrt/wrappers/*.la
03a042be
JB
80%py_postclean
81
82# just a copy of cs
5eec88c3 83%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs_CZ
03a042be
JB
84
85%find_lang %{name}
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post
91%update_icon_cache hicolor
92
93%postun
94%update_icon_cache hicolor
95
96%files -f %{name}.lang
97%defattr(644,root,root,755)
98%attr(755,root,root) %{_bindir}/gnome-abrt
44e1f915
JB
99%dir %{py3_sitedir}/gnome_abrt
100%{py3_sitedir}/gnome_abrt/*.py
101%{py3_sitedir}/gnome_abrt/__pycache__
102%dir %{py3_sitedir}/gnome_abrt/url
103%{py3_sitedir}/gnome_abrt/url/*.py
104%{py3_sitedir}/gnome_abrt/url/__pycache__
105%dir %{py3_sitedir}/gnome_abrt/wrappers
106%{py3_sitedir}/gnome_abrt/wrappers/__init__.py
107%{py3_sitedir}/gnome_abrt/wrappers/__pycache__
108%attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.so
03a042be 109%{_datadir}/gnome-abrt
a4b53cf6 110%{_datadir}/appdata/gnome-abrt.appdata.xml
03a042be 111%{_desktopdir}/gnome-abrt.desktop
23131381
JB
112%{_iconsdir}/hicolor/*x*/apps/gnome-abrt.png
113%{_iconsdir}/hicolor/*x*/status/gnome-abrt.png
114%{_iconsdir}/hicolor/symbolic/apps/gnome-abrt-symbolic.svg
77732c33 115%{_mandir}/man1/gnome-abrt.1*
This page took 0.09235 seconds and 4 git commands to generate.