]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- up to 2.33
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 1 Feb 2021 21:24:33 +0000 (22:24 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 1 Feb 2021 21:24:33 +0000 (22:24 +0100)
branch.sh
glibc-no-bash-nls.patch
glibc.spec

index 05c3545fae7803fd75d2a8aea6e45a037591ebe3..b4e19b9e2da459d9a3fc2bcfd0a8886cdc72a4f1 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,8 +2,8 @@
 set -e
 url=git://sourceware.org/git/glibc.git
 package=glibc
-tag=glibc-2.32
-branch=release/2.32/master
+tag=glibc-2.33
+branch=release/2.33/master
 out=$package-git.patch
 repo=$package.git
 
index 6b7214f0718402ee5136282b79beba69754dc415..4dc6b57f9e99e2caeb77a017803553d073cb090c 100644 (file)
@@ -3,7 +3,7 @@
 @@ -1,4 +1,4 @@
 -#! @BASH@
 +#!/bin/sh
- # Copyright (C) 1996-2020 Free Software Foundation, Inc.
+ # Copyright (C) 1996-2021 Free Software Foundation, Inc.
  # This file is part of the GNU C Library.
  
 @@ -35,16 +35,16 @@
@@ -14,7 +14,7 @@
 +    printf "Copyright (C) %s Free Software Foundation, Inc.
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- " "2020"
+ " "2021"
 -    printf $"Written by %s and %s.
 +    printf "Written by %s and %s.
  " "Roland McGrath" "Ulrich Drepper"
 @@ -1,4 +1,4 @@
 -#! @BASH@
 +#!/bin/sh
- # Copyright (C) 2011-2020 Free Software Foundation, Inc.
+ # Copyright (C) 2011-2021 Free Software Foundation, Inc.
  # This file is part of the GNU C Library.
  
 @@ -29,7 +29,7 @@
 +    printf "Copyright (C) %s Free Software Foundation, Inc.
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
- " "2020"
+ " "2021"
 -    printf $"Written by %s.\n" "Ulrich Drepper"
 +    printf "Written by %s.\n" "Ulrich Drepper"
      exit 0
index e2421adcabca41ae3b97bc61cdf7a6bb09c31690..4dbc0044d01bff7abf222ac289b3631f0b2521d1 100644 (file)
@@ -36,7 +36,7 @@
 %undefine              with_static_pie
 %endif
 
-%define                core_version    2.32
+%define                core_version    2.33
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -50,12 +50,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       8
+Release:       1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 720c7992861c57cf97d66a2f36d8d1fa
+# Source0-md5: 390bbd889c7e8e8a7041564cb6b27cca
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -67,7 +67,7 @@ Source7:      %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
-# Patch0-md5:  b1ec947dbc001ca41ffa2c4bf79ec4dc
+# Patch0-md5:  d41d8cd98f00b204e9800998ecf8427e
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -1084,7 +1084,6 @@ cp -a %{SOURCE3}          $RPM_BUILD_ROOT/etc/sysconfig/nscd
 cp -a %{SOURCE4}               $RPM_BUILD_ROOT/etc/logrotate.d/nscd
 cp -a nscd/nscd.conf           $RPM_BUILD_ROOT%{_sysconfdir}
 cp -a posix/gai.conf           $RPM_BUILD_ROOT%{_sysconfdir}
-cp -a nis/nss $RPM_BUILD_ROOT/etc/default/nss
 sed -e 's#\([ \t]\)db\([ \t]\)#\1#g' nss/nsswitch.conf > $RPM_BUILD_ROOT%{_sysconfdir}/nsswitch.conf
 
 xz -dc %{SOURCE5} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
@@ -1466,7 +1465,6 @@ fi
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nsswitch.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gai.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/nss
 
 %config %{_sysconfdir}/rpc
 
@@ -1475,7 +1473,7 @@ fi
 %attr(755,root,root) %{_bindir}/getent
 %attr(755,root,root) %{_bindir}/iconv
 %attr(755,root,root) %{_bindir}/locale
-%attr(755,root,root) %{_sbindir}/zdump
+%attr(755,root,root) %{_bindir}/zdump
 %attr(755,root,root) %{_sbindir}/zic
 
 %dir %{_libexecdir}/getconf
This page took 0.062574 seconds and 4 git commands to generate.