]> git.pld-linux.org Git - packages/glibc.git/commitdiff
- removed obsolete missing-nls,nss_include_dirs patches
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Feb 2020 16:12:18 +0000 (17:12 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Feb 2020 16:12:18 +0000 (17:12 +0100)
glibc-info.patch
glibc-missing-nls.patch [deleted file]
glibc-nss_include_dirs.patch [deleted file]
glibc-pr13013.patch [deleted file]
glibc.spec

index 8511c0afcb32415984651b7cab0c0dd08a4603c2..a98556d1680e10cbd4ee44f7eb4fb6797cbc45f3 100644 (file)
@@ -9,7 +9,7 @@ diff -Nru glibc-2.1/manual/libc.texinfo glibc-2.1.new/manual/libc.texinfo
 +@dircategory Libraries:
  @direntry
 -* Libc: (libc).                 C library.
-+* Libc: (libc).                               C library.
++* Libc: (libc).                               C library
  @end direntry
  @include dir-add.texi
  
diff --git a/glibc-missing-nls.patch b/glibc-missing-nls.patch
deleted file mode 100644 (file)
index 484ce3a..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- glibc-2.3.1/sunrpc/rpc_main.c.orig Fri Nov  2 03:15:17 2001
-+++ glibc-2.3.1/sunrpc/rpc_main.c      Mon Nov 11 14:07:24 2002
-@@ -38,6 +38,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
-+#include <locale.h>
- #include <libintl.h>
- #include <ctype.h>
- #include <sys/types.h>
-@@ -185,6 +185,9 @@
- {
-   struct commandline cmd;
-+  setlocale (LC_ALL, "");
-+  textdomain ("libc");
-+
-   (void) memset ((char *) &cmd, 0, sizeof (struct commandline));
-   clear_args ();
-   if (!parseargs (argc, argv, &cmd))
-
diff --git a/glibc-nss_include_dirs.patch b/glibc-nss_include_dirs.patch
deleted file mode 100644 (file)
index 1e4949c..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- glibc-2.26/configure.ac~   2017-12-04 08:35:08.000000000 +0100
-+++ glibc-2.26/configure.ac    2017-12-04 08:40:44.267900240 +0100
-@@ -326,14 +326,7 @@ AC_ARG_ENABLE([nss-crypt],
-             [nss_crypt=$enableval],
-             [nss_crypt=no])
- if test x$nss_crypt = xyes; then
--  nss_includes=-I$(nss-config --includedir 2>/dev/null)
--  if test $? -ne 0; then
--    AC_MSG_ERROR([cannot find include directory with nss-config])
--  fi
--  nspr_includes=-I$(nspr-config --includedir 2>/dev/null)
--  if test $? -ne 0; then
--    AC_MSG_ERROR([cannot find include directory with nspr-config])
--  fi
-+  nss_includes='-I/usr/include/nss -I/usr/include/nspr'
-   old_CFLAGS="$CFLAGS"
-   CFLAGS="$CFLAGS $nss_includes $nspr_includes"
-   AC_COMPILE_IFELSE([AC_LANG_PROGRAM([typedef int PRBool;
---- glibc-2.26/crypt/Makefile~ 2017-12-04 08:35:09.000000000 +0100
-+++ glibc-2.26/crypt/Makefile  2017-12-04 08:41:17.325468766 +0100
-@@ -38,7 +38,7 @@ endif
- ifeq ($(nss-crypt),yes)
- nss-cpp-flags := -DUSE_NSS \
--  -I$(shell nss-config --includedir) -I$(shell nspr-config --includedir)
-+  -I/usr/include/nss -I/usr/include/nspr
- CPPFLAGS-sha256-crypt.c += $(nss-cpp-flags)
- CPPFLAGS-sha512-crypt.c += $(nss-cpp-flags)
- CPPFLAGS-md5-crypt.c += $(nss-cpp-flags)
-
diff --git a/glibc-pr13013.patch b/glibc-pr13013.patch
deleted file mode 100644 (file)
index e654fb1..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-https://bugs.gentoo.org/391673
-http://sourceware.org/bugzilla/show_bug.cgi?id=13013
-
-2011-07-21  Aurelien Jarno  <aurel32@debian.org>
-
-       * resolv/res_query.c(__libc_res_nquery): Assign hp and hp2 
-       depending n and resplen2 to catch cases where answer 
-       equals answerp2.
-
-diff --git a/resolv/res_query.c b/resolv/res_query.c
-index 2f7cfaa..405fa68 100644
---- a/resolv/res_query.c
-+++ b/resolv/res_query.c
-@@ -122,6 +122,7 @@ __libc_res_nquery(res_state statp,
-                 int *resplen2)
- {
-       HEADER *hp = (HEADER *) answer;
-+      HEADER *hp2;
-       int n, use_malloc = 0;
-       u_int oflags = statp->_flags;
-@@ -239,26 +240,25 @@ __libc_res_nquery(res_state statp,
-         /* __libc_res_nsend might have reallocated the buffer.  */
-         hp = (HEADER *) *answerp;
--      /* We simplify the following tests by assigning HP to HP2.  It
--         is easy to verify that this is the same as ignoring all
--         tests of HP2.  */
--      HEADER *hp2 = answerp2 ? (HEADER *) *answerp2 : hp;
--
--      if (n < (int) sizeof (HEADER) && answerp2 != NULL
--          && *resplen2 > (int) sizeof (HEADER))
-+      /* We simplify the following tests by assigning HP to HP2 or
-+         vice versa.  It is easy to verify that this is the same as
-+         ignoring all tests of HP or HP2.  */
-+      if (answerp2 == NULL || *resplen2 < (int) sizeof (HEADER))
-         {
--          /* Special case of partial answer.  */
--          assert (hp != hp2);
--          hp = hp2;
-+          hp2 = hp;
-         }
--      else if (answerp2 != NULL && *resplen2 < (int) sizeof (HEADER)
--               && n > (int) sizeof (HEADER))
-+      else
-         {
--          /* Special case of partial answer.  */
--          assert (hp != hp2);
--          hp2 = hp;
-+          hp2 = (HEADER *) *answerp2;
-+          if (n < (int) sizeof (HEADER))
-+            {
-+              hp = hp2;
-+            }
-         }
-+      /* Make sure both hp and hp2 are defined */
-+      assert((hp != NULL) && (hp2 != NULL));
-+
-       if ((hp->rcode != NOERROR || ntohs(hp->ancount) == 0)
-           && (hp2->rcode != NOERROR || ntohs(hp2->ancount) == 0)) {
- #ifdef DEBUG
index 89576e5e8b6d4161202fb18fd4b7df9bc734f21a..8d3693300240a9c242bf2169649664e6d87c55e4 100644 (file)
@@ -71,8 +71,6 @@ Patch4:               %{name}-no-bash-nls.patch
 
 Patch6:                %{name}-paths.patch
 
-Patch8:                %{name}-missing-nls.patch
-Patch9:                %{name}-nss_include_dirs.patch
 Patch10:       %{name}-info.patch
 Patch11:       %{name}-autoconf.patch
 
@@ -953,9 +951,6 @@ exit 1
 
 %patch6 -p1
 
-%patch8 -p1
-%patch9 -p1
-
 %patch10 -p1
 %patch11 -p1
 
This page took 0.320217 seconds and 4 git commands to generate.