]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- rel 3; Don't crash on unresolved weak symbol reference.
[packages/glibc.git] / glibc.spec
index 27c44e1dd88c4180feedd9b30da0ddcdbed40925..e914515a38afae8dca73802e8d42c5eaf75dca72 100644 (file)
@@ -1,3 +1,10 @@
+# TODO:
+# - look at locale fixes/updates in bugzilla
+# - no more chicken-egg problem (postshell is no more dynamically linked with libc), remove SONAME symlinks? see files section.
+# [OLD]
+# - localedb-gen man pages(?)
+# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
+#   debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
 # min_kernel   (default is 2.6.12)
@@ -7,13 +14,6 @@
 %bcond_without localedb        # don't build localedb-all (is time consuming)
 %bcond_with    cross           # build using crossgcc (without libgcc_eh)
 #
-# TODO:
-# - look at locale fixes/updates in bugzilla
-# - no more chicken-egg problem (postshell is no more dynamically linked with libc), remove SONAME symlinks? see files section.
-# [OLD]
-# - localedb-gen man pages(?)
-# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
-#   debug/backtrace-tst(SEGV)  fail on alpha
 %{!?min_kernel:%global         min_kernel      2.6.12}
 
 %ifarch sparc64
@@ -32,13 +32,14 @@ Summary(ru.UTF-8):  GNU libc версии
 Summary(tr.UTF-8):     GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
-Version:       2.11
-Release:       6
+Version:       2.12
+Release:       3
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       ftp://sources.redhat.com/pub/glibc/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 2c990f97e9ff9fb1c3c85fe826e991b9
+# Source0:     ftp://sources.redhat.com/pub/glibc/releases/%{name}-%{version}.tar.bz2
+Source0:       %{name}-%{version}.tar.bz2
+# Source0-md5: 37526f1337474dffcf9cda5292957c24
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -69,6 +70,8 @@ Patch22:      %{name}-with-stroke.patch
 Patch23:       %{name}-pt_pax.patch
 Patch25:       %{name}-cv_gnu89_inline.patch
 Patch26:       %{name}-posix-sh.patch
+Patch27:       %{name}-i686.patch
+Patch28:       %{name}-dl.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf
@@ -88,7 +91,6 @@ BuildRequires:        linux-libc-headers >= %{llh_version}
 BuildRequires: nss-devel >= 1:3.12.3
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.3-0.20030610.28
-BuildRequires: rpm-perlprov
 BuildRequires: rpmbuild(macros) >= 1.413
 BuildRequires: sed >= 4.0.5
 BuildRequires: texinfo
@@ -105,8 +107,8 @@ Obsoletes:  glibc64
 %endif
 Suggests:      localedb
 Suggests:      tzdata
-Conflicts:     SysVinit < 2.86-11
 Conflicts:     %{name}-misc < %{epoch}:%{version}-%{release}
+Conflicts:     SysVinit < 2.86-11
 Conflicts:     kernel < %{min_kernel}
 Conflicts:     kernel24
 Conflicts:     kernel24-smp
@@ -886,7 +888,7 @@ Un juguete.
 Zabawka.
 
 %prep
-%setup -q 
+%setup -q
 #%patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -909,6 +911,8 @@ Zabawka.
 %patch23 -p0
 %patch25 -p1
 %patch26 -p1
+%patch27 -p1
+%patch28 -p1
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
@@ -1084,21 +1088,25 @@ done
 #   sr@ije (use LANGUAGE=sr_ME@ije/sr_RS@ije) (gnome)
 #
 # To be added when they become supported by glibc:
-#   az_IR (gtk+)
-#   co (vlc)
-#   dv (iso-codes)
-#   gn (gn_BR in gnome, maybe gn_PY)
-#   la (deluge, gnome, others; patch needed, won't be officially supported)
-#   my (gaim)
+#   az_IR (gtk+2)
+#   bal (newt,pessulus)
+#   bem (alacarte)
+#   ckb [or ku_IQ/ku_IR] (vlc,miro)
+#   co  (vlc)
+#   gn  (gn_BR in gnome, maybe gn_PY)
 #   bal (newt)
 #   haw (iso-codes)
 #   ilo (kudzu)
+#   io  (gtk+2, gnome, alacarte)
+#   jv  (gmpc)
 #   kok (iso-codes)
+#   lb  (geany,miro)
 #   man (ccsm; incorrectly named md)
 #   mus (bluez-gnome)
-#   sco (gnomad2)
+#   sco (gnomad2, picard)
+#   swg (sim)
 #   syr (iso-codes)
-#   ven (kalarm)
+#   tet (vlc)
 #
 # bn is used for bn_BD or bn_IN? Assume bn_IN as nothing for bn_BD appeared
 # till now.
@@ -1108,15 +1116,15 @@ done
 #   sv tr zh_CN zh_TW
 #
 for i in aa aa@saaho af am an ang ar ar_TN as ast az be@alternative be@latin \
-       bg bn bn_IN br bs byn ca@valencia crh csb cy de_AT de_CH dz en \
+       bg bn bn_IN br bs byn ca@valencia crh csb cy de_AT de_CH dv dz en \
        en@boldquot en@quot en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
-       hi hne hsb hy ia id ig ik is it_CH iu ka kk kl km kn ks ku kw ky lg li \
-       lo lt lv mai mg mi mk ml mn mr ms mt nds ne nl_BE nn nr nso oc om or \
-       pa pap ps pt rm ro sa sc se si sid sl so sq sr sr@Latn sr@ije sr@latin \
-       ss st sw ta te tg th ti tig tk tl tlh tn ts tt ug uk ur uz uz@cyrillic \
-       ve vi wa wal wo xh yi yo zh_HK zu; do
+       hi hne hsb hy ia id ig ik is it_CH iu ka kk kl km kn ks ku kw ky la \
+       lg li lo lt lv mai mg mi mk ml mn mr ms mt my nds ne nl_BE nn nr nso \
+       oc om or pa pap ps pt ps rm ro sa sc se si sid sl so sq sr sr@Latn \
+       sr@ije sr@latin ss st sw ta te tg th ti tig tk tl tlh tn ts tt ug uk \
+       ur uz uz@cyrillic ve vi wa wal wo xh yi yo zh_HK zu; do
        if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES ]; then
                install -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES
                # use lang() tags with ll_CC@variant (stripping charset and @quot|@boldquot)
@@ -1127,7 +1135,7 @@ done
 
 # LC_TIME category, used for localized date formats (at least by coreutils)
 for i in af be bg ca cs da de el en es et eu fi fr ga gl hu id it ja ko lg lt \
-       ms nb nl pl pt pt_BR ru rw sk sl sv tr uk vi zh_CN zh_TW; do
+       ms nb nl pl pt pt_BR ro ru rw sk sl sv tr uk vi zh_CN zh_TW; do
        if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i ]; then
                echo "%lang($lang) %{_datadir}/locale/$i" >> glibc.lang
        fi
@@ -1172,7 +1180,12 @@ rm -rf $RPM_BUILD_ROOT
 %postun        memusage -p /sbin/ldconfig
 
 %post -n localedb-src
-/usr/bin/localedb-gen || :
+SUPPORTED_LOCALES=
+[ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
+[ -f /etc/sysconfig/localedb ] && . /etc/sysconfig/localedb
+if [ "$SUPPORTED_LOCALES" ]; then
+       localedb-gen || :
+fi
 
 %post devel    -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
@@ -1433,9 +1446,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libcrypt-%{version}.so
 %ifarch alpha
-%ghost %attr(755,root,root) /%{_lib}/libcrypt.so.1.1
+%attr(755,root,root) %ghost /%{_lib}/libcrypt.so.1.1
 %else
-%ghost %attr(755,root,root) /%{_lib}/libcrypt.so.1
+%attr(755,root,root) %ghost /%{_lib}/libcrypt.so.1
 %endif
 
 %files -n ldconfig
@@ -1453,7 +1466,7 @@ fi
 %lang(pt) %{_mandir}/pt/man8/ldconfig.8*
 %lang(ru) %{_mandir}/ru/man8/ldconfig.8*
 %dir %attr(700,root,root) /var/cache/ldconfig
-%ghost %attr(600,root,root) /var/cache/ldconfig/aux-cache
+%attr(600,root,root) %ghost /var/cache/ldconfig/aux-cache
 
 %files -n nss_compat
 %defattr(644,root,root,755)
This page took 0.03873 seconds and 4 git commands to generate.