]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- rel 6; upstream fixes
[packages/glibc.git] / glibc.spec
index b3f9763892636f5b5f6ddba93c0ac10d193cb92b..e774e425124fd8a9f49c3bc115a78ee92ae716b5 100644 (file)
@@ -31,7 +31,7 @@
 %undefine      with_cet
 %endif
 
-%define                core_version    2.29
+%define                core_version    2.31
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -45,12 +45,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       7
+Release:       6
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: e6c279d5b2f0736f740216f152acf974
+# Source0-md5: 78a720f17412f3c3282be5a6f3363ec6
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -62,7 +62,7 @@ Source7:      %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
-# Patch0-md5:  1846996a893234311f8193725754f972
+# Patch0-md5:  ade74d0facf281aea8c3e7420699f738
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -71,8 +71,6 @@ Patch4:               %{name}-no-bash-nls.patch
 
 Patch6:                %{name}-paths.patch
 
-Patch8:                %{name}-missing-nls.patch
-Patch9:                %{name}-nss_include_dirs.patch
 Patch10:       %{name}-info.patch
 Patch11:       %{name}-autoconf.patch
 
@@ -86,7 +84,6 @@ Patch18:      %{name}-locale_fixes.patch
 Patch19:       %{name}-ZA_collate.patch
 
 Patch23:       %{name}-pt_pax.patch
-Patch24:       %{name}-resolv.patch
 
 # http://pkgs.fedoraproject.org/cgit/rpms/glibc.git/plain/glibc-c-utf8-locale.patch
 Patch27:       %{name}-c-utf8-locale.patch
@@ -100,16 +97,17 @@ BuildRequires:     automake
 BuildRequires: binutils >= 2:2.29
 BuildRequires: bison >= 2.7
 %{!?with_cross:BuildRequires:  dietlibc-static}
-BuildRequires: gawk
+BuildRequires: gawk >= 3.1.2
 %if %{with cet}
 BuildRequires: gcc >= 6:8.0
 %else
-BuildRequires: gcc >= 6:5.0
+BuildRequires: gcc >= 6:6.2
 %endif
 %{?with_memusage:BuildRequires:        gd-devel >= 2.0.1}
 BuildRequires: gettext-tools >= 0.10.36
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 BuildRequires: linux-libc-headers >= %{llh_version}
+BuildRequires: make >= 1:4.0
 %{?with_nss_crypt:BuildRequires:       nss-devel >= 1:3.15.1-2}
 BuildRequires: perl-base
 BuildRequires: python3 >= 1:3.4
@@ -117,7 +115,7 @@ BuildRequires:      python3-modules >= 1:3.4
 BuildRequires: rpm-build >= 4.3-0.20030610.28
 BuildRequires: rpmbuild(macros) >= 1.567
 BuildRequires: sed >= 4.0.5
-BuildRequires: texinfo
+BuildRequires: texinfo >= 4.7
 Requires:      %{name}-ld = %{epoch}:%{version}-%{release}
 Requires:      filesystem
 Requires:      uname(release) >= %{min_kernel}
@@ -142,11 +140,13 @@ Conflicts:        kernel24
 Conflicts:     kernel24-smp
 Conflicts:     ld.so < 1.9.9-10
 Conflicts:     man-pages < 4.00
+Conflicts:     openssh-server < 2:8.2p1-1
 Conflicts:     poldek < 0.30.1-9
 Conflicts:     rc-scripts < 0.3.1-13
 Conflicts:     rpm < 4.1
+Conflicts:     util-linux < 2.35.1-2
 Conflicts:     xorg-driver-video-nvidia-libs < 1:295.33
-ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32 ia64 alpha s390 s390x sparc sparc64 sparcv9 ppc ppc64 armv5tel
+ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32 ia64 alpha s390 s390x sparc sparc64 sparcv9 ppc ppc64 armv5tel aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # avoid -s here (ld.so must not be stripped to allow any program debugging)
@@ -954,13 +954,10 @@ exit 1
 
 %patch6 -p1
 
-%patch8 -p1
-%patch9 -p1
-
 %patch10 -p1
 %patch11 -p1
 
-%patch14 -p0
+%patch14 -p1
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
@@ -968,7 +965,6 @@ exit 1
 %patch19 -p1
 
 %patch23 -p0
-%patch24 -p1
 
 %patch27 -p1
 
@@ -1023,6 +1019,15 @@ AWK="gawk" \
        --with-selinux%{!?with_selinux:=no} \
        --with-tls
 
+# hack: libgd (used by memusagestat) requires librt, which is built after malloc/ subdir.
+# First build all without libgd-dependent components (LIBGD=no)...
+%{__make} \
+       AWK="gawk" \
+       complocaledir=%{_prefix}/lib/locale \
+       sLIBdir=%{_libdir} \
+       LIBGD=no
+
+# ...then, when librt is ready, rerun make to build memusagestat
 %{__make} \
        AWK="gawk" \
        complocaledir=%{_prefix}/lib/locale \
@@ -1146,7 +1151,6 @@ done
 # NOTES:
 # Languages not supported by glibc locales, but usable via $LANGUAGE:
 #   ang - Old English (gtk+, gnome)
-#   ca@valencia (gtk+, gnome; as ca_ES@valencia in FileZilla; locale exists in Debian)
 #   en@shaw - English with Shavian alphabet (gnome)
 #   la - Latin
 #   tlh - Klingon (bzflag)
@@ -1166,13 +1170,15 @@ done
 #   guc    (gtk-vnc)
 #   haw    (iso-codes, stellarium)
 #   hrx    (stellarium)
+#   ie     (xfce, cinnamon)
 #   ilo    (kudzu, libosinfo, libreport)
 #   io     (alacarte, gtk+2, gnome, iso-codes)
 #   jam    (iso-codes)
-#   jv     (avant-window-navigator, gmpc, kdesudo, mate)
+#   jv     (avant-window-navigator, gmpc, kdesudo, mate, cinnamon)
 #   ki     (iso-codes)
 #   kok@latin  (inkscape)
 #   kmr    (vlc)
+#   ksw    (cinnamon)
 #   ku_IQ  (mate)
 #   kv     (iso-codes)
 #   kw@kkcor, kw@uccor (libosinfo - currently empty) - add as supported variants when non-empty?
@@ -1182,12 +1188,14 @@ done
 #   mus    (bluez-gnome)
 #   na     (iso-codes)
 #   nah    (iso-codes, mate)
+#   nap    (cinnamon)
 #   nqo           (mate)
 #   nv     (iso-codes)
 #   pi     (iso-codes)
 #   pms    (deluge, mate-tweak)
+#   rue    (cinnamon)
 #   sat@deva[nagari]  (inkscape)
-#   sco    (gnomad2, mate, picard, stellarium)
+#   sco    (gnomad2, mate, picard, stellarium, cinnamon)
 #   son    (gtkspell3, iso-codes)
 #   su     (terminator)
 #   swg    (sim)
@@ -1232,6 +1240,7 @@ done
 # li=li_NL
 # ln=ln_CD
 # lo=lo_LA
+# mjw=mjw_IN
 # nds=nds_DE
 # nl=nl_NL
 # om=om_ET
@@ -1265,12 +1274,12 @@ done
 for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR \
        be@latin be@tarask bem bg bho bn bn_IN bo br brx bs byn \
        ca@valencia ce chr ckb cmn crh csb cv cy de_AT de_CH doi dv dz \
-       en en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo \
+       en en@boldquot en@quot en@shaw en_AU en_CA en_IE en_NZ en_US en_ZA eo \
        es_AR es_CL es_CO es_CR es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY es_VE \
        et eu fa ff fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv \
        ha he hi hne ht hsb hy ia id ig ik is it_CH iu \
        ka kab kg kk kl km kn kok ks ks@devanagari ku kw ky la lb lg li ln lo lt lv \
-       mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso oc om or \
+       mai mg mhr mi mjw mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso oc om or \
        pa pap ps pt ps quz rm ro \
        sa sat sc sd sd@devanagari se shn si sid sl so sq \
        sr sr@Latn sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw szl \
@@ -1782,7 +1791,11 @@ fi
 %ifarch ppc64 s390x
 %attr(755,root,root) /%{_lib}/ld64.so.1
 %endif
-%ifnarch %{ix86} sparc sparcv9 sparc64 alpha sh ia64 %{x8664} x32 ppc64 s390x %{arm}
+%ifarch aarch64
+%attr(755,root,root) /lib/ld-linux-aarch64.so.1
+%attr(755,root,root) /%{_lib}/ld-linux-aarch64.so.1
+%endif
+%ifnarch %{ix86} sparc sparcv9 sparc64 alpha sh ia64 %{x8664} x32 ppc64 s390x %{arm} aarch64
 %attr(755,root,root) /%{_lib}/ld.so.1
 %endif
 %attr(755,root,root) /sbin/ldconfig
@@ -1879,16 +1892,13 @@ fi
 %{_libdir}/libc.so
 %{_libdir}/libpthread.so
 # static-only libs
-%ifarch %{x8664} x32
-%{_libdir}/libmvec_nonshared.a
-%endif
 %{_libdir}/libc_nonshared.a
 %{_libdir}/libg.a
 %ifarch alpha ppc sparc
 %{_libdir}/libnldbl_nonshared.a
 %endif
 %{_libdir}/librpcsvc.a
-%ifarch %{ix86} %{x8664} x32 ppc ppc64 s390 s390x sparc sparcv9 sparc64
+%ifarch %{ix86} %{x8664} x32 ppc ppc64 s390 s390x sparc sparcv9 sparc64 aarch64
 # ABI-dependent headers
 %{_includedir}/gnu/stubs-*.h
 %endif
@@ -1901,6 +1911,8 @@ fi
 %endif
 %{_includedir}/arpa
 %{_includedir}/bits
+%dir %{_includedir}/finclude
+%{_includedir}/finclude/math-vector-fortran.h
 %dir %{_includedir}/gnu
 %{_includedir}/gnu/lib*.h
 %{_includedir}/gnu/stubs.h
This page took 0.047067 seconds and 4 git commands to generate.