]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- rel 11; fixes CVE-2017-17426, CVE-2017-1000408, CVE-2017-1000409
[packages/glibc.git] / glibc.spec
index 3def48b1471bd7249699cb487b4adbfce83c5b90..e511003afd148b5afe45dd0b695962bb38295ea1 100644 (file)
@@ -8,7 +8,7 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 3.4.0 except for x86/x86_64 where 2.6.32 suffices)
+# min_kernel   (default is 3.4.0 except for x86/x86_64 where 3.2.0 suffices)
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
@@ -18,7 +18,7 @@
 %bcond_with    bash_nls        # use bash NLS in shell scripts (ldd, sotruss); restores /bin/bash dep
 #
 %ifarch %{ix86} %{x8664}
-%{!?min_kernel:%global         min_kernel      2.6.32} 
+%{!?min_kernel:%global         min_kernel      3.2.0}
 %else
 %{!?min_kernel:%global         min_kernel      3.4.0}
 %endif
@@ -27,7 +27,7 @@
 %undefine      with_memusage
 %endif
 
-%define                core_version    2.24
+%define                core_version    2.26
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -41,12 +41,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       4
+Release:       11
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 97dc5517f92016f3d70d83e3162ad318
+# Source0-md5: 102f637c3812f81111f48f2427611be1
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -58,7 +58,7 @@ Source7:      %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
-# Patch0-md5:  db84fc2f3b428f64896dde0c7b0d8856
+# Patch0-md5:  870116e19a36b22ce35806d01fd75f26
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -66,7 +66,7 @@ Patch3:               %{name}-crypt-blowfish.patch
 Patch4:                %{name}-no-bash-nls.patch
 Patch5:                %{name}-sparc-softfp-gcc.patch
 Patch6:                %{name}-paths.patch
-Patch7:                1070_all_glibc-fadvise64_64.patch
+
 Patch8:                %{name}-missing-nls.patch
 Patch9:                %{name}-nss_include_dirs.patch
 Patch10:       %{name}-info.patch
@@ -80,7 +80,6 @@ Patch17:      %{name}-morelocales.patch
 # fixes mostly pending for upstream merge
 Patch18:       %{name}-locale_fixes.patch
 Patch19:       %{name}-ZA_collate.patch
-Patch20:       %{name}-thread_start.patch
 
 Patch23:       %{name}-pt_pax.patch
 
@@ -89,8 +88,6 @@ Patch27:      %{name}-c-utf8-locale.patch
 
 Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       glibc-rh1124987.patch
-
-Patch38:       1055_all_glibc-resolv-dynamic.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf >= 2.69
@@ -386,12 +383,16 @@ El antiguo módulo NYS NSS de glibc
 Stary moduł NYS NSS glibc.
 
 %package -n nss_db
-Summary:       Berkeley DB NSS glibc module
+Summary:       NSS glibc module that uses hashed key-value database
+Summary(pl.UTF-8):     Moduł NSS glibc wykorzystujący haszowaną bazę danych klucz-wartość
 Group:         Base
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description -n nss_db
-Berkeley DB NSS glibc module.
+NSS glibc module that uses hashed key-value database.
+
+%description -n nss_db -l pl.UTF-8
+Moduł NSS glibc wykorzystujący haszowaną bazę danych klucz-wartość.
 
 %package -n nss_dns
 Summary:       BIND NSS glibc module
@@ -945,8 +946,8 @@ kodowania danych z poziomu dowolnego programu.
 %prep
 %setup -q
 
-%if "%{min_kernel}" < "2.6.32"
-echo "Minimal supported kernel is 2.6.32" >&2
+%if "%{min_kernel}" < "3.2.0"
+echo "Minimal supported kernel is 3.2.0" >&2
 exit 1
 %endif
 
@@ -957,9 +958,9 @@ exit 1
 %{!?with_bash_nls:%patch4 -p1}
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
+
 %patch8 -p1
-%patch9 -p0
+%patch9 -p1
 
 %patch10 -p1
 %patch11 -p1
@@ -970,7 +971,6 @@ exit 1
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
-%patch20 -p1
 
 %patch23 -p0
 
@@ -979,8 +979,6 @@ exit 1
 %patch29 -p1
 %patch30 -p1
 
-%patch38 -p1
-
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
@@ -1014,9 +1012,12 @@ AWK="gawk" \
        --enable-hidden-plt \
        --enable-kernel="%{min_kernel}" \
        --enable-nss-crypt%{!?with_nss_crypt:=no} \
+       --enable-obsolete-nsl \
        --enable-obsolete-rpc \
        --enable-profile \
+       --enable-stack-protector=strong \
        --enable-stackguard-randomization \
+       --enable-tunables \
        --with-binutils=$(pwd)/alt-tools \
        --with-bugurl=http://bugs.pld-linux.org/ \
        --with-headers=%{_includedir} \
@@ -1128,7 +1129,7 @@ cp -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/nscd.conf
 rm -rf documentation
 install -d documentation
 
-for f in ChangeLog.old DESIGN-{condvar,rwlock,systemtap-probes}.txt TODO{,-kernel,-testing}; do
+for f in ChangeLog.old DESIGN-systemtap-probes.txt TODO{,-kernel,-testing}; do
        cp -af nptl/$f documentation/$f.nptl
 done
 cp -af crypt/README.ufc-crypt ChangeLog* documentation
@@ -1156,22 +1157,27 @@ done
 #   aln    (vlc, libreport)
 #   bal    (libosinfo, libreport, newt, pessulus)
 #   cgg    (vlc)
-#   co     (vlc)
+#   co     (FileZilla, vlc)
 #   frp    (xfce, lxlauncher, mate)
 #   gn     (gn_BR in gnome, maybe gn_PY)
+#   guc    (gtk-vnc)
 #   haw    (iso-codes, stellarium)
 #   hrx    (stellarium)
 #   ilo    (kudzu, libosinfo, libreport)
 #   io     (gtk+2, gnome, alacarte)
 #   jv     (gmpc, avant-window-navigator, kdesudo, mate)
+#   kab    (FileZilla)
+#   kok@latin  (inkscape)
 #   kmr    (vlc)
 #   ku_IQ  (mate)
 #   kw@kkcor, kw@uccor (libosinfo - currently empty) - add as supported variants when non-empty?
 #   man    (ccsm; incorrectly named md)
+#   mni@beng[ali]  (inkscape)
 #   mus    (bluez-gnome)
 #   nah    (mate)
 #   nqo           (mate)
 #   pms    (deluge, mate-tweak)
+#   sat@deva[nagari]  (inkscape)
 #   sco    (gnomad2, picard, stellarium, mate)
 #   son    (gtkspell3)
 #   su     (terminator)
@@ -1209,8 +1215,12 @@ done
 # fy=fy_NL
 # gez=gez_ET (?)
 # it=it_IT
+# ks=ks_IN
+# ks@devanagari=ks_IN@devanagari
 # ku=ku_TR
 # li=li_NL
+# ln=ln_CD
+# lo=lo_LA
 # nds=nds_DE
 # nl=nl_NL
 # om=om_ET
@@ -1220,6 +1230,7 @@ done
 # quz=quz_PE
 # ru=ru_RU
 # sd=sd_IN
+# sd@devanagari=sd_IN@devanagari
 # shn=shn_MM
 # so=so_SO
 # sr=sr_RS [cyrillic]
@@ -1244,9 +1255,9 @@ for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR be@latin be@ta
        en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa ff fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
-       hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ku kw ky la lb \
-       lg li lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
-       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se shn si sid sl so sq sr sr@Latn szl tl \
+       hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ks@devanagari ku kw ky la lb \
+       lg li ln lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
+       oc om or pa pap ps pt ps quz rm ro sa sat sc sd sd@devanagari se shn si sid sl so sq sr sr@Latn szl tl \
        sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw ta te tg th ti \
        tig tk tl tlh tn ts tt tt@iqtelif ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
        zh_HK zu; do
@@ -1884,7 +1895,7 @@ fi
 
 %files devel-doc
 %defattr(644,root,root,755)
-%doc documentation/* PROJECTS
+%doc documentation/*
 %{_infodir}/libc.info*
 
 %{_mandir}/man1/sprof.1*
@@ -1968,6 +1979,7 @@ fi
 %{_libdir}/libm.a
 %{_libdir}/libmcheck.a
 %ifarch %{x8664} x32
+%{_libdir}/libm-%{core_version}.a
 %{_libdir}/libmvec.a
 %endif
 %{_libdir}/libnsl.a
This page took 0.113903 seconds and 4 git commands to generate.