]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- update git patch
[packages/glibc.git] / glibc.spec
index 684263766fbf631d3c7e12474aa8cd56907ce0ae..df0651edf3525e63602ff31dec74f5c08453ea50 100644 (file)
@@ -8,7 +8,7 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 2.6.32)
+# min_kernel   (default is 3.4.0 except for x86/x86_64 where 2.6.32 suffices)
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
 %bcond_without nss_crypt       # disable crypt features based on Mozilla NSS library
 %bcond_with    bash_nls        # use bash NLS in shell scripts (ldd, sotruss); restores /bin/bash dep
 #
-%ifarch x32
-%{!?min_kernel:%global         min_kernel      3.4.0}
+%ifarch %{ix86} %{x8664}
+%{!?min_kernel:%global         min_kernel      2.6.32} 
 %else
-%{!?min_kernel:%global         min_kernel      2.6.32}
+%{!?min_kernel:%global         min_kernel      3.4.0}
 %endif
 
 %ifarch sparc64
 %undefine      with_memusage
 %endif
 
-%define                core_version    2.22
+%define                core_version    2.24
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -41,23 +41,24 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       14
+Release:       3
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: e51e02bf552a0a1fbbdc948fb2f5e83c
+# Source0-md5: 97dc5517f92016f3d70d83e3162ad318
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
 # from man-pages.spec --with tars
 Source5:       %{name}-man-pages.tar.xz
-# Source5-md5: 3a4eabb7d28db7d35d8204fdb471a863
+# Source5-md5: 82537aa7f6ee31dd782e7e085cc21018
 Source6:       %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
 Source9:       nscd.tmpfiles
-# git diff glibc-2.22..release/2.22/master
+# use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
+# Patch0-md5:  db84fc2f3b428f64896dde0c7b0d8856
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -70,7 +71,6 @@ Patch8:               %{name}-missing-nls.patch
 Patch9:                %{name}-nss_include_dirs.patch
 Patch10:       %{name}-info.patch
 Patch11:       %{name}-autoconf.patch
-Patch12:       glibc-CVE-2015-7547.patch
 
 Patch14:       %{name}-sparc-errno_fix.patch
 Patch15:       %{name}-new-charsets.patch
@@ -81,19 +81,19 @@ Patch17:    %{name}-morelocales.patch
 Patch18:       %{name}-locale_fixes.patch
 Patch19:       %{name}-ZA_collate.patch
 Patch20:       %{name}-thread_start.patch
-Patch22:       %{name}-with-stroke.patch
+
 Patch23:       %{name}-pt_pax.patch
-Patch25:       %{name}-cv_gnu89_inline.patch
-Patch27:       %{name}-locale-C.patch.xz
-# Patch27-md5: 34ebe52a2afb923e33af0fb7c541f540
-Patch28:       %{name}-locale-C-pld.patch
+
+# http://pkgs.fedoraproject.org/cgit/rpms/glibc.git/plain/glibc-c-utf8-locale.patch
+Patch27:       %{name}-c-utf8-locale.patch
+
 Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       glibc-rh1124987.patch
 
 Patch38:       1055_all_glibc-resolv-dynamic.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 %ifarch alpha
 BuildRequires: binutils >= 2:2.17.50.0.7
@@ -102,7 +102,7 @@ BuildRequires:      binutils >= 2:2.15.90.0.3
 %endif
 %{!?with_cross:BuildRequires:  dietlibc-static}
 BuildRequires: gawk
-BuildRequires: gcc >= 6:4.6
+BuildRequires: gcc >= 6:4.7
 %{?with_memusage:BuildRequires:        gd-devel >= 2.0.1}
 BuildRequires: gettext-tools >= 0.10.36
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
@@ -499,6 +499,12 @@ Provides:  %{name}-devel(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 Provides:      %{name}-devel(ix86) = %{epoch}:%{version}-%{release}
 %endif
 Obsoletes:     libiconv-devel
+%ifarch %{x8664}
+# see http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2016-May/024902.html
+%if "%(rpm -q --qf '%{E}:%{V}' binutils)" >= "4:2.26"
+Conflicts: binutils < 4:2.26
+%endif
+%endif
 
 %description devel
 To develop programs which use the standard C libraries (which nearly
@@ -974,7 +980,6 @@ exit 1
 
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
 
 %patch14 -p0
 %patch15 -p1
@@ -983,12 +988,11 @@ exit 1
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
-%patch22 -p1
+
 %patch23 -p0
 
-%patch25 -p1
 %patch27 -p1
-%patch28 -p1
+
 %patch29 -p1
 %patch30 -p1
 
@@ -1038,7 +1042,7 @@ AWK="gawk" \
 
 %{__make} \
        AWK="gawk" \
-       localedir=%{_prefix}/lib/locale \
+       complocaledir=%{_prefix}/lib/locale \
        sLIBdir=%{_libdir}
 
 cd ..
@@ -1063,14 +1067,14 @@ cd builddir
 env LANGUAGE=C LC_ALL=C \
 %{__make} install \
        install_root=$RPM_BUILD_ROOT \
-       localedir=%{_prefix}/lib/locale \
+       complocaledir=%{_prefix}/lib/locale \
        infodir=%{_infodir} \
        mandir=%{_mandir}
 
 %if %{with localedb}
 env LANGUAGE=C LC_ALL=C \
 %{__make} localedata/install-locales \
-       localedir=%{_prefix}/lib/locale \
+       complocaledir=%{_prefix}/lib/locale \
        install_root=$RPM_BUILD_ROOT
 %else
 install -d $RPM_BUILD_ROOT%{_prefix}/lib/locale
@@ -1139,7 +1143,7 @@ cp -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/nscd.conf
 rm -rf documentation
 install -d documentation
 
-for f in ChangeLog.old DESIGN-{barrier,condvar,rwlock,systemtap-probes}.txt TODO{,-kernel,-testing}; do
+for f in ChangeLog.old DESIGN-{condvar,rwlock,systemtap-probes}.txt TODO{,-kernel,-testing}; do
        cp -af nptl/$f documentation/$f.nptl
 done
 cp -af crypt/README.ufc-crypt ChangeLog* documentation
@@ -1164,31 +1168,32 @@ done
 #
 # To be added when they become supported by glibc:
 #   ach    (vlc, libreport)
-#   ak     (gtkspell3)
 #   aln    (vlc, libreport)
 #   bal    (libosinfo, libreport, newt, pessulus)
 #   cgg    (vlc)
 #   co     (vlc)
-#   frp    (xfce, lxlauncher)
+#   frp    (xfce, lxlauncher, mate)
 #   gn     (gn_BR in gnome, maybe gn_PY)
 #   haw    (iso-codes, stellarium)
 #   hrx    (stellarium)
 #   ilo    (kudzu, libosinfo, libreport)
 #   io     (gtk+2, gnome, alacarte)
-#   jv     (gmpc, avant-window-navigator, kdesudo, mate-desktop)
+#   jv     (gmpc, avant-window-navigator, kdesudo, mate)
 #   kmr    (vlc)
-#   ku_IQ  (mate-menus,mozo)
+#   ku_IQ  (mate)
 #   kw@kkcor, kw@uccor (libosinfo - currently empty) - add as supported variants when non-empty?
 #   man    (ccsm; incorrectly named md)
 #   mus    (bluez-gnome)
-#   nah    (mate-system-monitor)
-#   nqo           (mate-desktop)
-#   pms    (deluge)
-#   sco    (gnomad2, picard, stellarium)
+#   nah    (mate)
+#   nqo           (mate)
+#   pms    (deluge, mate-tweak)
+#   sco    (gnomad2, picard, stellarium, mate)
 #   son    (gtkspell3)
+#   su     (terminator)
 #   swg    (sim)
 #   syr    (iso-codes)
 #   tet    (vlc)
+#   tpi    (mate-tweak)
 #   tw     (libosinfo)
 #   vec    (mate-applet-indicator)
 #   wba    (libosinfo)
@@ -1199,6 +1204,7 @@ done
 #
 # Short forms (omitted country code, used instead of long form) for ambiguous or unclear cases:
 # aa=aa_ER
+# ak=ak_GH
 # anp=anp_IN
 # ar=common? (AE, BH, DZ, EG, IQ, JO, KW, LB, LY, MA, OM, QA, SA, SD, SY, TN, YE)
 # az=az_AZ
@@ -1229,6 +1235,7 @@ done
 # quz=quz_PE
 # ru=ru_RU
 # sd=sd_IN
+# shn=shn_MM
 # so=so_SO
 # sr=sr_RS [cyrillic]
 # sr@latin=sr_RS@latin
@@ -1247,14 +1254,14 @@ done
 #   be ca cs da de el en_GB es fi fr gl hr hu it ja ko nb nl pl pt_BR ru rw sk
 #   sv tr zh_CN zh_TW
 #
-for i in aa aa@saaho af am an ang anp ar ar_TN as ast az az_IR be@latin be@tarask bem \
+for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR be@latin be@tarask bem \
        bg bho bn bn_IN bo br brx bs byn ca@valencia ckb cmn crh csb cv cy de_AT de_CH doi dv dz en \
        en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa ff fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
        hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ku kw ky la lb \
        lg li lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
-       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se si sid sl so sq sr sr@Latn szl tl \
+       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se shn si sid sl so sq sr sr@Latn szl tl \
        sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw ta te tg th ti \
        tig tk tl tlh tn ts tt tt@iqtelif ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
        zh_HK zu; do
This page took 0.044965 seconds and 4 git commands to generate.