]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- added ia64
[packages/glibc.git] / glibc.spec
index 666b090203074af23934f5046812d016dff7a2ab..8709777887fdcb61607a3d5811a61065a910b004 100644 (file)
 # TODO:
 # - localedb-gen man pages(?)
 # - fix what trojan broke while upgreading (getaddrinfo-workaround)
-# - fix ld.so.conf (while upgrading glibc it do NOW mv ld.so.conf ld.so.conf.rpmsave)
-#
-# WARNING:
-#      posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
-#      in order to use this version!
 #
 
 %{!?min_kernel:%global          min_kernel      2.4.6}
 
 %if %{with nptl}
 # it seems that nptl uses cmpxchgl (available since i486) on x86
-%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
+%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
 %if "%{min_kernel}" < "2.6.0"
 %global                min_kernel      2.6.0
 %endif
 %endif
 
 %if %{with tls}
-%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
+%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
 %undefine      with_tls
 %endif
 %endif
 
-%define                llh_version     7:2.6.4.0
-%define                _snap           20040612
+%ifarch sparc64
+%undefine      with_memusage
+%endif
+
+%define                llh_version     7:2.6.6.0
+%define                _snap           20040707
 
 Summary:       GNU libc
 Summary(de):   GNU libc
@@ -58,13 +57,13 @@ Summary(tr):        GNU libc
 Summary(uk):   GNU libc ×ÅÒÓ¦§ 2.3
 Name:          glibc
 Version:       2.3.4
-Release:       0.%{_snap}.2%{?with_nptl:+nptl}
+Release:       0.%{_snap}.1%{?with_nptl:+nptl}%{!?with_nptl:%{?with_tls:+tls}}
 Epoch:         6
 License:       LGPL
 Group:         Libraries
 #Source0:      ftp://sources.redhat.com/pub/glibc/releases/%{name}-%{version}.tar.bz2
 Source0:       %{name}-%{_snap}.tar.bz2
-# Source0-md5: 60535f129045dc1176388e930b1998d2
+# Source0-md5: 7768ef6077b979c52f3c3bfd6da20c53
 #Source1:      ftp://sources.redhat.com/pub/glibc/releases/%{name}-linuxthreads-%{version}.tar.bz2
 #Source1:      %{name}-linuxthreads-2.3.3.tar.bz2
 Source2:       nscd.init
@@ -96,14 +95,12 @@ Patch13:    %{name}-kernel_includes.patch
 Patch14:       %{name}-includes.patch
 Patch15:       %{name}-soinit-EH_FRAME.patch
 Patch16:       %{name}-sparc-errno_fix.patch
-Patch17:       %{name}-make.patch
+Patch17:       %{name}-csu-quotes.patch
 Patch18:       %{name}-tests-noproc.patch
 Patch19:       %{name}-new-charsets.patch
 Patch20:       %{name}-sr_CS.patch
-Patch21:       %{name}-alpha-div.patch
-Patch22:       %{name}-alpha-relro.patch
-Patch23:       %{name}-sparc64-dl-machine.patch
-Patch24:       %{name}-csu-quotes.patch
+Patch21:       %{name}-sparc64-dl-machine.patch
+Patch22:       %{name}-tzfile-noassert.patch
 # PaX
 Patch30:       %{name}-pax_iconvconfig.patch
 Patch31:       %{name}-pax_dl-execstack.patch
@@ -142,7 +139,6 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                debugcflags     -O1 -g
 %ifarch sparc64
-%undefine      with_memusage
 %define        specflags_sparc64       -mvis -fcall-used-g6
 %define                _libdir                 /usr/lib64
 %endif
@@ -269,7 +265,7 @@ Summary:    Utilities and data used by glibc
 Summary(pl):   Narzêdzia i dane u¿ywane przez glibc
 Group:         Development/Libraries
 AutoReq:       false
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+PreReq:                %{name} = %{epoch}:%{version}-%{release}
 
 %description misc
 Utilities and data used by glibc.
@@ -510,8 +506,8 @@ Summary(ru):        GNU libc 
 Summary(tr):   Ölçüm desteði olan glibc
 Summary(uk):   GNU libc Ú Ð¦ÄÔÒÉÍËÏÀ ÐÒÏÆÁÊÌÅÒÁ
 Group:         Development/Libraries/Libc
-Obsoletes:     libc-profile
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Obsoletes:     libc-profile
 
 %description profile
 When programs are being profiled using gprof, they must use these
@@ -790,8 +786,6 @@ Statyczne 64-bitowe biblioteki GNU libc.
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
-%patch23 -p1
-%patch24 -p1
 
 %patch30 -p1
 %patch31 -p1
@@ -939,7 +933,7 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/libnss_*.so
 
 # strip ld.so with --strip-debug only (other ELFs are stripped by rpm):
 %ifnarch sparc64
-%{!?debug:strip -g -R .comment -R .note $RPM_BUILD_ROOT/%{_lib}/ld-%{version}.so}
+%{!?debug:strip -g -R .comment -R .note $RPM_BUILD_ROOT/%{_lib}/ld-*.so}
 %endif
 
 # Collect locale files and mark them with %%lang()
@@ -1104,7 +1098,7 @@ fi
 %attr(755,root,root) %{_bindir}/getent
 %attr(755,root,root) %{_bindir}/iconv
 %attr(755,root,root) %{_bindir}/ldd
-%ifnarch alpha ppc sparc64 amd64
+%ifnarch alpha amd64 ia64 ppc sparc64
 %attr(755,root,root) %{_bindir}/lddlibc4
 %endif
 %attr(755,root,root) %{_bindir}/locale
This page took 0.101063 seconds and 4 git commands to generate.