]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- kab[_DZ] and tpi[_PG] locales are supported now, add dirs; release 6
[packages/glibc.git] / glibc.spec
index df0651edf3525e63602ff31dec74f5c08453ea50..57b01ef58e0eb73a7da2d133e011d9db29a0cff2 100644 (file)
@@ -8,7 +8,7 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 3.4.0 except for x86/x86_64 where 2.6.32 suffices)
+# min_kernel   (default is 3.4.0 except for x86/x86_64 where 3.2.0 suffices)
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
 %bcond_with    cross           # make a cross build, skip native programs
 %bcond_without nss_crypt       # disable crypt features based on Mozilla NSS library
 %bcond_with    bash_nls        # use bash NLS in shell scripts (ldd, sotruss); restores /bin/bash dep
+%bcond_without cet             # Intel Control-flow Enforcement Technology (CET)
 #
 %ifarch %{ix86} %{x8664}
-%{!?min_kernel:%global         min_kernel      2.6.32} 
+%{!?min_kernel:%global         min_kernel      3.2.0}
 %else
 %{!?min_kernel:%global         min_kernel      3.4.0}
 %endif
 %ifarch sparc64
 %undefine      with_memusage
 %endif
+%ifnarch i686 %{x8664} x32
+%undefine      with_cet
+%endif
 
-%define                core_version    2.24
+%define                core_version    2.29
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -41,32 +45,32 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       3
+Release:       6
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 97dc5517f92016f3d70d83e3162ad318
+# Source0-md5: e6c279d5b2f0736f740216f152acf974
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
 # from man-pages.spec --with tars
 Source5:       %{name}-man-pages.tar.xz
-# Source5-md5: 82537aa7f6ee31dd782e7e085cc21018
+# Source5-md5: 78a8f7f8dfc63123f47a614e99136e61
 Source6:       %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
-# Patch0-md5:  db84fc2f3b428f64896dde0c7b0d8856
+# Patch0-md5:  1d84eeeeb1bd8d83ec0b3fa30401df0f
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
 Patch3:                %{name}-crypt-blowfish.patch
 Patch4:                %{name}-no-bash-nls.patch
-Patch5:                %{name}-sparc-softfp-gcc.patch
+
 Patch6:                %{name}-paths.patch
-Patch7:                1070_all_glibc-fadvise64_64.patch
+
 Patch8:                %{name}-missing-nls.patch
 Patch9:                %{name}-nss_include_dirs.patch
 Patch10:       %{name}-info.patch
@@ -80,40 +84,41 @@ Patch17:    %{name}-morelocales.patch
 # fixes mostly pending for upstream merge
 Patch18:       %{name}-locale_fixes.patch
 Patch19:       %{name}-ZA_collate.patch
-Patch20:       %{name}-thread_start.patch
 
 Patch23:       %{name}-pt_pax.patch
+Patch24:       %{name}-resolv.patch
 
 # http://pkgs.fedoraproject.org/cgit/rpms/glibc.git/plain/glibc-c-utf8-locale.patch
 Patch27:       %{name}-c-utf8-locale.patch
 
 Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       glibc-rh1124987.patch
-
-Patch38:       1055_all_glibc-resolv-dynamic.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
-%ifarch alpha
-BuildRequires: binutils >= 2:2.17.50.0.7
-%else
-BuildRequires: binutils >= 2:2.15.90.0.3
-%endif
+BuildRequires: binutils >= 2:2.29
+BuildRequires: bison >= 2.7
 %{!?with_cross:BuildRequires:  dietlibc-static}
 BuildRequires: gawk
-BuildRequires: gcc >= 6:4.7
+%if %{with cet}
+BuildRequires: gcc >= 6:8.0
+%else
+BuildRequires  gcc >= 6:5.0
+%endif
 %{?with_memusage:BuildRequires:        gd-devel >= 2.0.1}
 BuildRequires: gettext-tools >= 0.10.36
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 BuildRequires: linux-libc-headers >= %{llh_version}
 %{?with_nss_crypt:BuildRequires:       nss-devel >= 1:3.15.1-2}
 BuildRequires: perl-base
+BuildRequires: python3 >= 1:3.4
+BuildRequires: python3-modules >= 1:3.4
 BuildRequires: rpm-build >= 4.3-0.20030610.28
 BuildRequires: rpmbuild(macros) >= 1.567
 BuildRequires: sed >= 4.0.5
 BuildRequires: texinfo
-Requires(post):        ldconfig = %{epoch}:%{version}-%{release}
+Requires:      %{name}-ld = %{epoch}:%{version}-%{release}
 Requires:      filesystem
 Requires:      uname(release) >= %{min_kernel}
 Provides:      %{name}(%{_target_cpu}) = %{epoch}:%{version}-%{release}
@@ -122,7 +127,6 @@ Provides:   %{name}(ix86) = %{epoch}:%{version}-%{release}
 %endif
 Provides:      glibc(nptl)
 Provides:      glibc(tls)
-Provides:      rtld(GNU_HASH)
 Obsoletes:     glibc-common
 Obsoletes:     glibc-debug
 %ifarch %{x8664} sparc64 ppc64
@@ -181,6 +185,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoprov             .*\(GLIBC_PRIVATE\)
 %define                _noautoreq              .*\(GLIBC_PRIVATE\)
 
+# to avoid multi-arch conflicts on getconf/* files
+%define                _libexecdir             %{_libdir}
+
 %description
 Contains the standard libraries that are used by multiple programs on
 the system. In order to save disk space and memory, as well as to ease
@@ -294,6 +301,7 @@ Can be used on: Linux kernel >= %{min_kernel}.
 Summary:       Utilities and data used by glibc
 Summary(pl.UTF-8):     Narzędzia i dane używane przez glibc
 Group:         Applications/System
+Suggests:      libidn2 >= 2.0.5
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 %ifarch %{ix86}
 Conflicts:     %{name}(x32)
@@ -324,50 +332,34 @@ glibc library for crypt(3).
 %description libcrypt -l pl.UTF-8
 Biblioteka glibc z funkcją crypt(3).
 
-%package -n ldconfig
-Summary:       Create shared library cache and maintains symlinks
-Summary(de.UTF-8):     Erstellt ein shared library cache und verwaltet symlinks
-Summary(fr.UTF-8):     Crée un cache de bibliothčque partagée et gčre *.so
-Summary(pl.UTF-8):     Tworzenie cache'u bibliotek dynamicznych i ich dowiązań symbolicznych
-Summary(tr.UTF-8):     Ortak kitaplýk önbelleđi yaratýr ve bađlantýlarý kurar
+%package ld
+Summary:       Dynamic linker
+Summary(pl.UTF-8):     Linker (konsolidator) dynamiczny
 Group:         Applications/System
 Requires:      uname(release) >= %{min_kernel}
+# we want FHS being installed before ldconfig, altho they are both unrelated to each-other.
+Requires:      FHS
+Provides:      rtld(GNU_HASH)
 # This is needed because previous package (glibc) had autoreq false and had
 # provided this manually. Probably poldek bug that have to have it here.
 Provides:      /sbin/ldconfig
-# we want FHS being installed before ldconfig, altho they are both unrelated to each-other.
-Requires:      FHS
+Provides:      ldconfig = %{epoch}:%{version}-%{release}
+Obsoletes:     ldconfig < 6:2.28-6.1
+
+%description ld
+The dynamic linker is used to load shared libraries used by
+executables linked dynamically.
 
-%description -n ldconfig
-ldconfig scans a running system and sets up the symbolic links that
-are used to load shared libraries properly. It also creates
-/etc/ld.so.cache which speeds the loading programs which use shared
-libraries.
-
-%description -n ldconfig -l de.UTF-8
-ldconfig scannt ein laufendes System und richtet die symbolischen
-Verknüpfungen zum Laden der gemeinsam genutzten Libraries ein.
-Außerdem erstellt es /etc/ld.so.cache, was das Laden von Programmen
-mit gemeinsam genutzten Libraries beschleunigt.
-
-%description -n ldconfig -l fr.UTF-8
-ldconfig analyse un systčme et configure les liens symboliques
-utilisés pour charger correctement les bibliothčques partagées. Il
-crée aussi /etc/ld.so.cache qui accélčre le chargement des programmes
-utilisant les bibliothčques partagées.
-
-%description -n ldconfig -l pl.UTF-8
-ldconfig testuje uruchomiony system i tworzy dowiązania symboliczne,
-które są następnie używane do poprawnego ładowania bibliotek
-dynamicznych. Program ten tworzy plik /etc/ld.so.cache, który
-przyśpiesza ładowanie programów korzystających z bibliotek
-dynamicznych.
-
-%description -n ldconfig -l tr.UTF-8
-ldconfig, çalýţmakta olan sistemi araţtýrýr ve ortak kitaplýklarýn
-düzgün bir ţekilde yüklenmesi için gereken simgesel bađlantýlarý
-kurar. Ayrýca ortak kitaplýklarý kullanan programlarýn yüklenmesini
-hýzlandýran /etc/ld.so.cache dosyasýný yaratýr.
+The package also contains the ldconfig tool used to maintain shared
+library cache for the linker.
+
+%description ld -l pl.UTF-8
+Linker (konsolidator) dynamiczny służy do ładowania bibliotek
+współdzielonych używanych przez programy wykonywalne konsolidowane
+dynamicznie.
+
+Pakiet zawiera także narzędzie ldconfig, służące do utrzymywania
+pamięci podręcznej bibliotek współdzielonych dla linkera.
 
 %package -n nss_compat
 Summary:       Old style NYS NSS glibc module
@@ -385,6 +377,18 @@ El antiguo módulo NYS NSS de glibc
 %description -n nss_compat -l pl.UTF-8
 Stary moduł NYS NSS glibc.
 
+%package -n nss_db
+Summary:       NSS glibc module that uses hashed key-value database
+Summary(pl.UTF-8):     Moduł NSS glibc wykorzystujący haszowaną bazę danych klucz-wartość
+Group:         Base
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description -n nss_db
+NSS glibc module that uses hashed key-value database.
+
+%description -n nss_db -l pl.UTF-8
+Moduł NSS glibc wykorzystujący haszowaną bazę danych klucz-wartość.
+
 %package -n nss_dns
 Summary:       BIND NSS glibc module
 Summary(es.UTF-8):     Módulo BIND NSS de glibc
@@ -671,35 +675,10 @@ korzystające ze standardowych bibliotek C.
 Summary:       Documentation needed for development using standard C libraries
 Summary(pl.UTF-8):     Dokumentacja do tworzenia programów przy użyciu standardowych bibliotek C
 Group:         Documentation
-Provides:      %{name}-devel-doc(%{_target_cpu}) = %{epoch}:%{version}-%{release}
-%ifarch %{ix86}
-Provides:      %{name}-devel-doc(ix86) = %{epoch}:%{version}-%{release}
-%endif
-%ifarch %{x8664}
-# If both -m32 and -m64 is to be supported on x86_64, x86_64 package
-# have to be installed, not ix86 one.
-Obsoletes:     glibc-devel-doc(athlon)
-Obsoletes:     glibc-devel-doc(i386)
-Obsoletes:     glibc-devel-doc(i486)
-Obsoletes:     glibc-devel-doc(i586)
-Obsoletes:     glibc-devel-doc(i686)
-Obsoletes:     glibc-devel-doc(ix86)
-Obsoletes:     glibc-devel-doc(pentium3)
-Obsoletes:     glibc-devel-doc(pentium4)
-%endif
-%ifarch x32
-Obsoletes:     glibc-devel-doc(x86_64)
-%endif
-%ifarch ppc64
-Obsoletes:     glibc-devel-doc(ppc)
-%endif
-%ifarch s390x
-Obsoletes:     glibc-devel-doc(s390)
-%endif
-%ifarch sparc64
-Obsoletes:     glibc-devel-doc(sparc)
+Conflicts:     man-pages < 4.09
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
 %endif
-Conflicts:     man-pages < 4.00
 
 %description devel-doc
 The glibc-devel-doc package contains info and manual pages necessary
@@ -962,8 +941,8 @@ kodowania danych z poziomu dowolnego programu.
 %prep
 %setup -q
 
-%if "%{min_kernel}" < "2.6.32"
-echo "Minimal supported kernel is 2.6.32" >&2
+%if "%{min_kernel}" < "3.2.0"
+echo "Minimal supported kernel is 3.2.0" >&2
 exit 1
 %endif
 
@@ -972,11 +951,11 @@ exit 1
 %patch2 -p1
 %patch3 -p0
 %{!?with_bash_nls:%patch4 -p1}
-%patch5 -p1
+
 %patch6 -p1
-%patch7 -p1
+
 %patch8 -p1
-%patch9 -p0
+%patch9 -p1
 
 %patch10 -p1
 %patch11 -p1
@@ -987,17 +966,15 @@ exit 1
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
-%patch20 -p1
 
 %patch23 -p0
+%patch24 -p1
 
 %patch27 -p1
 
 %patch29 -p1
 %patch30 -p1
 
-%patch38 -p1
-
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
@@ -1025,15 +1002,21 @@ PATH=$(pwd)/alt-tools:$PATH; export PATH
 
 AWK="gawk" \
 ../%configure \
-       --enable-add-ons=libidn \
+%if %{with cet}
+       --enable-cet \
+%endif
        --enable-bind-now \
        --enable-experimental-malloc \
        --enable-hidden-plt \
        --enable-kernel="%{min_kernel}" \
        --enable-nss-crypt%{!?with_nss_crypt:=no} \
+       --enable-obsolete-nsl \
        --enable-obsolete-rpc \
        --enable-profile \
+       --enable-stack-protector=strong \
        --enable-stackguard-randomization \
+       --enable-static-pie \
+       --enable-tunables \
        --with-binutils=$(pwd)/alt-tools \
        --with-bugurl=http://bugs.pld-linux.org/ \
        --with-headers=%{_includedir} \
@@ -1054,7 +1037,9 @@ env LANGUAGE=C LC_ALL=C \
 
 %if %{without cross}
 CC="%{__cc}"
-diet ${CC#*ccache } %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
+CC=${CC#*ccache }
+CC=${CC#%{_libdir}/ccache/}
+diet ${CC} %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
 %endif
 
 %install
@@ -1100,7 +1085,7 @@ install -p glibc-postinst                         $RPM_BUILD_ROOT/sbin
 mv -f $RPM_BUILD_ROOT/%{_lib}/libpcprofile.so  $RPM_BUILD_ROOT%{_libdir}
 
 # make symlinks across top-level directories absolute
-for l in BrokenLocale anl cidn crypt dl \
+for l in BrokenLocale anl crypt dl \
 %ifarch %{x8664} x32
        mvec \
 %endif
@@ -1143,7 +1128,7 @@ cp -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/nscd.conf
 rm -rf documentation
 install -d documentation
 
-for f in ChangeLog.old DESIGN-{condvar,rwlock,systemtap-probes}.txt TODO{,-kernel,-testing}; do
+for f in DESIGN-systemtap-probes.txt TODO{,-kernel,-testing}; do
        cp -af nptl/$f documentation/$f.nptl
 done
 cp -af crypt/README.ufc-crypt ChangeLog* documentation
@@ -1167,33 +1152,47 @@ done
 #   tlh - Klingon (bzflag)
 #
 # To be added when they become supported by glibc:
-#   ach    (vlc, libreport)
-#   aln    (vlc, libreport)
+#   ace    (iso-codes)
+#   ach    (iso-codes, libreport, vlc)
+#   aln    (libreport, vlc)
 #   bal    (libosinfo, libreport, newt, pessulus)
+#   bar    (iso-codes)
 #   cgg    (vlc)
-#   co     (vlc)
-#   frp    (xfce, lxlauncher, mate)
-#   gn     (gn_BR in gnome, maybe gn_PY)
+#   ch     (iso-codes)
+#   co     (FileZilla, vlc)
+#   es_419 (alpm - common "Spanish (Latin America)")
+#   frp    (iso-codes, lxlauncher, mate, xfce)
+#   gn     (iso-codes, gnome; gn_BR in gnome, maybe gn_PY)
+#   guc    (gtk-vnc)
 #   haw    (iso-codes, stellarium)
 #   hrx    (stellarium)
 #   ilo    (kudzu, libosinfo, libreport)
-#   io     (gtk+2, gnome, alacarte)
-#   jv     (gmpc, avant-window-navigator, kdesudo, mate)
+#   io     (alacarte, gtk+2, gnome, iso-codes)
+#   jam    (iso-codes)
+#   jv     (avant-window-navigator, gmpc, kdesudo, mate)
+#   ki     (iso-codes)
+#   kok@latin  (inkscape)
 #   kmr    (vlc)
 #   ku_IQ  (mate)
+#   kv     (iso-codes)
 #   kw@kkcor, kw@uccor (libosinfo - currently empty) - add as supported variants when non-empty?
 #   man    (ccsm; incorrectly named md)
+#   mni@beng[ali]  (inkscape)
+#   mo     (iso-codes)
 #   mus    (bluez-gnome)
-#   nah    (mate)
+#   na     (iso-codes)
+#   nah    (iso-codes, mate)
 #   nqo           (mate)
+#   nv     (iso-codes)
+#   pi     (iso-codes)
 #   pms    (deluge, mate-tweak)
-#   sco    (gnomad2, picard, stellarium, mate)
-#   son    (gtkspell3)
+#   sat@deva[nagari]  (inkscape)
+#   sco    (gnomad2, mate, picard, stellarium)
+#   son    (gtkspell3, iso-codes)
 #   su     (terminator)
 #   swg    (sim)
 #   syr    (iso-codes)
 #   tet    (vlc)
-#   tpi    (mate-tweak)
 #   tw     (libosinfo)
 #   vec    (mate-applet-indicator)
 #   wba    (libosinfo)
@@ -1211,6 +1210,8 @@ done
 # bn=bn_BD
 # bo=bo_CN? (or common for CN, IN?)
 # ca=ca_ES
+# ce=ce_RU
+# chr=chr_US
 # ckb=ckb_IQ
 # cv=cv_RU
 # de=de_DE
@@ -1224,8 +1225,13 @@ done
 # fy=fy_NL
 # gez=gez_ET (?)
 # it=it_IT
+# kab=kab_DZ
+# ks=ks_IN
+# ks@devanagari=ks_IN@devanagari
 # ku=ku_TR
 # li=li_NL
+# ln=ln_CD
+# lo=lo_LA
 # nds=nds_DE
 # nl=nl_NL
 # om=om_ET
@@ -1235,6 +1241,7 @@ done
 # quz=quz_PE
 # ru=ru_RU
 # sd=sd_IN
+# sd@devanagari=sd_IN@devanagari
 # shn=shn_MM
 # so=so_SO
 # sr=sr_RS [cyrillic]
@@ -1246,6 +1253,7 @@ done
 # ta=ta_IN
 # te=te_IN
 # ti=ti_ER (?)
+# tpi=tpi_PG
 # tr=tr_TR
 # ur=ur_PK (?)
 # zh: no short code used (use zh_CN, zh_HK, zh_SG[not included yet], zh_TW)
@@ -1255,15 +1263,15 @@ done
 #   sv tr zh_CN zh_TW
 #
 for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR be@latin be@tarask bem \
-       bg bho bn bn_IN bo br brx bs byn ca@valencia ckb cmn crh csb cv cy de_AT de_CH doi dv dz en \
+       bg bho bn bn_IN bo br brx bs byn ca@valencia ce chr ckb cmn crh csb cv cy de_AT de_CH doi dv dz en \
        en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa ff fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
-       hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ku kw ky la lb \
-       lg li lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
-       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se shn si sid sl so sq sr sr@Latn szl tl \
+       hi hne ht hsb hy ia id ig ik is it_CH iu ka kab kg kk kl km kn kok ks ks@devanagari ku kw ky la lb \
+       lg li ln lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
+       oc om or pa pap ps pt ps quz rm ro sa sat sc sd sd@devanagari se shn si sid sl so sq sr sr@Latn szl tl \
        sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw ta te tg th ti \
-       tig tk tl tlh tn ts tt tt@iqtelif ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
+       tig tk tl tlh tn tpi ts tt tt@iqtelif ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
        zh_HK zu; do
        if [ ! -d $RPM_BUILD_ROOT%{_localedir}/$i/LC_MESSAGES ]; then
                install -d $RPM_BUILD_ROOT%{_localedir}/$i/LC_MESSAGES
@@ -1309,11 +1317,18 @@ rm -rf $RPM_BUILD_ROOT
 %if %{without cross}
 %post  -p /sbin/postshell
 /sbin/glibc-postinst /%{_lib}/%{_host_cpu} /%{_lib}/tls
-/sbin/ldconfig
+-/sbin/ldconfig
+
+%postun        -p /sbin/postshell
+-/sbin/ldconfig
 
-%postun        -p /sbin/ldconfig
+%post ld -p /sbin/postshell
+-/sbin/ldconfig
 
-%triggerpostun -p /sbin/postshell -- glibc-misc < 6:2.3.5-7.6
+%postun        ld -p /sbin/postshell
+-/sbin/ldconfig
+
+%triggerpostun ld -p /sbin/postshell -- glibc-misc < 6:2.3.5-7.6
 -/bin/cp -f /etc/ld.so.conf /etc/ld.so.conf.rpmsave
 -/bin/sed -i -e '1iinclude ld.so.conf.d/*.conf' /etc/ld.so.conf
 %endif
@@ -1385,31 +1400,11 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README NEWS BUGS CONFORMANCE
+%doc README NEWS
 %if %{without cross}
 %attr(755,root,root) /sbin/glibc-postinst
 %endif
-# TODO: package ldconfig symlinks as %ghost
-%attr(755,root,root) /%{_lib}/ld-%{core_version}.so
 # wildly arch-dependent ld.so SONAME symlink
-%ifarch %{ix86} sparc sparcv9 sparc64 alpha sh
-%attr(755,root,root) /%{_lib}/ld-linux.so.2
-%endif
-%ifarch ia64
-%attr(755,root,root) /%{_lib}/ld-linux-ia64.so.2
-%endif
-%ifarch %{x8664}
-%attr(755,root,root) /%{_lib}/ld-linux-x86-64.so.2
-%endif
-%ifarch x32
-%attr(755,root,root) /%{_lib}/ld-linux-x32.so.2
-%endif
-%ifarch ppc64 s390x
-%attr(755,root,root) /%{_lib}/ld64.so.1
-%endif
-%ifnarch %{ix86} sparc sparcv9 sparc64 alpha sh ia64 %{x8664} x32 ppc64 s390x %{arm}
-%attr(755,root,root) /%{_lib}/ld.so.1
-%endif
 %attr(755,root,root) /%{_lib}/libBrokenLocale-%{core_version}.so
 %ifarch alpha
 %attr(755,root,root) /%{_lib}/libBrokenLocale.so.1.1
@@ -1425,8 +1420,6 @@ fi
 %else
 %attr(755,root,root) /%{_lib}/libc.so.6
 %endif
-%attr(755,root,root) /%{_lib}/libcidn-%{core_version}.so
-%attr(755,root,root) /%{_lib}/libcidn.so.1
 %attr(755,root,root) /%{_lib}/libdl-%{core_version}.so
 %ifarch alpha
 %attr(755,root,root) /%{_lib}/libdl.so.2.1
@@ -1469,13 +1462,6 @@ fi
 %endif
 %dir %{_prefix}/lib/locale
 
-#%files -n nss_db
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/makedb
-%attr(755,root,root) /%{_lib}/libnss_db-%{core_version}.so
-%attr(755,root,root) /%{_lib}/libnss_db.so.2
-%{_var}/db/Makefile
-
 #%files -n nss_dns
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libnss_dns-%{core_version}.so
@@ -1536,9 +1522,6 @@ fi
 %{_mandir}/man7/unicode.7*
 %{_mandir}/man7/utf-8.7*
 %{_mandir}/man7/utf8.7*
-%{_mandir}/man8/ld-linux.8*
-%{_mandir}/man8/ld-linux.so.8*
-%{_mandir}/man8/ld.so.8*
 %{_mandir}/man8/sln.8*
 %{_mandir}/man8/zdump.8*
 %{_mandir}/man8/zic.8*
@@ -1572,9 +1555,6 @@ fi
 %lang(es) %{_mandir}/es/man7/unicode.7*
 %lang(es) %{_mandir}/es/man7/utf-8.7*
 %lang(es) %{_mandir}/es/man7/utf8.7*
-%lang(es) %{_mandir}/es/man8/ld-linux.8*
-%lang(es) %{_mandir}/es/man8/ld-linux.so.8*
-%lang(es) %{_mandir}/es/man8/ld.so.8*
 %lang(es) %{_mandir}/es/man8/zdump.8*
 %lang(es) %{_mandir}/es/man8/zic.8*
 %lang(fr) %{_mandir}/fr/man5/locale.5*
@@ -1592,9 +1572,6 @@ fi
 %lang(fr) %{_mandir}/fr/man7/unicode.7*
 %lang(fr) %{_mandir}/fr/man7/utf-8.7*
 %lang(fr) %{_mandir}/fr/man7/utf8.7*
-%lang(fr) %{_mandir}/fr/man8/ld-linux.8*
-%lang(fr) %{_mandir}/fr/man8/ld-linux.so.8*
-%lang(fr) %{_mandir}/fr/man8/ld.so.8*
 %lang(fr) %{_mandir}/fr/man8/zdump.8*
 %lang(fr) %{_mandir}/fr/man8/zic.8*
 %lang(hu) %{_mandir}/hu/man7/ascii.7*
@@ -1605,9 +1582,6 @@ fi
 %lang(hu) %{_mandir}/hu/man7/locale.7*
 %lang(hu) %{_mandir}/hu/man7/utf-8.7*
 %lang(hu) %{_mandir}/hu/man7/utf8.7*
-%lang(hu) %{_mandir}/hu/man8/ld-linux.8*
-%lang(hu) %{_mandir}/hu/man8/ld-linux.so.8*
-%lang(hu) %{_mandir}/hu/man8/ld.so.8*
 %lang(hu) %{_mandir}/hu/man8/zdump.8*
 %lang(it) %{_mandir}/it/man5/locale.5*
 %lang(it) %{_mandir}/it/man7/ascii.7*
@@ -1647,9 +1621,6 @@ fi
 %lang(ja) %{_mandir}/ja/man7/unicode.7*
 %lang(ja) %{_mandir}/ja/man7/utf-8.7*
 %lang(ja) %{_mandir}/ja/man7/utf8.7*
-%lang(ja) %{_mandir}/ja/man8/ld-linux.8*
-%lang(ja) %{_mandir}/ja/man8/ld-linux.so.8*
-%lang(ja) %{_mandir}/ja/man8/ld.so.8*
 %lang(ja) %{_mandir}/ja/man8/sln.8*
 %lang(ja) %{_mandir}/ja/man8/zdump.8*
 %lang(ja) %{_mandir}/ja/man8/zic.8*
@@ -1674,9 +1645,6 @@ fi
 %lang(pl) %{_mandir}/pl/man7/unicode.7*
 %lang(pl) %{_mandir}/pl/man7/utf-8.7*
 %lang(pl) %{_mandir}/pl/man7/utf8.7*
-%lang(pl) %{_mandir}/pl/man8/ld-linux.8*
-%lang(pl) %{_mandir}/pl/man8/ld-linux.so.8*
-%lang(pl) %{_mandir}/pl/man8/ld.so.8*
 %lang(pt) %{_mandir}/pt/man5/locale.5*
 %lang(pt) %{_mandir}/pt/man5/nsswitch.conf.5*
 %lang(pt) %{_mandir}/pt/man5/rpc.5*
@@ -1713,8 +1681,6 @@ fi
 %lang(ru) %{_mandir}/ru/man7/unicode.7*
 %lang(ru) %{_mandir}/ru/man7/utf-8.7*
 %lang(ru) %{_mandir}/ru/man7/utf8.7*
-%lang(ru) %{_mandir}/ru/man8/ld-linux.so.8*
-%lang(ru) %{_mandir}/ru/man8/ld.so.8*
 %lang(ru) %{_mandir}/ru/man8/zdump.8*
 %lang(ru) %{_mandir}/ru/man8/zic.8*
 %lang(tr) %{_mandir}/tr/man1/iconv.1*
@@ -1770,19 +1736,59 @@ fi
 %attr(755,root,root) %ghost /%{_lib}/libcrypt.so.1
 %endif
 
-%files -n ldconfig
+%files ld
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf
 %dir %{_sysconfdir}/ld.so.conf.d
 %ghost %{_sysconfdir}/ld.so.cache
+# TODO: package ldconfig symlinks as %ghost
+%attr(755,root,root) /%{_lib}/ld-%{core_version}.so
+%ifarch %{ix86} sparc sparcv9 sparc64 alpha sh
+%attr(755,root,root) /%{_lib}/ld-linux.so.2
+%endif
+%ifarch ia64
+%attr(755,root,root) /%{_lib}/ld-linux-ia64.so.2
+%endif
+%ifarch %{x8664}
+%attr(755,root,root) /%{_lib}/ld-linux-x86-64.so.2
+%endif
+%ifarch x32
+%attr(755,root,root) /%{_lib}/ld-linux-x32.so.2
+%endif
+%ifarch ppc64 s390x
+%attr(755,root,root) /%{_lib}/ld64.so.1
+%endif
+%ifnarch %{ix86} sparc sparcv9 sparc64 alpha sh ia64 %{x8664} x32 ppc64 s390x %{arm}
+%attr(755,root,root) /%{_lib}/ld.so.1
+%endif
 %attr(755,root,root) /sbin/ldconfig
+%{_mandir}/man8/ld-linux.8*
+%{_mandir}/man8/ld-linux.so.8*
+%{_mandir}/man8/ld.so.8*
 %{_mandir}/man8/ldconfig.8*
+%lang(es) %{_mandir}/es/man8/ld-linux.8*
+%lang(es) %{_mandir}/es/man8/ld-linux.so.8*
+%lang(es) %{_mandir}/es/man8/ld.so.8*
 %lang(es) %{_mandir}/es/man8/ldconfig.8*
+%lang(fr) %{_mandir}/fr/man8/ld-linux.8*
+%lang(fr) %{_mandir}/fr/man8/ld-linux.so.8*
+%lang(fr) %{_mandir}/fr/man8/ld.so.8*
 %lang(fr) %{_mandir}/fr/man8/ldconfig.8*
+%lang(hu) %{_mandir}/hu/man8/ld-linux.8*
+%lang(hu) %{_mandir}/hu/man8/ld-linux.so.8*
+%lang(hu) %{_mandir}/hu/man8/ld.so.8*
 %lang(hu) %{_mandir}/hu/man8/ldconfig.8*
+%lang(ja) %{_mandir}/ja/man8/ld-linux.8*
+%lang(ja) %{_mandir}/ja/man8/ld-linux.so.8*
+%lang(ja) %{_mandir}/ja/man8/ld.so.8*
 %lang(ja) %{_mandir}/ja/man8/ldconfig.8*
+%lang(pl) %{_mandir}/pl/man8/ld-linux.8*
+%lang(pl) %{_mandir}/pl/man8/ld-linux.so.8*
+%lang(pl) %{_mandir}/pl/man8/ld.so.8*
 %lang(pl) %{_mandir}/pl/man8/ldconfig.8*
 %lang(pt) %{_mandir}/pt/man8/ldconfig.8*
+%lang(ru) %{_mandir}/ru/man8/ld-linux.so.8*
+%lang(ru) %{_mandir}/ru/man8/ld.so.8*
 %lang(ru) %{_mandir}/ru/man8/ldconfig.8*
 %dir %attr(700,root,root) /var/cache/ldconfig
 %attr(600,root,root) %ghost /var/cache/ldconfig/aux-cache
@@ -1792,6 +1798,13 @@ fi
 %attr(755,root,root) /%{_lib}/libnss_compat-%{core_version}.so
 %attr(755,root,root) /%{_lib}/libnss_compat.so.2
 
+%files -n nss_db
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/makedb
+%attr(755,root,root) /%{_lib}/libnss_db-%{core_version}.so
+%attr(755,root,root) /%{_lib}/libnss_db.so.2
+%{_var}/db/Makefile
+
 %files -n nss_hesiod
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libnss_hesiod-%{core_version}.so
@@ -1824,7 +1837,6 @@ fi
 %attr(755,root,root) %{_libdir}/libBrokenLocale.so
 %attr(755,root,root) %{_libdir}/libanl.so
 %attr(755,root,root) %{_libdir}/libcrypt.so
-%attr(755,root,root) %{_libdir}/libcidn.so
 %attr(755,root,root) %{_libdir}/libdl.so
 %attr(755,root,root) %{_libdir}/libm.so
 %ifarch %{x8664} x32
@@ -1837,7 +1849,8 @@ fi
 %attr(755,root,root) %{_libdir}/libthread_db.so
 %attr(755,root,root) %{_libdir}/libutil.so
 %{_libdir}/crt[1in].o
-%{_libdir}/[MSg]crt1.o
+%{_libdir}/[MSgr]crt1.o
+%{_libdir}/grcrt1.o
 # ld scripts
 %{_libdir}/libc.so
 %{_libdir}/libpthread.so
@@ -1847,11 +1860,9 @@ fi
 %endif
 %{_libdir}/libc_nonshared.a
 %{_libdir}/libg.a
-%{_libdir}/libieee.a
 %ifarch alpha ppc sparc
 %{_libdir}/libnldbl_nonshared.a
 %endif
-%{_libdir}/libpthread_nonshared.a
 %{_libdir}/librpcsvc.a
 %ifarch %{ix86} %{x8664} x32 ppc ppc64 s390 s390x sparc sparcv9 sparc64
 # ABI-dependent headers
@@ -1899,12 +1910,14 @@ fi
 
 %files devel-doc
 %defattr(644,root,root,755)
-%doc documentation/* PROJECTS
+%doc documentation/*
 %{_infodir}/libc.info*
 
 %{_mandir}/man1/sprof.1*
 # just a link to getcwd.3
 %{_mandir}/man2/getcwd.2*
+# just a link to killpg.3
+%{_mandir}/man2/killpg.2*
 %{_mandir}/man3/*
 %{_mandir}/man7/aio.7*
 %{_mandir}/man7/attributes.7*
@@ -1921,10 +1934,13 @@ fi
 %{_mandir}/man7/sem_overview.7*
 %{_mandir}/man7/shm_overview.7*
 %lang(cs) %{_mandir}/cs/man3/*
+%lang(de) %{_mandir}/de/man2/killpg.2*
 %lang(de) %{_mandir}/de/man3/*
+%lang(es) %{_mandir}/es/man2/killpg.2*
 %lang(es) %{_mandir}/es/man3/*
 %lang(es) %{_mandir}/es/man7/glob.7*
 %lang(fr) %{_mandir}/fr/man2/getcwd.2*
+%lang(fr) %{_mandir}/fr/man2/killpg.2*
 %lang(fr) %{_mandir}/fr/man3/*
 %lang(fr) %{_mandir}/fr/man7/complex.7*
 %lang(fr) %{_mandir}/fr/man7/feature_test_macros.7*
@@ -1938,6 +1954,7 @@ fi
 %lang(it) %{_mandir}/it/man7/glob.7*
 %lang(ja) %{_mandir}/ja/man1/sprof.1*
 %lang(ja) %{_mandir}/ja/man2/getcwd.2*
+%lang(ja) %{_mandir}/ja/man2/killpg.2*
 %lang(ja) %{_mandir}/ja/man3/*
 %lang(ja) %{_mandir}/ja/man7/aio.7*
 %lang(ja) %{_mandir}/ja/man7/complex.7*
@@ -1950,12 +1967,16 @@ fi
 %lang(ja) %{_mandir}/ja/man7/pthreads.7*
 %lang(ja) %{_mandir}/ja/man7/sem_overview.7*
 %lang(ja) %{_mandir}/ja/man7/shm_overview.7*
+%lang(ko) %{_mandir}/ko/man2/killpg.2*
 %lang(ko) %{_mandir}/ko/man3/*
 %lang(nl) %{_mandir}/nl/man3/*
+%lang(pl) %{_mandir}/pl/man2/killpg.2*
 %lang(pl) %{_mandir}/pl/man3/*
+%lang(pt) %{_mandir}/pt/man2/killpg.2*
 %lang(pt) %{_mandir}/pt/man3/*
 %lang(pt) %{_mandir}/pt/man7/glob.7*
 %lang(ru) %{_mandir}/ru/man1/sprof.1*
+%lang(ru) %{_mandir}/ru/man2/killpg.2*
 %lang(ru) %{_mandir}/ru/man3/*
 %lang(ru) %{_mandir}/ru/man7/glob.7*
 %lang(tr) %{_mandir}/tr/man3/*
@@ -1973,6 +1994,7 @@ fi
 %{_libdir}/libm.a
 %{_libdir}/libmcheck.a
 %ifarch %{x8664} x32
+%{_libdir}/libm-%{core_version}.a
 %{_libdir}/libmvec.a
 %endif
 %{_libdir}/libnsl.a
This page took 0.112646 seconds and 4 git commands to generate.