]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- added alpha-div patch (now fails later on ld.so linking)
[packages/glibc.git] / glibc.spec
index f3a49f8a85c599f5007f11daa340e41ed59de42b..405a9b4339cd90bffd890786214eb73bd783e4e3 100644 (file)
@@ -3,12 +3,12 @@
 # default is 2.4.6
 #
 # Conditional build:
-%bcond_without fp              # build without frame pointer (pass \--enable-omitfp)
+%bcond_with    omitfp          # build without frame pointer (pass \--enable-omitfp)
 %bcond_without memusage        # don't build memusage utility
 %bcond_with    kernelheaders   # use headers from kernel-headers instead of
                                # linux-libc-headers (evil, breakage etc., don't use)
 %bcond_without dist_kernel     # for above, allow non-distribution kernel
-%bcond_with    nptl            # use nptl instead of linuxthreads
+%bcond_with    nptl            # use nptl instead of linuxthreads (implies tls)
 %bcond_with    tls             # use tls
 %bcond_with    tests           # perform "make test"
 
 %if "%{min_kernel}" < "2.6.0"
 %global                min_kernel      2.6.0
 %endif
+# NPTL requires TLS
+%define                with_tls        1
 %else
-%undefine with_nptl
+%undefine      with_nptl
 %endif
 %endif
 
 %if %{with tls}
 %ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
-%undefine with_tls
+%undefine      with_tls
 %endif
 %endif
 
-%define        llh_version     7:2.6.1.3
+%define                llh_version     7:2.6.4.0
+%define                _snap           20040603
+
 Summary:       GNU libc
 Summary(de):   GNU libc
 Summary(es):   GNU libc
@@ -53,16 +57,15 @@ Summary(tr):        GNU libc
 Summary(uk):   GNU libc ×ÅÒÓ¦§ 2.3
 Name:          glibc
 Version:       2.3.4
-Release:       0.20040318.1%{?with_nptl:+nptl}
+Release:       0.%{_snap}.1%{?with_nptl:+nptl}
 Epoch:         6
 License:       LGPL
 Group:         Libraries
 #Source0:      ftp://sources.redhat.com/pub/glibc/releases/%{name}-%{version}.tar.bz2
-Source0:       %{name}-2.3.3.tar.bz2
-# Source0-md5: abb1508f747df2a73b38f49a120d7461
+Source0:       %{name}-%{_snap}.tar.bz2
+# Source0-md5: 8564ff95873944201e4bb6317ea070d6
 #Source1:      ftp://sources.redhat.com/pub/glibc/releases/%{name}-linuxthreads-%{version}.tar.bz2
-Source1:       %{name}-linuxthreads-2.3.3.tar.bz2
-# Source1-md5: 97c30992592f854a67107579dcef61dd
+#Source1:      %{name}-linuxthreads-2.3.3.tar.bz2
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -97,6 +100,7 @@ Patch20:     %{name}-tests-noproc.patch
 Patch21:       %{name}-linuxthreads-ppc-fix.patch
 Patch23:       %{name}-new-charsets.patch
 Patch26:       %{name}-sr_CS.patch
+Patch27:       %{name}-alpha-div.patch
 # PaX
 Patch30:       %{name}-pax_iconvconfig.patch
 Patch31:       %{name}-pax_dl-execstack.patch
@@ -282,6 +286,7 @@ Summary(uk):        
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 %{!?with_kernelheaders:Requires:       linux-libc-headers >= %{llh_version}}
+Obsoletes:     libiconv-devel
 
 %description devel
 To develop programs which use the standard C libraries (which nearly
@@ -472,6 +477,7 @@ Summary(ru):        
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ glibc
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Obsoletes:     libiconv-static
 
 %description static
 GNU libc static libraries.
@@ -753,7 +759,8 @@ Bibliotecas est
 Statyczne 64-bitowe biblioteki GNU libc.
 
 %prep
-%setup -q -a 1 -n libc
+#setup -q -a 1 -n libc
+%setup -q -n libc
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -771,12 +778,13 @@ Statyczne 64-bitowe biblioteki GNU libc.
 %{?with_kernelheaders:%patch13}
 %{?!with_kernelheaders:%patch14 -p1}
 %patch15 -p1
-%patch17
+%patch17 -p0
 %patch18 -p1
 %patch20 -p1
 %patch21 -p1
 %patch23 -p1
 %patch26 -p1
+%patch27 -p1
 
 %patch30 -p1
 %patch31 -p1
@@ -789,13 +797,17 @@ cp /usr/share/automake/config.sub .
 cp /usr/share/automake/config.sub scripts
 %{__aclocal}
 %{__autoconf}
+# i786 (aka pentium4) hack
+cd nptl/sysdeps/i386 && ln -s i686 i786 && cd -
+cd nptl/sysdeps/unix/sysv/linux/i386 && ln -s i686 i786 && cd -
+#
 [ -d builddir ] || mkdir builddir
 cd builddir
 # avoid stripping ld.so by -s in rpmldflags
 LDFLAGS=" " ; export LDFLAGS
 ../%configure \
        --enable-kernel="%{min_kernel}" \
-       --%{!?with_fp:en}%{?with_fp:dis}able-omitfp \
+       --%{?with_omitfp:en}%{!?with_omitfp:dis}able-omitfp \
        %{?with_tls:--with-tls} \
 %if %{with nptl}
         --enable-add-ons=nptl \
@@ -1053,6 +1065,8 @@ fi
 %attr(755,root,root) /%{_lib}/libnsl*
 %attr(755,root,root) /%{_lib}/lib[BScmprtu]*
 %dir %{_libdir}/locale
+%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf
+%ghost %{_sysconfdir}/ld.so.cache
 
 #%files -n nss_dns
 %defattr(644,root,root,755)
@@ -1066,10 +1080,8 @@ fi
 %files misc -f %{name}.lang
 %defattr(644,root,root,755)
 
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf
 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/nsswitch.conf
 %config %{_sysconfdir}/rpc
-%ghost %{_sysconfdir}/ld.so.cache
 
 %attr(755,root,root) /sbin/sln
 %attr(755,root,root) %{_bindir}/catchsegv
This page took 0.089307 seconds and 4 git commands to generate.