]> git.pld-linux.org Git - packages/glibc.git/blame_incremental - glibc.spec
- updated new-charsets patch, release .8
[packages/glibc.git] / glibc.spec
... / ...
CommitLineData
1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
3# default is 2.4.6
4#
5# Conditional build:
6%bcond_without fp # build without frame pointer (pass \--enable-omitfp)
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
9 # glibc-kernel-headers (evil, breakage etc., don't use)
10%bcond_without dist_kernel # for above, allow non-distribution kernel
11%bcond_with nptl # use nptl instead of linuxthreads
12%bcond_with tls # use tls
13%bcond_with tests # do not perform "make test"
14
15#
16# TODO:
17# - localedb-gen man pages(?)
18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
19#
20# WARNING:
21# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
22# in order to use this version!
23#
24
25%{!?min_kernel:%global min_kernel 2.4.6}
26
27%if %{with nptl}
28# it seems that nptl uses cmpxchgl (available since i486) on x86
29%ifarch i486 i586 i686 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
30%if "%{min_kernel}" < "2.6.0"
31%global min_kernel 2.6.0
32%endif
33%else
34%undefine with_nptl
35%endif
36%endif
37
38%if %{with tls}
39%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
40%undefine with_tls
41%endif
42%endif
43
44%define gkh_version 7:2.6.0.3
45Summary: GNU libc
46Summary(de): GNU libc
47Summary(es): GNU libc
48Summary(fr): GNU libc
49