]> git.pld-linux.org Git - packages/glibc.git/blame_incremental - glibc.spec
- added hsb locale dir
[packages/glibc.git] / glibc.spec
... / ...
CommitLineData
1#
2# TODO:
3# - SECURITY: http://securitytracker.com/alerts/2004/Aug/1010975.html
4#
5# You can define min_kernel macro by "rpm --define 'min_kernel version'"
6# default is 2.4.6
7#
8# Conditional build:
9%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
10%bcond_without memusage # don't build memusage utility
11%bcond_with kernelheaders # use headers from kernel-headers instead of
12 # linux-libc-headers (evil, breakage etc., don't use)
13%bcond_without dist_kernel # for above, allow non-distribution kernel
14%bcond_with nptl # use nptl instead of linuxthreads (implies tls)
15%bcond_with tls # use tls
16%bcond_with tests # perform "make test"
17
18#
19# TODO:
20# - localedb-gen man pages(?)
21# - fix what trojan broke while upgreading (getaddrinfo-workaround)
22# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
23# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
24#
25
26%{!?min_kernel:%global min_kernel 2.4.6}
27
28%if %{with nptl}
29# it seems that nptl uses cmpxchgl (available since i486) on x86
30%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
31%if "%{min_kernel}" < "2.6.0"
32%global min_kernel 2.6.0
33%endif
34# NPTL requires TLS
35%define with_tls 1
36%else
37%undefine with_nptl
38%endif
39%endif
40
41%if %{with tls}
42%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
43%undefine with_tls
44%endif
45%endif
46
47%ifarch sparc64
48%undefine with_memusage
49%endif
50
51%define llh_version 7:2.6.6.0
52%define _snap 20040722
53
54Summary: GNU libc
55Summary(de): GNU libc
56Summary(es): GNU libc
57Summary(fr): GNU libc
58