]> git.pld-linux.org Git - packages/glibc.git/blame_incremental - glibc.spec
- quotes fixed.
[packages/glibc.git] / glibc.spec
... / ...
CommitLineData
1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
3# default is 2.4.6
4#
5# Conditional build:
6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
9 # linux-libc-headers (evil, breakage etc., don't use)
10%bcond_without dist_kernel # for above, allow non-distribution kernel
11%bcond_with nptl # use nptl instead of linuxthreads (implies tls)
12%bcond_with tls # use tls
13%bcond_with tests # perform "make test"
14
15#
16# TODO:
17# - localedb-gen man pages(?)
18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
19# - fix ld.so.conf (while upgrading glibc it do NOW mv ld.so.conf ld.so.conf.rpmsave)
20#
21# WARNING:
22# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
23# in order to use this version!
24#
25
26%{!?min_kernel:%global min_kernel 2.4.6}
27
28%if %{with nptl}
29# it seems that nptl uses cmpxchgl (available since i486) on x86
30%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
31%if "%{min_kernel}" < "2.6.0"
32%global min_kernel 2.6.0
33%endif
34# NPTL requires TLS
35%define with_tls 1
36%else
37%undefine with_nptl
38%endif
39%endif
40
41%if %{with tls}
42%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
43%undefine with_tls
44%endif
45%endif
46
47%define llh_version 7:2.6.4.0
48%define _snap 20040612
49
50Summary: GNU libc
51Summary(de): GNU libc
52Summary(es): GNU libc
53Summary(fr): GNU libc
54