]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- added missing /var/run/nscd dir to nscd package
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
b05916ae 6%bcond_without fp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
9 # glibc-kernel-headers (evil, breakage etc., don't use)
10%bcond_without dist_kernel # for above, allow non-distribution kernel
61918272 11%bcond_with nptl # use nptl instead of linuxthreads
92121d4a 12%bcond_with tls # use tls
dc3eddd2 13%bcond_with tests # do not perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec
AM
18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
19#
76f01b70
JB
20# WARNING:
21# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
22# in order to use this version!
23#
61918272 24
3900e225 25%{!?min_kernel:%global min_kernel 2.4.6}
61918272 26
27%if %{with nptl}
dc3eddd2
JB
28# it seems that nptl uses cmpxchgl (available since i486) on x86
29%ifarch i486 i586 i686 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
76131947
AM
30%if "%{min_kernel}" < "2.6.0"
31%global min_kernel 2.6.0
32%endif
61918272 33%else
3900e225
AM
34%undefine with_nptl
35%endif
61918272 36%endif
61918272 37
f3f771b7 38%if %{with tls}
dc3eddd2 39%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
f3f771b7
AM
40%undefine with_tls
41%endif
42%endif
43
adfd3b3d 44%define gkh_version 7:2.6.0.3
236a5027 45Summary: GNU libc
46Summary(de): GNU libc
4a04bb32 47Summary(es): GNU libc
236a5027 48Summary(fr): GNU libc
c5387ad5 49