]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- use %useradd/%groupadd macros
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
e03cf19f
JB
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
757f96eb 14%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 15%bcond_with tests # perform "make test"
4cceaf33 16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
0a85848c 17%bcond_without localedb # don't build localedb-all (is time consuming)
472e31ee 18%bcond_with cross # build using crossgcc (without libgcc_eh)
b287d865 19#
37cd6ebc 20# TODO:
72549d49
JB
21# - look at locale fixes/updates in bugzilla
22# [OLD]
37cd6ebc 23# - localedb-gen man pages(?)
4acad1ec 24# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
25# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
26# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
27# - problem compiling with --enable-bounded (must be reported to libc-alpha)
28# (is this comment still valid???)
76f01b70 29#
61918272 30
3900e225 31%{!?min_kernel:%global min_kernel 2.4.6}
76131947 32%if "%{min_kernel}" < "2.6.0"
40240acb
JB
33%global nptl_min_kernel 2.6.0
34%else
35%global nptl_min_kernel %{min_kernel}
76131947 36%endif
40240acb 37
e03cf19f 38%if %{with tls}
c14df6fe 39# sparc temporarily removed (broken)
472e31ee 40%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
e03cf19f
JB
41%undefine with_tls
42%endif
43%endif
44
40240acb 45%if %{with nptl}
472e31ee
JB
46# on x86 uses cmpxchgl (available since i486)
47# on sparc only sparcv9 is supported
4bcd7e8c 48%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
40240acb 49%undefine with_nptl
e03cf19f
JB
50%else
51%if %{without tls}
52%undefine with_nptl
3900e225 53%endif
61918272 54%endif
f3f771b7
AM
55%endif
56
e24149ab
PS
57%ifarch sparc64
58%undefine with_memusage
59%endif
60
40240acb
JB
61%if %{with linuxthreads} && %{with nptl}
62%define with_dual 1
63%endif
64
a643003b 65%define llh_version 7:2.6.10.0-3
e8c60795 66
236a5027 67Summary: GNU libc
68Summary(de): GNU libc
4a04bb32 69Summary(es): GNU libc
236a5027 70Summary(fr): GNU libc
c5387ad5 71