]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- or dir for Oriya added
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
fd1d4127 10%bcond_without dist_kernel # for above, allow non-distribution kernel
5f56f24b 11%bcond_with nptl # use nptl instead of linuxthreads (implies tls)
87146167 12%bcond_with tls # use tls
c9d8e545 13%bcond_with tests # perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec 18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
19# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
20# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
76f01b70 21#
61918272 22
3900e225 23%{!?min_kernel:%global min_kernel 2.4.6}
61918272 24
25%if %{with nptl}
dc3eddd2 26# it seems that nptl uses cmpxchgl (available since i486) on x86
dd75ad7c 27%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
76131947
AM
28%if "%{min_kernel}" < "2.6.0"
29%global min_kernel 2.6.0
30%endif
5f56f24b
JB
31# NPTL requires TLS
32%define with_tls 1
61918272 33%else
5f56f24b 34%undefine with_nptl
3900e225 35%endif
61918272 36%endif
61918272 37
f3f771b7 38%if %{with tls}
dd75ad7c 39%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 40%undefine with_tls
f3f771b7
AM
41%endif
42%endif
43
e24149ab
PS
44%ifarch sparc64
45%undefine with_memusage
46%endif
47
121eb47e 48%define llh_version 7:2.6.6.0
baee199c 49%define _snap 20040722
e8c60795 50
236a5027 51Summary: GNU libc
52Summary(de): GNU libc
4a04bb32 53Summary(es): GNU libc
236a5027 54Summary(fr): GNU libc
c5387ad5 55