]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- added nptl bcond (mainly port from DEVEL)
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
b05916ae 6%bcond_without fp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
9 # glibc-kernel-headers (evil, breakage etc., don't use)
10%bcond_without dist_kernel # for above, allow non-distribution kernel
11%bcond_with idn # build with included libidn
61918272 12%bcond_with nptl # use nptl instead of linuxthreads
adfd3b3d 13%bcond_without tests # do not perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec
AM
18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
19#
76f01b70
JB
20# WARNING:
21# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
22# in order to use this version!
23#
61918272 24
25# We dont have all those archs, but just in case and
26%define _nptl_arches i686 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
27
28%ifnarch %{_nptl_arches}
29%undefine with_nptl
30%endif
31
32%if %{with nptl}
33%{!?min_kernel:%global min_kernel 2.6.0}
34# Doesnt go through checks.
35#%%undefine with_fp
36%else
37%{!?min_kernel:%global min_kernel 2.4.6}
38%endif
39
40
adfd3b3d 41%define gkh_version 7:2.6.0.3
236a5027 42Summary: GNU libc
43Summary(de): GNU libc
4a04bb32 44Summary(es): GNU libc
236a5027 45Summary(fr): GNU libc
c5387ad5 46