]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- resync cosmetics with AC-branch
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
e03cf19f
JB
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
757f96eb 14%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 15%bcond_with tests # perform "make test"
4cceaf33 16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
0a85848c 17%bcond_without localedb # don't build localedb-all (is time consuming)
472e31ee 18%bcond_with cross # build using crossgcc (without libgcc_eh)
5b00029e 19%bcond_with pax # apply PaX hack
b287d865 20#
37cd6ebc 21# TODO:
72549d49
JB
22# - look at locale fixes/updates in bugzilla
23# [OLD]
37cd6ebc 24# - localedb-gen man pages(?)
4acad1ec 25# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
26# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
27# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
28# - problem compiling with --enable-bounded (must be reported to libc-alpha)
29# (is this comment still valid???)
76f01b70 30#
61918272 31
3900e225 32%{!?min_kernel:%global min_kernel 2.4.6}
76131947 33%if "%{min_kernel}" < "2.6.0"
40240acb
JB
34%global nptl_min_kernel 2.6.0
35%else
36%global nptl_min_kernel %{min_kernel}
76131947 37%endif
40240acb 38
e03cf19f 39%if %{with tls}
c14df6fe 40# sparc temporarily removed (broken)
7adf02d6 41%ifnarch %{ix86} %{x8664} ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
e03cf19f
JB
42%undefine with_tls
43%endif
44%endif
45
40240acb 46%if %{with nptl}
472e31ee
JB
47# on x86 uses cmpxchgl (available since i486)
48# on sparc only sparcv9 is supported
7adf02d6 49%ifnarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
40240acb 50%undefine with_nptl
e03cf19f
JB
51%else
52%if %{without tls}
53%undefine with_nptl
3900e225 54%endif
61918272 55%endif
f3f771b7
AM
56%endif
57
e24149ab
PS
58%ifarch sparc64
59%undefine with_memusage
60%endif
61
40240acb
JB
62%if %{with linuxthreads} && %{with nptl}
63%define with_dual 1
64%endif
65
a643003b 66%define llh_version 7:2.6.10.0-3
e8c60795 67
236a5027 68Summary: GNU libc
69Summary(de): GNU libc
4a04bb32 70Summary(es): GNU libc
236a5027 71Summary(fr): GNU libc
c5387ad5 72