]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- merge locale changes from AC-branch
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
fd1d4127 10%bcond_without dist_kernel # for above, allow non-distribution kernel
2e1eb688
JB
11%bcond_without nptl # don't use NPTL (implies using linuxthreads)
12%bcond_without tls # don't use tls (implies no NPTL)
c9d8e545 13%bcond_with tests # perform "make test"
0a85848c 14%bcond_without localedb # don't build localedb-all (is time consuming)
61918272 15
b287d865 16#
37cd6ebc
JB
17# TODO:
18# - localedb-gen man pages(?)
4acad1ec 19# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
20# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
21# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
76f01b70 22#
61918272 23
3900e225 24%{!?min_kernel:%global min_kernel 2.4.6}
61918272 25
26%if %{with nptl}
dc3eddd2 27# it seems that nptl uses cmpxchgl (available since i486) on x86
dd75ad7c 28%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
76131947
AM
29%if "%{min_kernel}" < "2.6.0"
30%global min_kernel 2.6.0
31%endif
3900e225 32%endif
61918272 33%endif
61918272 34
f3f771b7 35%if %{with tls}
dd75ad7c 36%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 37%undefine with_tls
f3f771b7
AM
38%endif
39%endif
40
2e1eb688
JB
41%if %{without tls}
42# NPTL requires TLS
43%undefine with_nptl
44%endif
45
e24149ab
PS
46%ifarch sparc64
47%undefine with_memusage
48%endif
49
3e233c2a
MM
50%ifarch sparc
51%undefine with_nptl
19eda128 52%undefine with_tls
3e233c2a
MM
53%endif
54
121eb47e 55%define llh_version 7:2.6.6.0
78007e8e 56%define _snap 20041030
e8c60795 57
236a5027 58Summary: GNU libc
59Summary(de): GNU libc
4a04bb32 60Summary(es): GNU libc
236a5027 61Summary(fr): GNU libc
c5387ad5 62