]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- don't kill libpthread.so ld script
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
2e1eb688
JB
10%bcond_without nptl # don't use NPTL (implies using linuxthreads)
11%bcond_without tls # don't use tls (implies no NPTL)
757f96eb 12%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 13%bcond_with tests # perform "make test"
0a85848c 14%bcond_without localedb # don't build localedb-all (is time consuming)
61918272 15
b287d865 16#
37cd6ebc
JB
17# TODO:
18# - localedb-gen man pages(?)
4acad1ec 19# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
20# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
21# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
22# - problem compiling with --enable-bounded (must be reported to libc-alpha)
23# (is this comment still valid???)
24
76f01b70 25#
61918272 26
3900e225 27%{!?min_kernel:%global min_kernel 2.4.6}
61918272 28
29%if %{with nptl}
dc3eddd2 30# it seems that nptl uses cmpxchgl (available since i486) on x86
dd75ad7c 31%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
76131947
AM
32%if "%{min_kernel}" < "2.6.0"
33%global min_kernel 2.6.0
34%endif
3900e225 35%endif
61918272 36%endif
61918272 37
f3f771b7 38%if %{with tls}
dd75ad7c 39%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 40%undefine with_tls
f3f771b7
AM
41%endif
42%endif
43
2e1eb688
JB
44%if %{without tls}
45# NPTL requires TLS
46%undefine with_nptl
47%endif
48
e24149ab
PS
49%ifarch sparc64
50%undefine with_memusage
51%endif
52
3e233c2a 53%ifarch sparc
05743f54 54# broken
19eda128 55%undefine with_tls
3e233c2a
MM
56%endif
57
121eb47e 58%define llh_version 7:2.6.6.0
969145b1 59%define _snap 20041122
e8c60795 60
236a5027 61Summary: GNU libc
62Summary(de): GNU libc
4a04bb32 63Summary(es): GNU libc
236a5027 64Summary(fr): GNU libc
c5387ad5 65