]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
bogus
[packages/glibc.git] / glibc.spec
CommitLineData
c1c4a746 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
4#
5# Conditional build:
6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
9 # linux-libc-headers (evil, breakage etc., don't use)
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
14%bcond_without selinux # without SELinux support (in nscd)
15%bcond_with tests # perform "make test"
16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
17%bcond_without localedb # don't build localedb-all (is time consuming)
18%bcond_with cross # build using crossgcc (without libgcc_eh)
9adfa5ca 19%bcond_with pax # apply PaX hack
c1c4a746 20#
21# TODO:
22# - look at locale fixes/updates in bugzilla
23# [OLD]
24# - localedb-gen man pages(?)
25# - fix what trojan broke while upgreading (getaddrinfo-workaround)
26# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
27# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
28# - problem compiling with --enable-bounded (must be reported to libc-alpha)
29# (is this comment still valid???)
30#
31
32%{!?min_kernel:%global min_kernel 2.4.6}
33%if "%{min_kernel}" < "2.6.0"
34%global nptl_min_kernel 2.6.0
35%else
36%global nptl_min_kernel %{min_kernel}
37%endif
38
39%if %{with tls}
40# sparc temporarily removed (broken)
9d12badb 41%ifnarch %{ix86} %{x8664} ia64 alpha s390 s390x
83beae24 42# sparc64 sparcv9 ppc ppc64 -- disabled in AC (gcc < 3.4)
c1c4a746 43%undefine with_tls
44%endif
45%endif
46
47%if %{with nptl}
48# on x86 uses cmpxchgl (available since i486)
49# on sparc only sparcv9 is supported
9d12badb 50%ifnarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} ia64 alpha s390 s390x
83beae24 51# sparc64 sparcv9 ppc ppc64 -- disabled in AC (gcc < 3.4)
c1c4a746 52%undefine with_nptl
53%else
54%if %{without tls}
55%undefine with_nptl
56%endif
57%endif
58%endif
59
60%ifarch sparc64
61%undefine with_memusage
62%endif
63
64%if %{with linuxthreads} && %{with nptl}
65%define with_dual 1
66%endif
67
3872159c 68%define llh_version 7:2.6.10.0-3
c1c4a746 69
70Summary: GNU libc
71Summary(de): GNU libc
72Summary(es): GNU libc
73Summary(fr): GNU libc
74