]> git.pld-linux.org Git - packages/glib2.git/commitdiff
- added python_shebang patch (call python3 directly); release 2 auto/th/glib2-2.62.4-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 20 Dec 2019 18:14:37 +0000 (19:14 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 20 Dec 2019 18:14:37 +0000 (19:14 +0100)
glib2-python_shebang.patch [new file with mode: 0644]
glib2.spec

diff --git a/glib2-python_shebang.patch b/glib2-python_shebang.patch
new file mode 100644 (file)
index 0000000..eb48fcf
--- /dev/null
@@ -0,0 +1,43 @@
+--- glib-2.62.4/meson.build.orig       2019-12-19 17:33:15.000000000 +0100
++++ glib-2.62.4/meson.build    2019-12-20 18:37:03.307665835 +0100
+@@ -1988,7 +1988,7 @@
+ python = import('python').find_installation('python3')
+ # used for '#!/usr/bin/env <name>'
+-python_name = 'python3'
++python_name = python.path()
+ python_version = python.language_version()
+ python_version_req = '>=3.4'
+--- glib-2.62.4/gio/gdbus-2.0/codegen/gdbus-codegen.in.orig    2019-12-19 17:33:15.000000000 +0100
++++ glib-2.62.4/gio/gdbus-2.0/codegen/gdbus-codegen.in 2019-12-20 18:38:55.327058974 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env @PYTHON@
++#!@PYTHON@
+ # GDBus - GLib D-Bus Library
+ #
+--- glib-2.62.4/glib/gtester-report.in.orig    2019-12-19 17:33:15.000000000 +0100
++++ glib-2.62.4/glib/gtester-report.in 2019-12-20 18:38:21.813907197 +0100
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env @PYTHON@
++#!@PYTHON@
+ # GLib Testing Framework Utility                      -*- Mode: python; -*-
+ # Copyright (C) 2007 Imendio AB
+ # Authors: Tim Janik
+--- glib-2.62.4/gobject/glib-genmarshal.in.orig        2019-12-19 17:33:15.000000000 +0100
++++ glib-2.62.4/gobject/glib-genmarshal.in     2019-12-20 18:37:54.627387812 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env @PYTHON@
++#!@PYTHON@
+ # pylint: disable=too-many-lines, missing-docstring, invalid-name
+--- glib-2.62.4/gobject/glib-mkenums.in.orig   2019-12-19 17:33:15.000000000 +0100
++++ glib-2.62.4/gobject/glib-mkenums.in        2019-12-20 18:38:03.210674646 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env @PYTHON@
++#!@PYTHON@
+ # If the code below looks horrible and unpythonic, do not panic.
+ #
index a34c9426b86ad2b1c1e75cb5da6eba412e70b7c1..b1a038b39053af9b38c335a161def0519de56627 100644 (file)
@@ -20,12 +20,13 @@ Summary(tr.UTF-8):  Yararlı ufak yordamlar kitaplığı
 Summary(zh_CN.UTF-8):  实用工具函数库
 Name:          glib2
 Version:       2.62.4
-Release:       1
+Release:       2
 Epoch:         1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/glib/2.62/glib-%{version}.tar.xz
 # Source0-md5: d52234ecba128932bed90bbc3553bfe5
+Patch0:                %{name}-python_shebang.patch
 URL:           https://www.gtk.org/
 BuildRequires: docbook-dtd412-xml
 BuildRequires: docbook-dtd45-xml
@@ -232,6 +233,7 @@ Sondy systemtap/dtrace dla GLib 2.
 
 %prep
 %setup -q -n glib-%{version}
+%patch0 -p1
 
 %build
 %meson build \
This page took 0.562728 seconds and 4 git commands to generate.