]> git.pld-linux.org Git - packages/gjs.git/blame_incremental - gjs.spec
- updated to 1.64.4
[packages/gjs.git] / gjs.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without sysprof # sysprof profiling
4%bcond_without systemtap # systemtap/dtrace trace support
5#
6Summary: JavaScript bindings for GNOME
7Summary(pl.UTF-8): Wiązania JavaScriptu dla GNOME
8Name: gjs
9Version: 1.64.4
10Release: 1
11License: MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
12Group: Libraries
13Source0: http://ftp.gnome.org/pub/GNOME/sources/gjs/1.64/%{name}-%{version}.tar.xz
14# Source0-md5: dc0d4a0453484c5a77eb0e2bda091704
15URL: https://wiki.gnome.org/Projects/Gjs
16BuildRequires: autoconf >= 2.64
17BuildRequires: automake >= 1:1.11.1
18BuildRequires: cairo-devel
19BuildRequires: cairo-gobject-devel
20BuildRequires: gettext-tools
21BuildRequires: glib2-devel >= 1:2.58.0
22BuildRequires: gobject-introspection-devel >= 1.61.2
23BuildRequires: libffi-devel
24BuildRequires: libstdc++-devel >= 6:5.0
25BuildRequires: libtool >= 2:2.2.0
26BuildRequires: meson >= 0.50.0
27BuildRequires: mozjs68-devel >= 68
28BuildRequires: ninja >= 1.5
29BuildRequires: pkgconfig
30BuildRequires: readline-devel
31BuildRequires: rpmbuild(macros) >= 1.736
32# pkgconfig(sysprof-capture-3)
33%{?with_sysprof:BuildRequires: sysprof-devel >= 3.34}
34%{?with_systemtap:BuildRequires: systemtap-sdt-devel}
35BuildRequires: tar >= 1:1.22
36BuildRequires: xz
37Requires: glib2 >= 1:2.58.0
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Gjs allows using GNOME libraries from JavaScript. It is mainly based
42on Spidermonkey JavaScript engine and the GObject introspection
43framework.
44
45%description -l pl.UTF-8
46Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
47na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
48
49%package devel
50Summary: Header files for gjs library
51Summary(pl.UTF-8): Pliki nagłówkowe biblioteki gjs
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: cairo-devel
55Requires: cairo-gobject-devel
56Requires: glib2-devel >= 1:2.58.0
57Requires: gobject-introspection-devel >= 1.61.2
58Requires: libffi-devel
59Requires: mozjs60-devel >= 60
60
61%description devel
62Header files for gjs library.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe biblioteki gjs.
66
67%package -n systemtap-gjs
68Summary: systemtap/dtrace probes for gjs
69Summary(pl.UTF-8): Sondy systemtap/dtrace dla gjs
70Group: Development/Tools
71Requires: %{name} = %{version}-%{release}
72Requires: systemtap-client
73
74%description -n systemtap-gjs
75systemtap/dtrace probes for gjs.
76
77%description -n systemtap-gjs -l pl.UTF-8
78Sondy systemtap/dtrace dla gjs.
79
80%prep
81%setup -q
82
83%build
84%meson build \
85 -Dprofiler=%{?with_sysprof:enabled}%{!?with_sysprof:disabled} \
86 -Dsystemtap=%{__true_false systemtap} \
87 -Ddtrace=%{__true_false systemtap}
88
89%ninja_build -C build
90
91%install
92rm -rf $RPM_BUILD_ROOT
93install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95%ninja_install -C build
96
97cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
98
99# belongs to installed-tests
100%{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
101%{__rm} -r $RPM_BUILD_ROOT{%{_datadir},%{_libexecdir}/gjs}/installed-tests
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
109%files
110%defattr(644,root,root,755)
111%doc COPYING NEWS README.md
112%attr(755,root,root) %{_bindir}/gjs
113%attr(755,root,root) %{_bindir}/gjs-console
114%attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
115%attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
116%dir %{_libdir}/gjs
117%dir %{_libdir}/gjs/girepository-1.0
118%{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
119%{_datadir}/gjs-1.0
120
121%files devel
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_libdir}/libgjs.so
124%{_includedir}/gjs-1.0
125%{_pkgconfigdir}/gjs-1.0.pc
126%{_examplesdir}/%{name}-%{version}
127
128%files -n systemtap-gjs
129%defattr(644,root,root,755)
130%{_datadir}/systemtap/tapset/gjs.stp
This page took 0.045664 seconds and 4 git commands to generate.