]> git.pld-linux.org Git - packages/gjs.git/blame - gjs.spec
- updated to 1.72.2
[packages/gjs.git] / gjs.spec
CommitLineData
95911c7e
JB
1#
2# Conditional build:
aee54d63 3%bcond_without sysprof # sysprof profiling
95911c7e 4%bcond_without systemtap # systemtap/dtrace trace support
68e1bbed 5#
d1e21e3e 6Summary: JavaScript bindings for GNOME
ae612451 7Summary(pl.UTF-8): Wiązania JavaScriptu dla GNOME
d1e21e3e 8Name: gjs
468b1377 9Version: 1.72.2
e3f8969d 10Release: 1
ae612451 11License: MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
d1e21e3e 12Group: Libraries
66539832 13Source0: https://download.gnome.org/sources/gjs/1.72/%{name}-%{version}.tar.xz
468b1377 14# Source0-md5: e0a715951ee3941132f5b1149f28ba5d
c4adf36e 15URL: https://wiki.gnome.org/Projects/Gjs
d2570104
AF
16BuildRequires: cairo-devel
17BuildRequires: cairo-gobject-devel
dee0d724 18BuildRequires: gettext-tools
b905d295
JB
19BuildRequires: glib2-devel >= 1:2.66.0
20BuildRequires: gobject-introspection-devel >= 1.66.1
118870d4 21BuildRequires: libffi-devel
e3f8969d 22BuildRequires: libstdc++-devel >= 6:7.0
e3f8969d 23BuildRequires: meson >= 0.52.0
66539832 24BuildRequires: mozjs91-devel >= 91.3.0
f7239c5e 25BuildRequires: ninja >= 1.5
d1e21e3e 26BuildRequires: pkgconfig
d2570104 27BuildRequires: readline-devel
b905d295 28BuildRequires: rpm-build >= 4.6
f7239c5e 29BuildRequires: rpmbuild(macros) >= 1.736
e3f8969d
JB
30# pkgconfig(sysprof-capture-4)
31%{?with_sysprof:BuildRequires: sysprof-devel >= 3.36}
95911c7e 32%{?with_systemtap:BuildRequires: systemtap-sdt-devel}
1c06e8ee
JB
33BuildRequires: tar >= 1:1.22
34BuildRequires: xz
b905d295 35Requires: glib2 >= 1:2.66.0
d1e21e3e
MB
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Gjs allows using GNOME libraries from JavaScript. It is mainly based
40on Spidermonkey JavaScript engine and the GObject introspection
41framework.
42
43%description -l pl.UTF-8
ae612451
JB
44Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
45na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
d1e21e3e
MB
46
47%package devel
48Summary: Header files for gjs library
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki gjs
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
ee5cf52a
JB
52Requires: cairo-devel
53Requires: cairo-gobject-devel
b905d295
JB
54Requires: glib2-devel >= 1:2.66.0
55Requires: gobject-introspection-devel >= 1.66.0
ee5cf52a 56Requires: libffi-devel
66539832 57Requires: mozjs91-devel >= 91.3.0
d1e21e3e
MB
58
59%description devel
60Header files for gjs library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki gjs.
64
95911c7e
JB
65%package -n systemtap-gjs
66Summary: systemtap/dtrace probes for gjs
67Summary(pl.UTF-8): Sondy systemtap/dtrace dla gjs
68Group: Development/Tools
69Requires: %{name} = %{version}-%{release}
70Requires: systemtap-client
b905d295 71BuildArch: noarch
95911c7e
JB
72
73%description -n systemtap-gjs
74systemtap/dtrace probes for gjs.
75
76%description -n systemtap-gjs -l pl.UTF-8
77Sondy systemtap/dtrace dla gjs.
78
d1e21e3e
MB
79%prep
80%setup -q
81
82%build
a9efafad
JR
83%meson build \
84 -Dprofiler=%{?with_sysprof:enabled}%{!?with_sysprof:disabled} \
85 -Dsystemtap=%{__true_false systemtap} \
86 -Ddtrace=%{__true_false systemtap}
87
88%ninja_build -C build
d1e21e3e
MB
89
90%install
91rm -rf $RPM_BUILD_ROOT
0a8630ec 92install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
d1e21e3e 93
a9efafad 94%ninja_install -C build
d1e21e3e 95
aee54d63 96cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
d1e21e3e 97
aee54d63
JB
98# belongs to installed-tests
99%{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
e3f8969d 100%{__rm} -r $RPM_BUILD_ROOT{%{_datadir},%{_libexecdir}}/installed-tests
d1e21e3e
MB
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
a9efafad 110%doc COPYING NEWS README.md
d1e21e3e
MB
111%attr(755,root,root) %{_bindir}/gjs
112%attr(755,root,root) %{_bindir}/gjs-console
d1e21e3e
MB
113%attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
1ec4cb2a
ŁK
115%dir %{_libdir}/gjs
116%dir %{_libdir}/gjs/girepository-1.0
117%{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
e8f0ae7c 118%{_datadir}/gjs-1.0
d1e21e3e
MB
119
120%files devel
121%defattr(644,root,root,755)
d1e21e3e 122%attr(755,root,root) %{_libdir}/libgjs.so
d1e21e3e
MB
123%{_includedir}/gjs-1.0
124%{_pkgconfigdir}/gjs-1.0.pc
d1e21e3e 125%{_examplesdir}/%{name}-%{version}
95911c7e 126
ab1adb5b 127%if %{with systemtap}
95911c7e
JB
128%files -n systemtap-gjs
129%defattr(644,root,root,755)
130%{_datadir}/systemtap/tapset/gjs.stp
ab1adb5b 131%endif
This page took 0.124064 seconds and 4 git commands to generate.