]> git.pld-linux.org Git - packages/gitlab-runner.git/commitdiff
up to 9.1.1
authorElan Ruusamäe <glen@delfi.ee>
Tue, 16 May 2017 10:15:53 +0000 (13:15 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 16 May 2017 10:15:53 +0000 (13:15 +0300)
compilation fails

branch-preserver.patch
gitlab-ci-multi-runner.spec
nodim_gz.patch

index 12ba9ef15f2ae7298f3d7e2718f2333c7be09c28..bf6a1209e3635c923fbfb14023e5bdc927d7850f 100644 (file)
@@ -1,17 +1,15 @@
-diff --git a/shells/abstract.go b/shells/abstract.go
-index e4ae2b0..f3cb56b 100644
---- a/shells/abstract.go
-+++ b/shells/abstract.go
-@@ -99,7 +99,11 @@ func (b *AbstractShell) writeFetchCmd(w ShellWriter, build *common.Build, projec
+--- gitlab-ci-multi-runner/shells/abstract.go~ 2017-05-02 13:12:18.000000000 +0300
++++ gitlab-ci-multi-runner/shells/abstract.go  2017-05-16 08:10:46.528840805 +0300
+@@ -96,7 +96,11 @@
  
  func (b *AbstractShell) writeCheckoutCmd(w ShellWriter, build *common.Build) {
-       w.Notice("Checking out %s as %s...", build.Sha[0:8], build.RefName)
--      w.Command("git", "checkout", "-f", "-q", build.Sha)
-+      if build.Tag {
-+              w.Command("git", "checkout", "-f", "-q", build.Sha)
+       w.Notice("Checking out %s as %s...", build.GitInfo.Sha[0:8], build.GitInfo.Ref)
+-      w.Command("git", "checkout", "-f", "-q", build.GitInfo.Sha)
++      if build.GitInfo.RefType == common.RefTypeTag {
++              w.Command("git", "checkout", "-f", "-q", build.GitInfo.Sha)
 +      } else {
-+              w.Command("git", "checkout", "-fq", "-B", build.RefName, build.Sha)
++              w.Command("git", "checkout", "-fq", "-B", build.GitInfo.Ref, build.GitInfo.Sha)
 +      }
  }
  
- func (b *AbstractShell) cacheFile(build *common.Build, userKey string) (key, file string) {
+ func (b *AbstractShell) writeSubmoduleUpdateCmd(w ShellWriter, build *common.Build, recursive bool) {
index 45d4aa47b76c15a5a902c6b53d39b1278bc12d14..0d1b8c0417f990e3c36b1a792fbe1a4a2416f698 100644 (file)
@@ -1,11 +1,11 @@
 Summary:       The official GitLab CI runner written in Go
 Name:          gitlab-ci-multi-runner
-Version:       1.10.0
-Release:       1
+Version:       9.1.1
+Release:       0.1
 License:       MIT
 Group:         Development/Building
 Source0:       https://gitlab.com/gitlab-org/gitlab-ci-multi-runner/repository/archive.tar.gz?ref=v%{version}&/%{name}-%{version}.tar.gz
-# Source0-md5: fb2034a3c976d0abc2ae1579df3adf93
+# Source0-md5: 06776a8b070bc741a7ec3d33c7bce7ab
 Source3:       %{name}.init
 Source4:       %{name}.sysconfig
 Source5:       %{name}.service
index b23df7a989381e68ec75f1f35bbc98b5ed0ae0c4..5de4cb0b8ce17548f8796ef8e98b2e11f577c411 100644 (file)
@@ -4,10 +4,10 @@ Bug-Upstream: https://gitlab.com/gitlab-org/gitlab-ci-multi-runner/issues/1504
 Author: Dmitry Smirnov <onlyjob@debian.org>
 Description: do not incorporate Docker image into executable.
 
---- gitlab-ci-multi-runner/executors/docker/executor_docker.go~        2016-12-22 16:21:38.000000000 +0200
-+++ gitlab-ci-multi-runner/executors/docker/executor_docker.go 2016-12-23 14:41:59.425571451 +0200
-@@ -208,17 +208,11 @@
-               return
+--- gitlab-ci-multi-runner/executors/docker/executor_docker.go~        2017-05-02 13:12:18.000000000 +0300
++++ gitlab-ci-multi-runner/executors/docker/executor_docker.go 2017-05-16 08:08:28.042038918 +0300
+@@ -228,16 +228,11 @@
+               return &image, nil
        }
  
 -      data, err := Asset("prebuilt-" + architecture + prebuiltImageExtension)
@@ -16,12 +16,11 @@ Description: do not incorporate Docker image into executable.
 -      }
 -
        s.Debugln("Loading prebuilt image...")
-       err = s.client.ImportImage(docker.ImportImageOptions{
-               Repository:  prebuiltImageName,
-               Tag:         architecture + "-" + common.REVISION,
--              Source:      "-",
--              InputStream: bytes.NewBuffer(data),
+       ref := prebuiltImageName
+       source := types.ImageImportSource{
+-              Source:     bytes.NewBuffer(data),
 +              Source:      "/var/lib/gitlab-runner/prebuilt-" + architecture + ".tar.xz",
-       })
-       if err != nil {
-               return
+               SourceName: "-",
+       }
+       options := types.ImageImportOptions{
This page took 0.047093 seconds and 4 git commands to generate.