]> git.pld-linux.org Git - packages/gitlab-runner.git/commitdiff
version the build image as package version
authorElan Ruusamäe <glen@delfi.ee>
Thu, 24 Nov 2016 21:58:44 +0000 (23:58 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 24 Nov 2016 21:58:44 +0000 (23:58 +0200)
do this for simplicity
this creates new tags each time runner is upgraded
possibly from same tar.xz

gitlab-ci-multi-runner.spec

index d5e0797617d7c6dc105e9de41decbf39cca78c16..fab8bbd4a356f2aa7621d439d9dd418d6c520e51 100644 (file)
@@ -1,10 +1,3 @@
-
-# the revision for images
-# $ git fetch https://gitlab.com/gitlab-org/gitlab-ci-multi-runner refs/tags/v1.6.0
-# $ git rev-list -n 1 --abbrev-commit FETCH_HEAD
-#define revision 76fdacd
-# No changes to image, so don't refetch it
-%define revision 1.5.2
 Summary:       The official GitLab CI runner written in Go
 Name:          gitlab-ci-multi-runner
 Version:       1.8.0
@@ -84,7 +77,7 @@ export PATH=$(pwd):$PATH
 %{__make} version | tee version.txt
 
 CN=gitlab.com/gitlab-org/gitlab-ci-multi-runner/common
-LDFLAGS="-X $CN.NAME=gitlab-ci-multi-runner -X $CN.VERSION=%{version} -X $CN.REVISION=%{revision}"
+LDFLAGS="-X $CN.NAME=gitlab-ci-multi-runner -X $CN.VERSION=%{version} -X $CN.REVISION=%{version}"
 %gobuild
 
 # verify that version matches
This page took 0.062073 seconds and 4 git commands to generate.