]> git.pld-linux.org Git - packages/gitlab-runner.git/blame - gitlab-ci-multi-runner.spec
always avoid docker
[packages/gitlab-runner.git] / gitlab-ci-multi-runner.spec
CommitLineData
c5c6476d
ER
1Summary: The official GitLab CI runner written in Go
2Name: gitlab-ci-multi-runner
eac9a939 3Version: 1.1.3
4ffe1735 4Release: 1
c5c6476d
ER
5License: GPL v3
6Group: Development/Building
7Source0: https://gitlab.com/gitlab-org/gitlab-ci-multi-runner/repository/archive.tar.gz?ref=v%{version}&/%{name}-%{version}.tar.gz
eac9a939 8# Source0-md5: 3ce0499c2ee0bca486dcdaf1bb01d2d1
4ffe1735
ER
9Source1: https://gitlab-ci-multi-runner-downloads.s3.amazonaws.com/master/docker/prebuilt.tar.gz
10# Source1-md5: d616dcc457a6ce69bed4af2ca08dfe0a
c5c6476d
ER
11URL: https://gitlab.com/gitlab-org/gitlab-ci-multi-runner
12BuildRequires: git-core
4ffe1735 13BuildRequires: go-bindata >= 3.0.7-1.a0ff2567
c5c6476d
ER
14BuildRequires: golang
15Requires: ca-certificates
16Requires: curl
17Requires: git-core
18Requires: tar
4ffe1735 19ExclusiveArch: %{ix86} %{x8664} %{arm}
c5c6476d
ER
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
4ffe1735
ER
22# go stuff
23%define _enable_debug_packages 0
24%define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
25
c5c6476d
ER
26%description
27This is the official GitLab Runner written in Go. It runs tests and
28sends the results to GitLab. GitLab CI is the open-source continuous
29integration service included with GitLab that coordinates the testing.
30
31%prep
32%setup -qc
33mv gitlab-ci-multi-runner-*/{.??*,*} .
34
bf2084d5
ER
35install -d Godeps/_workspace/src/gitlab.com/gitlab-org
36ln -s ../../../../.. Godeps/_workspace/src/gitlab.com/gitlab-org/gitlab-ci-multi-runner
37
4ffe1735
ER
38mkdir -p out/docker
39ln -s %{SOURCE1} out/docker/prebuilt.tar.gz
6ada5ccc
ER
40# touch, otherwise make rules would download it nevertheless
41touch out/docker/prebuilt.tar.gz
4ffe1735 42
a0a05733
ER
43# avoid docker being used even if executable found
44cat <<'EOF' > docker
45#!/bin/sh
46echo >&2 "No docker"
47exit 1
48EOF
49chmod a+rx docker
50
c5c6476d 51%build
bf2084d5 52export GOPATH=$(pwd):$(pwd)/Godeps/_workspace
a0a05733 53export PATH=$(pwd):$PATH
bf2084d5 54
4ffe1735
ER
55%{__make} docker
56%gobuild
c5c6476d
ER
57
58%install
59rm -rf $RPM_BUILD_ROOT
4ffe1735
ER
60install -d $RPM_BUILD_ROOT%{_bindir}
61install -p %{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
c5c6476d
ER
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc README.md CHANGELOG.md
4ffe1735 69%attr(755,root,root) %{_bindir}/gitlab-ci-multi-runner
This page took 0.075809 seconds and 4 git commands to generate.