]> git.pld-linux.org Git - packages/git-core.git/commitdiff
- fix for key bindings in SHA1 bar
authorKacper Kornet <draenog@pld-linux.org>
Mon, 7 Feb 2011 16:37:53 +0000 (16:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    git-core-key-bindings.patch -> 1.1
    git-core.spec -> 1.233

git-core-key-bindings.patch [new file with mode: 0644]
git-core.spec

diff --git a/git-core-key-bindings.patch b/git-core-key-bindings.patch
new file mode 100644 (file)
index 0000000..0f3c17f
--- /dev/null
@@ -0,0 +1,45 @@
+From 2ad6d3e9325a39333be0c4b9094e9d5e756dea65 Mon Sep 17 00:00:00 2001
+From: Kacper <kornet@tuptus>
+Date: Thu, 9 Dec 2010 18:57:06 +0000
+Subject: [PATCH] Preserve Entry class key bindings for SHA id
+
+If bind is specified for key without any modifier, then any combination
+of modifiers may be present in the event. So bind $e $ev "$escript;
+break" breaks some useful bindings from Entry class (for example
+Ctrl+k).
+---
+ gitk |   10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git gitk-git/gitk gitk-git/gitk
+index 45e3380..0c6f3af 100755
+--- gitk-git/gitk
++++ gitk-git/gitk
+@@ -2365,6 +2365,10 @@ proc makewindow {} {
+         }
+     }
++    foreach e $entries {
++        bindtags $e [linsert [bindtags $e] 2 entrybind]
++    }
++
+     bind .pwbottom <Configure> {resizecdetpanes %W %w}
+     pack .ctop -fill both -expand 1
+     bindall <1> {selcanvline %W %x %y}
+@@ -2563,12 +2567,8 @@ proc scrollcanv {cscroll f0 f1} {
+ proc bindkey {ev script} {
+     global entries
+     bind . $ev $script
+-    set escript [bind Entry $ev]
+-    if {$escript == {}} {
+-      set escript [bind Entry <Key>]
+-    }
+     foreach e $entries {
+-      bind $e $ev "$escript; break"
++      bind entrybind $ev "break"
+     }
+ }
+-- 
+1.7.3.3
+
index 8e111e973b762e41848359185a03f32aff6f749a..5357dee3076d1fba9d61c35b411fd4f0c2768615 100644 (file)
@@ -21,6 +21,7 @@ Source4:      %{name}.sysconfig
 Source5:       %{name}.inet
 Source6:       %{name}.init
 Patch0:                %{name}-tests.patch
 Source5:       %{name}.inet
 Source6:       %{name}.init
 Patch0:                %{name}-tests.patch
+Patch1:                %{name}-key-bindings.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf
 BuildRequires: automake
 URL:           http://git-scm.com/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -368,6 +369,7 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %prep
 %setup -q -n git-%{version}
 %patch0 -p1
 %prep
 %setup -q -n git-%{version}
 %patch0 -p1
+%patch1 -p0
 
 %build
 %{__aclocal}
 
 %build
 %{__aclocal}
This page took 0.053226 seconds and 4 git commands to generate.