]> git.pld-linux.org Git - packages/git-core.git/commitdiff
up to 2.12.1 auto/th/git-core-2.12.1-1
authorJan Palus <atler@pld-linux.org>
Wed, 22 Mar 2017 19:38:43 +0000 (20:38 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 22 Mar 2017 19:39:08 +0000 (20:39 +0100)
- gitview removed by upstream (unused/unmaintained)
- dropped outdated test patch
- fixed tests with incorrectly terminated << operator

git-core-t5615.patch [deleted file]
git-core-tests.patch
git-core.spec

diff --git a/git-core-t5615.patch b/git-core-t5615.patch
deleted file mode 100644 (file)
index 1637c65..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urN git-2.11.1.orig/t/t5615-alternate-env.sh git-2.11.1/t/t5615-alternate-env.sh
---- git-2.11.1.orig/t/t5615-alternate-env.sh   2017-02-03 02:24:45.115143042 +0100
-+++ git-2.11.1/t/t5615-alternate-env.sh        2017-02-03 02:24:58.081809318 +0100
-@@ -77,6 +77,7 @@
-       check_obj "$quoted:$unquoted" <<-EOF
-       $one blob
-       $two blob
-+      EOF
- '
- test_expect_success !MINGW 'broken quoting falls back to interpreting raw' '
index 0bbfc3db08badc30e0501cf23f6b5f0cd6801f75..b71a8cd6a54d30a5f52dc9be30641666cda501e6 100644 (file)
@@ -1,13 +1,82 @@
-diff -ur git-1.7.0.3.orig/t/t1304-default-acl.sh git-1.7.0.3/t/t1304-default-acl.sh
---- git-1.7.0.3.orig/t/t1304-default-acl.sh    2010-03-22 01:35:03.000000000 +0000
-+++ git-1.7.0.3/t/t1304-default-acl.sh 2010-03-23 19:53:49.069813289 +0000
-@@ -9,6 +9,8 @@
- # => this must come before . ./test-lib.sh
- umask 077
-+LOGNAME=$(whoami)
-+
- . ./test-lib.sh
- # We need an arbitrary other user give permission to using ACLs. root
-
+diff -ur git-2.12.1.orig/t/t5615-alternate-env.sh git-2.12.1/t/t5615-alternate-env.sh
+--- git-2.12.1.orig/t/t5615-alternate-env.sh   2017-03-22 18:52:45.344354935 +0100
++++ git-2.12.1/t/t5615-alternate-env.sh        2017-03-22 18:52:59.320917887 +0100
+@@ -77,6 +77,7 @@
+       check_obj "$quoted:$unquoted" <<-EOF
+       $one blob
+       $two blob
++      EOF
+ '
+ test_expect_success !MINGW 'broken quoting falls back to interpreting raw' '
+diff -ur git-2.12.1.orig/t/t7004-tag.sh git-2.12.1/t/t7004-tag.sh
+--- git-2.12.1.orig/t/t7004-tag.sh     2017-03-22 18:52:45.347688243 +0100
++++ git-2.12.1/t/t7004-tag.sh  2017-03-22 18:53:28.757366131 +0100
+@@ -880,21 +880,13 @@
+ '
+ test_expect_success 'verifying a proper tag with --format pass and format accordingly' '
+-      cat >expect <<-\EOF
++      cat >expect <<-\EOF &&
+       tagname : signed-tag
+-      EOF &&
++      EOF
+       git tag -v --format="tagname : %(tag)" "signed-tag" >actual &&
+       test_cmp expect actual
+ '
+-test_expect_success 'verifying a forged tag with --format fail and format accordingly' '
+-      cat >expect <<-\EOF
+-      tagname : forged-tag
+-      EOF &&
+-      test_must_fail git tag -v --format="tagname : %(tag)" "forged-tag" >actual &&
+-      test_cmp expect actual
+-'
+-
+ # blank and empty messages for signed tags:
+ get_tag_header empty-signed-tag $commit commit $time >expect
+--- git-2.12.1.orig/t/t7030-verify-tag.sh      2017-03-22 18:52:45.347688243 +0100
++++ git-2.12.1/t/t7030-verify-tag.sh   2017-03-22 19:06:41.894375653 +0100
+@@ -126,19 +126,11 @@
+ '
+ test_expect_success 'verifying tag with --format' '
+-      cat >expect <<-\EOF
++      cat >expect <<-\EOF &&
+       tagname : fourth-signed
+-      EOF &&
++      EOF
+       git verify-tag --format="tagname : %(tag)" "fourth-signed" >actual &&
+       test_cmp expect actual
+ '
+-test_expect_success 'verifying a forged tag with --format fail and format accordingly' '
+-      cat >expect <<-\EOF
+-      tagname : 7th forged-signed
+-      EOF &&
+-      test_must_fail git verify-tag --format="tagname : %(tag)" $(cat forged1.tag) >actual-forged &&
+-      test_cmp expect actual-forged
+-'
+-
+ test_done
+--- git-2.12.1.orig/t/t7406-submodule-update.sh        2017-03-22 18:52:45.347688243 +0100
++++ git-2.12.1/t/t7406-submodule-update.sh     2017-03-22 19:16:48.043071963 +0100
+@@ -440,17 +440,6 @@
+       ) &&
+       test_i18ncmp actual expect
+ '
+-
+-test_expect_success 'submodule update - command run for initial population of submodule' '
+-      cat <<-\ EOF >expect
+-      Execution of '\''false $submodulesha1'\'' failed in submodule path '\''submodule'\''
+-      EOF &&
+-      rm -rf super/submodule &&
+-      test_must_fail git -C super submodule update >../actual &&
+-      test_cmp expect actual &&
+-      git -C super submodule update --checkout
+-'
+-
+ cat << EOF >expect
+ Execution of 'false $submodulesha1' failed in submodule path '../super/submodule'
+ Failed to recurse into submodule path '../super'
index afcd9ebf1c8f5fa2ae6d2d09534e7e4ace36805c..6ba2983043d4f90415cbfd3a4740943cc5334e3e 100644 (file)
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       2.11.1
+Version:       2.12.1
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
-# Source0-md5: 2970ae6cd234b2fca4f2d14ba4226f35
+# Source0-md5: 8aa0430bd7476a51c983dc68cc03f6b9
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -31,7 +31,6 @@ Patch0:               %{name}-tests.patch
 Patch1:                %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
 Patch3:                cherry-picked-commitlog.patch
 Patch1:                %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
 Patch3:                cherry-picked-commitlog.patch
-Patch4:                %{name}-t5615.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -91,6 +90,7 @@ Suggests:     git-core-svn
 Suggests:      less
 Suggests:      openssh-clients
 Suggests:      rsync
 Suggests:      less
 Suggests:      openssh-clients
 Suggests:      rsync
+Obsoletes:     git-core-gitview
 Obsoletes:     python-Git
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 Obsoletes:     python-Git
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -257,26 +257,6 @@ This package provides a web interface for browsing git repositories.
 %description gitweb -l pl.UTF-8
 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
 
 %description gitweb -l pl.UTF-8
 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
 
-%package gitview
-Summary:       A GTK+ based repository browser for git
-Summary(pl.UTF-8):     Oparta na GTK+ przeglądarka repozytorium gita
-Group:         Development/Tools
-Requires:      %{name} = %{version}-%{release}
-Requires:      python >= 1:2.4
-Requires:      python-pycairo >= 1.0
-Requires:      python-pygobject
-Requires:      python-pygtk-gtk >= 2:2.8
-Suggests:      python-gnome-desktop-gtksourceview
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
-
-%description gitview
-A GTK+ based repository browser for git.
-
-%description gitview -l pl.UTF-8
-Oparta na GTK+ przeglądarka repozytorium gita.
-
 %package gui
 Summary:       Tcl/Tk interface to the Git version control system
 Summary(pl.UTF-8):     Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
 %package gui
 Summary:       Tcl/Tk interface to the Git version control system
 Summary(pl.UTF-8):     Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
@@ -481,7 +461,6 @@ Moduł trzeba zarejestrować poleceniem:
 %patch1 -p0
 %patch2 -p1
 %patch3 -p1
 %patch1 -p0
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
 
 
 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
 
@@ -593,9 +572,6 @@ cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
-# gitview
-install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
-
 # git-daemon related files
 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
 # git-daemon related files
 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
@@ -779,6 +755,7 @@ fi
 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
+%lang(pt_PT) %{_datadir}/gitk/lib/msgs/pt_pt.msg
 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
@@ -801,11 +778,6 @@ fi
 %{_mandir}/man5/gitweb.conf.5*
 %endif
 
 %{_mandir}/man5/gitweb.conf.5*
 %endif
 
-%files gitview
-%defattr(644,root,root,755)
-%doc contrib/gitview/gitview.txt
-%attr(755,root,root) %{_bindir}/gitview
-
 %if %{with tk}
 %files gui
 %defattr(644,root,root,755)
 %if %{with tk}
 %files gui
 %defattr(644,root,root,755)
This page took 0.07862 seconds and 4 git commands to generate.