]> git.pld-linux.org Git - packages/git-core.git/commitdiff
up to 2.29.0 auto/th/git-core-2.29.0-1
authorJan Palus <atler@pld-linux.org>
Mon, 19 Oct 2020 20:49:51 +0000 (22:49 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 19 Oct 2020 20:49:51 +0000 (22:49 +0200)
- adjusted gitk patches

cherry-picked-commitlog.patch
git-core-key-bindings.patch
git-core.spec

index fee97a7ac0c39d644af9475123fa2b6345ced676..eedf491d40d59467e289c563768f98f32e8db9e6 100644 (file)
@@ -1,13 +1,11 @@
-diff --git a/gitk-git/gitk.orig b/gitk-git/gitk
-index ce63a8c..4ae5a56 100755
---- a/gitk-git/gitk.orig
-+++ b/gitk-git/gitk
-@@ -9150,7 +9150,7 @@ proc cherrypick {} {
+--- git-2.29.0/gitk-git/gitk.orig      2020-10-19 21:40:17.774293686 +0200
++++ git-2.29.0/gitk-git/gitk   2020-10-19 21:43:33.023626764 +0200
+@@ -9711,7 +9711,7 @@
      update
      # Unfortunately git-cherry-pick writes stuff to stderr even when
      # no error occurs, and exec takes that as an indication of error...
 -    if {[catch {exec sh -c "git cherry-pick -r $rowmenuid 2>&1"} err]} {
 +    if {[catch {exec sh -c "git cherry-pick -x -r $rowmenuid 2>&1"} err]} {
      update
      # Unfortunately git-cherry-pick writes stuff to stderr even when
      # no error occurs, and exec takes that as an indication of error...
 -    if {[catch {exec sh -c "git cherry-pick -r $rowmenuid 2>&1"} err]} {
 +    if {[catch {exec sh -c "git cherry-pick -x -r $rowmenuid 2>&1"} err]} {
-       notbusy cherrypick
-       if {[regexp -line \
-                {Entry '(.*)' (would be overwritten by merge|not uptodate)} \
+         notbusy cherrypick
+         if {[regexp -line \
+                  {Entry '(.*)' (would be overwritten by merge|not uptodate)} \
index 0f3c17f8d275c0e345572097d511feb360448415..8cac40839a37ece1e385a2088589fc24ecea76c1 100644 (file)
@@ -15,31 +15,28 @@ diff --git gitk-git/gitk gitk-git/gitk
 index 45e3380..0c6f3af 100755
 --- gitk-git/gitk
 +++ gitk-git/gitk
 index 45e3380..0c6f3af 100755
 --- gitk-git/gitk
 +++ gitk-git/gitk
-@@ -2365,6 +2365,10 @@ proc makewindow {} {
-         }
+@@ -2528,6 +2528,10 @@
+         set ::BM "2"
      }
  
 +    foreach e $entries {
 +        bindtags $e [linsert [bindtags $e] 2 entrybind]
 +    }
 +
      }
  
 +    foreach e $entries {
 +        bindtags $e [linsert [bindtags $e] 2 entrybind]
 +    }
 +
-     bind .pwbottom <Configure> {resizecdetpanes %W %w}
-     pack .ctop -fill both -expand 1
-     bindall <1> {selcanvline %W %x %y}
-@@ -2563,12 +2567,8 @@ proc scrollcanv {cscroll f0 f1} {
+     if {$use_ttk} {
+         bind .ctop <Map> {
+             bind %W <Map> {}
+@@ -2759,12 +2763,8 @@
  proc bindkey {ev script} {
      global entries
      bind . $ev $script
 -    set escript [bind Entry $ev]
 -    if {$escript == {}} {
  proc bindkey {ev script} {
      global entries
      bind . $ev $script
 -    set escript [bind Entry $ev]
 -    if {$escript == {}} {
--      set escript [bind Entry <Key>]
+-        set escript [bind Entry <Key>]
 -    }
      foreach e $entries {
 -    }
      foreach e $entries {
--      bind $e $ev "$escript; break"
-+      bind entrybind $ev "break"
+-        bind $e $ev "$escript; break"
++        bind entrybind $ev "break"
      }
  }
  
      }
  }
  
--- 
-1.7.3.3
-
index f7c3dbd254810a433f4c818fd1cd7933b5637b6a..a91226c2f2e5e4288014c8b2e9d43c3c54d236ba 100644 (file)
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       2.28.0
+Version:       2.29.0
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
-# Source0-md5: 5fde0206768ed70092d1fcc8f447251a
+# Source0-md5: b07a283043e089dca8d2174d2654191b
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -741,7 +741,6 @@ fi
 %exclude %{gitcoredir}/git-instaweb
 %exclude %{gitcoredir}/git-remote-bzr
 %exclude %{gitcoredir}/git-remote-hg
 %exclude %{gitcoredir}/git-instaweb
 %exclude %{gitcoredir}/git-remote-bzr
 %exclude %{gitcoredir}/git-remote-hg
-%exclude %{gitcoredir}/git-remote-testsvn
 %exclude %{gitcoredir}/git-svn
 %exclude %{gitcoredir}/mergetools/p4merge
 %if %{with gnome_keyring}
 %exclude %{gitcoredir}/git-svn
 %exclude %{gitcoredir}/mergetools/p4merge
 %if %{with gnome_keyring}
@@ -876,7 +875,6 @@ fi
 %files svn
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-svn
 %files svn
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-svn
-%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
 %{perl_vendorlib}/Git/SVN
 %{perl_vendorlib}/Git/SVN.pm
 %if %{with doc}
 %{perl_vendorlib}/Git/SVN
 %{perl_vendorlib}/Git/SVN.pm
 %if %{with doc}
This page took 0.096053 seconds and 4 git commands to generate.