]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- up to 1.6.6
[packages/git-core.git] / git-core.spec
index 4c9af8b73c660786cd171136660ba75bdcc83a6a..9322f4934f63559a15d5909c1e906b61e3537a79 100644 (file)
@@ -1,18 +1,19 @@
 #
 # Conditional build:
 %bcond_without tests   # don't perform make test
+%bcond_with            tests_cvs
 %bcond_without doc     # skip building/packaging docs/manuals (takes some time)
 #
 %include       /usr/lib/rpm/macros.perl
 Summary:       The stupid content tracker
 Summary(pl.UTF-8):     Prymitywne narzędzie do śledzenia treści
 Name:          git-core
-Version:       1.6.4
-Release:       2
+Version:       1.6.6
+Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
-# Source0-md5: d41e3d43c8f1d23024fb3d3fe6aa3858
+# Source0-md5: 25e4bcdc528b3ffadc6e59908a513881
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}.sysconfig
@@ -22,24 +23,26 @@ URL:                http://git-scm.com/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: curl-devel
-BuildRequires: docbook-dtd45-xml
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
 BuildRequires: openssl-devel
-BuildRequires: perl-Error
+BuildRequires: perl-Error > 0.15
 BuildRequires: perl-base
-BuildRequires: python
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.264
 BuildRequires: zlib-devel
 %if %{with doc}
 BuildRequires: asciidoc >= 7.1.2-3
+BuildRequires: docbook-dtd45-xml
 BuildRequires: xmlto
 %endif
 %if %{with tests}
+%if %{with tests_cvs}
 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
 BuildRequires: cvs-gnu-client < 1.13
 BuildRequires: cvs-gnu-client >= 1.12
+%endif
 BuildRequires: pdksh >= 5.2.14-46
 %endif
 Requires:      coreutils
@@ -51,6 +54,8 @@ Requires:     perl-Error
 Requires:      sed
 Suggests:      git-core-cvs
 Suggests:      git-core-svn
+Suggests:      less
+Suggests:      rsync
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # html docs have links to txt files
@@ -94,6 +99,20 @@ Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
 katalogu.
 
+%package doc
+Summary:       Documentation for git-core
+Summary(pl.UTF-8):     Dokumentacja do git-core
+Group:         Documentation
+
+%description doc
+Documentation for git-core.
+
+%description doc -l pl.UTF-8
+Dokumentacja do git-core.
+
+%description doc -l fr.UTF-8
+Javadoc pour git-core.
+
 %package daemon-inetd
 Summary:       Files necessary to run git-daemon as an inetd service
 Summary(pl.UTF-8):     Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
@@ -252,6 +271,23 @@ CVS support for Git.
 %description cvs -l pl.UTF-8
 Obsługa CVS dla Git.
 
+%package arch
+Summary:       Git tools for importing Arch repositories
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+Requires:      tla
+
+%description arch
+Git tools for importing Arch repositories.
+
+%package email
+Summary:       Git tools for sending email
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description email
+Git tools for sending email.
+
 %package -n bash-completion-git
 Summary:       bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
@@ -268,7 +304,6 @@ Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
 Summary:       Perl interface to the Git version control system
 Summary(pl.UTF-8):     Perlowy interfejs do systemu kontroli wersji Git
 Group:         Development/Languages/Perl
-Requires:      %{name} = %{version}-%{release}
 Obsoletes:     perl-git-core
 
 %description -n perl-Git
@@ -308,6 +343,7 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
        --with-openssl
 
 %{__make} \
+       BLK_SHA1=1 \
        INSTALLDIRS=vendor \
        GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
        GITWEB_PROJECTROOT="/var/lib/git" \
@@ -315,16 +351,20 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
        GITWEB_LOGO="/gitweb/git-logo.png" \
        GITWEB_FAVICON="/gitweb/git-favicon.png"
 
-%{?with_doc:%{__make} -C Documentation}
+# use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
+%{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
 
-%{?with_tests:%{__make} test}
+%if %{with tests}
+%if %{without tests_cvs}
+rm t/t*cvs*.sh
+%endif
+%{__make} test
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
-install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
 
 %{__make} install \
@@ -343,10 +383,12 @@ install libgit.a $RPM_BUILD_ROOT%{_libdir}
 install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
 
 # bash completion
-install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
+cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
 
 # vim syntax
-cat > $RPM_BUILD_ROOT/%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
+install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
+cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
@@ -361,29 +403,33 @@ autocmd BufNewFile,BufRead *.git/**
 EOF
 
 # gitweb
-install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
-install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
-install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
+cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
+cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
+cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
+cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
 
 # gitview
-install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
+install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
 
 # git-daemon related files
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
-install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
-install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
+cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
+cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
+install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
 
 # paths cleanup
 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
 
+# hardlink
+ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
+ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
+ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
+ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
+
 # remove unneeded files
-rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
-rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
-rm -f $RPM_BUILD_ROOT%{_mandir}/man3/private-Error.3*
+rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
+rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -421,9 +467,10 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README contrib
+%attr(755,root,root) %{_bindir}/git
+%attr(755,root,root) %{_bindir}/git-*
+
 %if %{with doc}
-%doc Documentation/RelNotes*
-%doc Documentation/*.html Documentation/howto Documentation/technical
 %{_mandir}/man1/git-*.1*
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
@@ -441,17 +488,27 @@ fi
 %{_mandir}/man7/gittutorial.7*
 %{_mandir}/man7/gitworkflows.7*
 %endif
-%attr(755,root,root) %{_bindir}/git
-%attr(755,root,root) %{_bindir}/git-*
+
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/*-*
 %attr(755,root,root) %{_libdir}/%{name}/git
+
 %exclude %{_libdir}/%{name}/git-gui
 %exclude %{_libdir}/%{name}/git-svn
+%exclude %{_libdir}/%{name}/git-archimport
 %exclude %{_libdir}/%{name}/git-cvs*
+%exclude %{_libdir}/%{name}/*email*
+
 %{_datadir}/%{name}
+
 %{_localstatedir}/lib/git
 
+%if %{with doc}
+%files doc
+%doc Documentation/RelNotes*
+%doc Documentation/*.html Documentation/howto Documentation/technical
+%endif
+
 %files daemon-inetd
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
@@ -479,6 +536,7 @@ fi
 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
+%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
 
@@ -508,6 +566,7 @@ fi
 %{_datadir}/git-gui/lib/*.js
 %{_datadir}/git-gui/lib/*.tcl
 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
+%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
@@ -532,6 +591,20 @@ fi
 %{_mandir}/man7/gitcvs-migration.7*
 %endif
 
+%files arch
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/git-archimport
+%if %{with doc}
+%{_mandir}/man1/git-archimport.1*
+%endif
+
+%files email
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/*email*
+%if %{with doc}
+%{_mandir}/man1/*email*.1*
+%endif
+
 %files -n bash-completion-git
 %defattr(644,root,root,755)
 %{_sysconfdir}/bash_completion.d/*
@@ -544,4 +617,4 @@ fi
 %files -n vim-syntax-gitcommit
 %defattr(644,root,root,755)
 %doc contrib/vim/README
-%{_datadir}/vim/vimfiles/syntax/*
+%{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.089755 seconds and 4 git commands to generate.