]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
macros for %noarchpackage
[packages/git-core.git] / git-core.spec
index 6467a916a2e47fff4a51937cde1e2c414f55e310..8d853850571ffaa32ff6c2ea89989e9e750932c3 100644 (file)
@@ -1,25 +1,25 @@
 #
 # Conditional build:
-%bcond_without tests           # don't perform make test
-%bcond_with    tests_cvs       # perform tests which use CVS
-%bcond_without tests_svn       # perform tests which use subversion
-%bcond_without doc             # skip building/packaging docs/manuals (takes some time)
+%bcond_without tests           # test suite
+%bcond_with    tests_cvs       # tests which use CVS
+%bcond_without tests_svn       # tests which use subversion
+%bcond_without doc             # building/packaging docs/manuals (takes some time)
 %bcond_without pcre            # perl-compatible regexes support
-%bcond_without gnome_keyring   # build without gnome keyring support
-%bcond_without tk              # build without the Tcl/Tk interface
+%bcond_without gnome_keyring   # gnome keyring credentials support
+%bcond_without libsecret       # libsecret credentials support
+%bcond_without tk              # Tcl/Tk interface
 
 # for AC: --without doc --without gnome_keyring --without tests
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       2.17.1
+Version:       2.30.0
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
-# Source0-md5: 5179245515c637357b4a134e8d4e9a6f
+# Source0-md5: 2457ee7e198bb949fecb0af94f7361a3
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -40,19 +40,27 @@ BuildRequires:      gettext-devel
 %else
 BuildRequires: gettext-tools
 %endif
+%if %{with gnome_keyring} || %{with libsecret}
+BuildRequires: glib2-devel >= 2.0
+%endif
 %if %{with gnome_keyring}
 BuildRequires: libgnome-keyring-devel
-BuildRequires: pkgconfig
+%endif
+%if %{with libsecret}
+BuildRequires: libsecret-devel
 %endif
 BuildRequires: openssl-devel
 %{?with_pcre:BuildRequires:    pcre2-8-devel}
 BuildRequires: perl-Error > 0.15
 BuildRequires: perl-MailTools
 BuildRequires: perl-base
+%if %{with gnome_keyring} || %{with libsecret}
+BuildRequires: pkgconfig
+%endif
 BuildRequires: python-devel
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.673
+BuildRequires: rpmbuild(macros) >= 1.752
 %if %{with tk}
 # wish
 BuildRequires: tk
@@ -64,6 +72,10 @@ BuildRequires:       docbook-dtd45-xml
 BuildRequires: xmlto
 %endif
 %if %{with tests}
+BuildRequires: perl-CGI
+BuildRequires: perl-Digest-MD5
+BuildRequires: perl-Encode
+BuildRequires: perl-Time-HiRes
 %if %{with tests_cvs}
 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
 BuildRequires: cvs-gnu-client < 1.13
@@ -144,9 +156,7 @@ katalogu.
 Summary:       Documentation for git-core
 Summary(pl.UTF-8):     Dokumentacja do git-core
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
+%{?noarchpackage}
 
 %description doc
 Documentation for git-core.
@@ -211,9 +221,7 @@ Summary(pl.UTF-8):  Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      tk
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
+%{?noarchpackage}
 
 %description gitk
 gitk displays changes in a repository or a selected set of commits.
@@ -379,9 +387,7 @@ Summary(pl.UTF-8):  bashowe uzupełnianie nazw dla gita
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion >= 2.0
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
+%{?noarchpackage}
 
 %description -n bash-completion-git
 This package provides bash-completion for git.
@@ -394,9 +400,7 @@ Summary:    Perl interface to the Git version control system
 Summary(pl.UTF-8):     Perlowy interfejs do systemu kontroli wersji Git
 Group:         Development/Languages/Perl
 Obsoletes:     perl-git-core
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
+%{?noarchpackage}
 
 %description -n perl-Git
 This module provides Perl scripts easy way to interface the Git
@@ -414,7 +418,7 @@ wykonania przy użyciu ogólnego interfejsu poleceń.
 
 %package -n gnome-keyring-git-core
 Summary:       GNOME Keyring authentication provider for Git
-Summary(pl.UTF-8):     Moduł uwierzytelniający GNOME Keyring dla Git
+Summary(pl.UTF-8):     Moduł uwierzytelniający GNOME Keyring dla Gita
 Group:         X11/Applications
 URL:           http://git-scm.com/docs/gitcredentials.html
 Requires:      %{name} = %{version}-%{release}
@@ -427,23 +431,46 @@ You need to register it with:
 - git config --global credential.helper gnome-keyring
 
 %description -n gnome-keyring-git-core -l pl.UTF-8
-Moduł uwierzytelniający dla Subversion pozwalający klientom git
+Moduł uwierzytelniający dla Gita pozwalający klientom git
 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
 
 Moduł trzeba zarejestrować poleceniem:
 - git config --global credential.helper gnome-keyring
 
+%package credential-libsecret
+Summary:       GNOME authentication provider for Git using libsecret
+Summary(pl.UTF-8):     Moduł uwierzytelniający GNOME dla Gita wykorzystujący libsecret
+Group:         X11/Applications
+URL:           http://git-scm.com/docs/gitcredentials.html
+Requires:      %{name} = %{version}-%{release}
+
+%description credential-libsecret
+Authentication provider module for Git which allows git client to
+authenticate using GNOME libsecret.
+
+You need to register it with:
+- git config --global credential.helper libsecret
+
+%description credential-libsecret -l pl.UTF-8
+Moduł uwierzytelniający dla Gita pozwalający klientom git
+uwierzytelniać się przy użyciu mechanizmu GNOME libsecret.
+
+Moduł trzeba zarejestrować poleceniem:
+- git config --global credential.helper libsecret
+
 %prep
 %setup -q -n git-%{version}
 %patch0 -p0
 %patch1 -p1
 %patch2 -p1
 
-%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
+%{__rm} {Documentation/technical,contrib/credential/gnome-keyring}/.gitignore
 
 # we build things in contrib but want to have it clean for doc purporses, too
 cp -a contrib contrib-doc
 
+%{__sed} -i -e '1s|#!/usr/bin/env python$|#!%{__python}|' git-p4.py
+
 %build
 %{__aclocal}
 %{__autoconf}
@@ -467,7 +494,17 @@ echo "BLK_SHA1=1" >> config.mak
 %{__make} -C contrib/subtree
 
 %if %{with gnome_keyring}
-%{__make} -C contrib/credential/gnome-keyring
+%{__make} -C contrib/credential/gnome-keyring \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -Wall" \
+       LDFLAGS="%{rpmldflags}"
+%endif
+
+%if %{with libsecret}
+%{__make} -C contrib/credential/libsecret \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -Wall" \
+       LDFLAGS="%{rpmldflags}"
 %endif
 
 %if %{with doc}
@@ -477,8 +514,6 @@ echo "BLK_SHA1=1" >> config.mak
 %endif
 
 %if %{with tests}
-# t5770 has multiple race conditions making it very unstable
-GIT_SKIP_TESTS=t5570
 %if %{without tests_cvs}
 %{__rm} t/t*cvs*.sh || :
 %endif
@@ -538,6 +573,10 @@ cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%
 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
 %endif
 
+%if %{with libsecret}
+install -p contrib/credential/libsecret/git-credential-libsecret $RPM_BUILD_ROOT%{gitcoredir}
+%endif
+
 # bash completion
 install -d $RPM_BUILD_ROOT%{bash_compdir}
 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
@@ -550,7 +589,7 @@ cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contri
 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
 
 # gitweb
-mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
+%{__mv} $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
@@ -593,12 +632,26 @@ ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftps
 # remove unneeded files
 %py_postclean
 
-mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
 %find_lang git
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+if [ ! -f /etc/shells ]; then
+       echo "%{_bindir}/git-shell" >> /etc/shells
+else
+       grep -q '^%{_bindir}/git-shell$' /etc/shells || echo "%{_bindir}/git-shell" >> /etc/shells
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       umask 022
+       grep -v '^%{_bindir}/git-shell$' /etc/shells > /etc/shells.new
+       mv -f /etc/shells.new /etc/shells
+fi
+
 %post daemon-inetd
 %service -q rc-inetd reload
 
@@ -650,10 +703,10 @@ fi
 %exclude %{_mandir}/man1/git-archimport.1*
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
-%exclude %{_mandir}/man1/git-imap-send*.1*
-%exclude %{_mandir}/man1/*email*.1*
+%exclude %{_mandir}/man1/git-imap-send.1*
+%exclude %{_mandir}/man1/git-p4.1*
+%exclude %{_mandir}/man1/git-send-email.1*
 %{_mandir}/man1/git.1*
-%{_mandir}/man1/gitremote-helpers.1*
 %{_mandir}/man5/gitattributes.5*
 %{_mandir}/man5/githooks.5*
 %{_mandir}/man5/gitignore.5*
@@ -664,8 +717,10 @@ fi
 %{_mandir}/man7/gitcredentials.7*
 %{_mandir}/man7/gitdiffcore.7*
 %{_mandir}/man7/giteveryday.7*
+%{_mandir}/man7/gitfaq.7*
 %{_mandir}/man7/gitglossary.7*
 %{_mandir}/man7/gitnamespaces.7*
+%{_mandir}/man7/gitremote-helpers.7*
 %{_mandir}/man7/gitrevisions.7*
 %{_mandir}/man7/gitsubmodules.7*
 %{_mandir}/man7/gittutorial-2.7*
@@ -693,12 +748,14 @@ fi
 %exclude %{gitcoredir}/git-instaweb
 %exclude %{gitcoredir}/git-remote-bzr
 %exclude %{gitcoredir}/git-remote-hg
-%exclude %{gitcoredir}/git-remote-testsvn
 %exclude %{gitcoredir}/git-svn
 %exclude %{gitcoredir}/mergetools/p4merge
 %if %{with gnome_keyring}
 %exclude %{gitcoredir}/git-credential-gnome-keyring
 %endif
+%if %{with libsecret}
+%exclude %{gitcoredir}/git-credential-libsecret
+%endif
 
 %if %{with doc}
 %files doc
@@ -745,6 +802,7 @@ fi
 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
+%lang(zh_CN) %{_datadir}/gitk/lib/msgs/zh_cn.msg
 %endif
 
 %files gitweb
@@ -820,11 +878,13 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-p4
 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
+%if %{with doc}
+%{_mandir}/man1/git-p4.1*
+%endif
 
 %files svn
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-svn
-%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
 %{perl_vendorlib}/Git/SVN
 %{perl_vendorlib}/Git/SVN.pm
 %if %{with doc}
@@ -834,10 +894,10 @@ fi
 %files email
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-imap-send
-%attr(755,root,root) %{gitcoredir}/*email*
+%attr(755,root,root) %{gitcoredir}/git-send-email
 %if %{with doc}
-%{_mandir}/man1/*email*.1*
-%{_mandir}/man1/*imap-send*.1*
+%{_mandir}/man1/git-imap-send.1*
+%{_mandir}/man1/git-send-email.1*
 %endif
 
 %files -n bash-completion-git
@@ -856,10 +916,16 @@ fi
 %{perl_vendorlib}/Git/LoadCPAN/Error.pm
 %dir %{perl_vendorlib}/Git/LoadCPAN/Mail
 %{perl_vendorlib}/Git/LoadCPAN/Mail/Address.pm
-%{_mandir}/man3/Git.3pm*
+%{?with_doc:%{_mandir}/man3/Git.3pm*}
 
 %if %{with gnome_keyring}
 %files -n gnome-keyring-git-core
 %defattr(644,root,root,755)
 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
 %endif
+
+%if %{with libsecret}
+%files credential-libsecret
+%defattr(644,root,root,755)
+%attr(755,root,root) %{gitcoredir}/git-credential-libsecret
+%endif
This page took 0.044685 seconds and 4 git commands to generate.