]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- up to 1.7.9
[packages/git-core.git] / git-core.spec
index 2bf5f224978ce3a89ac86c4fc9484d57860159ff..82cf802396bb74d176ecbd04493d84b9d5284db5 100644 (file)
@@ -2,18 +2,20 @@
 # Conditional build:
 %bcond_without tests           # don't perform make test
 %bcond_with    tests_cvs       # perform tests which use CVS
+%bcond_with    tests_svn       # perform tests which use subversion
 %bcond_without doc             # skip building/packaging docs/manuals (takes some time)
-#
+
 %include       /usr/lib/rpm/macros.perl
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
+Version:       1.7.9
 Release:       1
-Version:       1.7.6
 License:       GPL v2
 Group:         Development/Tools
-Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
-# Source0-md5: 9e0a438eb71e89eedb61f89470ed32a0
+# Source0:     http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
+Source0:       http://git-core.googlecode.com/files/git-%{version}.tar.gz
+# Source0-md5: d94314eb49622a945b22595b36b7fc47
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -49,7 +51,7 @@ BuildRequires:        xmlto
 BuildRequires: cvs-gnu-client < 1.13
 BuildRequires: cvs-gnu-client >= 1.12
 %endif
-BuildRequires: pdksh >= 5.2.14-46
+Conflicts:     pdksh < 5.2.14-46
 %endif
 Requires:      coreutils
 Requires:      diffutils
@@ -262,6 +264,7 @@ Summary:    Subversion support for Git
 Summary(pl.UTF-8):     Obsługa Subversion dla Gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
+Requires:      perl-Encode
 Requires:      perl-Term-ReadKey
 
 %description svn
@@ -313,6 +316,7 @@ Narzędzia Gita do wysyłania poczty.
 Summary:       bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
 Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
 
 %description -n bash-completion-git
@@ -342,22 +346,24 @@ specjalne metody do łatwego wykonywania operacji nietrywialnych do
 wykonania przy użyciu ogólnego interfejsu poleceń.
 
 %package -n python-Git
-Summary:       Python interface to the Git version control system
-Summary(pl.UTF-8):     Pythonowy interfejs do systemu kontroli wersji Git
+Summary:       Python Git remote helpers for non-git repositories
+Summary(pl.UTF-8):     Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
 Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
 
 %description -n python-Git
-This module provides Python scripts easy way to interface the Git
-version control system.
+This package contains Python git_repote_helpers package - Git remote
+helpers for non-git repositories.
 
 %description -n python-Git -l pl.UTF-8
-Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
-wersji Git.
+Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
+pomocnicze Gita dla repozytoriów niegitowych.
 
 %package -n vim-syntax-gitcommit
 Summary:       Vim syntax: gitcommit
 Summary(pl.UTF-8):     Składnia dla Vima: gitcommit
 Group:         Applications/Editors/Vim
+Requires:      %{name} = %{version}-%{release}
 # for _vimdatadir existence
 Requires:      vim-rt >= 4:6.3.058-3
 
@@ -398,7 +404,7 @@ echo "BLK_SHA1=1" >> config.mak
 %if %{without tests_cvs}
 rm t/t*cvs*.sh || :
 %endif
-%{__make} test
+%{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
 %endif
 
 %install
@@ -406,10 +412,10 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/git-core
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
 [init]
-       templatedir = /etc/git-core/templates
+       templatedir = %{_sysconfdir}/%{name}/templates
 EOF
 
 %{__make} install \
@@ -426,15 +432,15 @@ cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}
 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
 
 # header files and lib
-cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
+cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
-cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
-cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
-cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
+cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
+cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
+cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
 
 # bash completion
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
-cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
+install -d $RPM_BUILD_ROOT/etc/bash_completion.d
+cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
 
 # vim syntax
 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
@@ -454,10 +460,10 @@ EOF
 
 # gitweb
 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
-cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 # gitview
 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
@@ -478,8 +484,8 @@ ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
 
 # remove unneeded files
-rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
-rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
+%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
 %py_postclean
 
 %clean
@@ -529,12 +535,13 @@ fi
 %attr(755,root,root) %{_bindir}/git-shell
 %attr(755,root,root) %{_bindir}/git-upload-archive
 %attr(755,root,root) %{_bindir}/git-upload-pack
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/git-core
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
 
 %if %{with doc}
 %{_mandir}/man1/git-*.1*
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
+%exclude %{_mandir}/man1/git-remote-helpers.1*
 %{_mandir}/man1/git.1*
 %{_mandir}/man5/gitattributes.5*
 %{_mandir}/man5/githooks.5*
@@ -545,6 +552,7 @@ fi
 %{_mandir}/man7/gitcore-tutorial.7*
 %{_mandir}/man7/gitdiffcore.7*
 %{_mandir}/man7/gitglossary.7*
+%{_mandir}/man7/gitnamespaces.7*
 %{_mandir}/man7/gitrevisions.7*
 %{_mandir}/man7/gittutorial-2.7*
 %{_mandir}/man7/gittutorial.7*
@@ -554,11 +562,13 @@ fi
 %dir %{_libdir}/%{name}
 %attr(755,root,root) %{_libdir}/%{name}/*-*
 %attr(755,root,root) %{_libdir}/%{name}/git
+%{_libdir}/%{name}/mergetools
 
 %exclude %{_libdir}/%{name}/git-gui
 %exclude %{_libdir}/%{name}/git-svn
 %exclude %{_libdir}/%{name}/git-archimport
 %exclude %{_libdir}/%{name}/git-cvs*
+%exclude %{_libdir}/%{name}/git-remote-testgit
 %exclude %{_libdir}/%{name}/*email*
 
 %{_datadir}/%{name}
@@ -583,7 +593,7 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/git-core
+%{_includedir}/%{name}
 %{_libdir}/libgit.a
 %{_libdir}/libgit_xdiff.a
 
@@ -616,6 +626,8 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
 %attr(755,root,root) %{cgibindir}/gitweb.cgi
 %{appdir}
+%{_mandir}/man1/gitweb.1*
+%{_mandir}/man5/gitweb.conf.5*
 
 %files gitview
 %defattr(644,root,root,755)
@@ -676,7 +688,7 @@ fi
 
 %files -n bash-completion-git
 %defattr(644,root,root,755)
-%{_sysconfdir}/bash_completion.d/*
+/etc/bash_completion.d/git-completion.bash
 
 %files -n perl-Git
 %defattr(644,root,root,755)
@@ -685,6 +697,7 @@ fi
 
 %files -n python-Git
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
@@ -692,8 +705,11 @@ fi
 %if "%{py_ver}" > "2.4"
 %{py_sitescriptdir}/git_remote_helpers*.egg-info
 %endif
+%if %{with doc}
+%{_mandir}/man1/git-remote-helpers.1*
+%endif
 
 %files -n vim-syntax-gitcommit
 %defattr(644,root,root,755)
 %doc contrib/vim/README
-%{_datadir}/vim/vimfiles/syntax/*.vim
+%{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.046129 seconds and 4 git commands to generate.