]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
updated to 1.8.4
[packages/git-core.git] / git-core.spec
index 3946c6eeba71af5f3ae1497567967c8d4cb34e36..796226c9626ffda005fa4d8a86652e6b9dce0b45 100644 (file)
@@ -2,28 +2,33 @@
 # Conditional build:
 %bcond_without tests           # don't perform make test
 %bcond_with    tests_cvs       # perform tests which use CVS
-%bcond_with    tests_svn       # perform tests which use subversion
+%bcond_without tests_svn       # perform tests which use subversion
 %bcond_without doc             # skip building/packaging docs/manuals (takes some time)
+%bcond_without pcre            # perl-compatible regexes support
 
 %include       /usr/lib/rpm/macros.perl
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       1.7.12
+Version:       1.8.4
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://git-core.googlecode.com/files/git-%{version}.tar.gz
-# Source0-md5: ceb1a6b17a3e33bbc70eadf8fce5876c
+# Source0-md5: 355768a1c70d0cb4fedf4b598ac1375b
 Source1:       %{name}-gitweb.conf
-Source2:       %{name}-gitweb-httpd.conf
+Source2:       %{name}-gitweb-apache.conf
 Source3:       %{name}-gitweb-lighttpd.conf
 Source4:       %{name}.sysconfig
 Source5:       %{name}.inet
 Source6:       %{name}.init
+Source7:       %{name}-gitweb-httpd.conf
 Patch0:                %{name}-tests.patch
 Patch1:                %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
+Patch3:                cherry-picked-commitlog.patch
+Patch4:                %{name}-svn-serf.patch
+Patch5:                %{name}-svn-exit-errors.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -31,6 +36,7 @@ BuildRequires:        curl-devel
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
 BuildRequires: openssl-devel
+%{?with_pcre:BuildRequires:    pcre-devel}
 BuildRequires: perl-Error > 0.15
 BuildRequires: perl-base
 BuildRequires: python-devel
@@ -50,6 +56,7 @@ BuildRequires:        xmlto
 BuildRequires: cvs-gnu-client < 1.13
 BuildRequires: cvs-gnu-client >= 1.12
 %endif
+%{?with_tests_svn:BuildRequires:  subversion}
 Conflicts:     pdksh < 5.2.14-46
 %endif
 Requires:      coreutils
@@ -73,6 +80,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                webappdir       %{_sysconfdir}/webapps/%{webapp}
 %define                appdir          %{_datadir}/%{webapp}
 %define                cgibindir       %{_prefix}/lib/cgi-bin
+%define                bash_compdir    %{_datadir}/bash-completion/completions
 
 %description
 "git" can mean anything, depending on your mood.
@@ -161,16 +169,16 @@ udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
 do uruchomienia git-daemona w trybie usługi samodzielnej.
 
 %package devel
-Summary:       Header files for git-core
-Summary(pl.UTF-8):     Pliki nagłówkowe dla git-core
+Summary:       Git library with header files
+Summary(pl.UTF-8):     Biblioteka Gita oraz pliki nagłówkowe
 Group:         Development/Libraries
 Requires:      zlib-devel
 
 %description devel
-Header files for git-core.
+Git library with header files.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla git-core.
+Biblioteka Gita oraz pliki nagłówkowe.
 
 %package gitk
 Summary:       Tcl/Tk interface to the Git version control system
@@ -207,6 +215,7 @@ Requires:   webapps
 Requires:      webserver(alias)
 Requires:      webserver(cgi)
 Suggests:      webserver(setenv)
+Conflicts:     apache-base < 2.4.0-1
 
 %description gitweb
 This package provides a web interface for browsing git repositories.
@@ -317,7 +326,7 @@ Summary:    bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
-Requires:      bash-completion
+Requires:      bash-completion >= 2.0
 
 %description -n bash-completion-git
 This package provides bash-completion for git.
@@ -378,12 +387,15 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %patch0 -p1
 %patch1 -p0
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %configure \
        --sysconfdir=%{_sysconfdir}/git-core \
+       %{?with_pcre:--with-libpcre} \
        --with-openssl
 
 echo "BLK_SHA1=1" >> config.mak
@@ -397,11 +409,15 @@ echo "BLK_SHA1=1" >> config.mak
        GITWEB_FAVICON="/gitweb/git-favicon.png" \
        V=1
 
-%{?with_doc:%{__make} -C Documentation V=1}
+%if %{with doc}
+%{__make} -C Documentation \
+       MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
+       V=1
+%endif
 
 %if %{with tests}
 %if %{without tests_cvs}
-rm t/t*cvs*.sh || :
+%{__rm} t/t*cvs*.sh || :
 %endif
 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
 %endif
@@ -438,8 +454,8 @@ cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
 
 # bash completion
-install -d $RPM_BUILD_ROOT/etc/bash_completion.d
-cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
 
 # vim syntax
 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
@@ -462,7 +478,7 @@ mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
-cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 # gitview
@@ -518,10 +534,10 @@ fi
 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{webapp}
 
-%triggerin gitweb -- apache < 2.2.0, apache-base
+%triggerin gitweb -- apache-base
 %webapp_register httpd %{webapp}
 
-%triggerun gitweb -- apache < 2.2.0, apache-base
+%triggerun gitweb -- apache-base
 %webapp_unregister httpd %{webapp}
 
 %triggerin gitweb -- lighttpd
@@ -546,7 +562,7 @@ fi
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
 %exclude %{_mandir}/man1/*email*.1*
-%exclude %{_mandir}/man1/git-remote-helpers.1*
+%exclude %{_mandir}/man1/gitremote-helpers.1*
 %{_mandir}/man1/git.1*
 %{_mandir}/man5/gitattributes.5*
 %{_mandir}/man5/githooks.5*
@@ -575,7 +591,7 @@ fi
 %exclude %{_libdir}/%{name}/git-archimport
 %exclude %{_libdir}/%{name}/git-cvs*
 %exclude %{_libdir}/%{name}/git-instaweb
-%exclude %{_libdir}/%{name}/git-remote-testgit
+%exclude %{_libdir}/%{name}/git-remote-testsvn
 %exclude %{_libdir}/%{name}/*email*
 
 %{_datadir}/%{name}
@@ -669,6 +685,7 @@ fi
 %files svn
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/git-svn
+%attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
 %{perl_vendorlib}/Git/SVN
 %{perl_vendorlib}/Git/SVN.pm
 %if %{with doc}
@@ -700,7 +717,7 @@ fi
 
 %files -n bash-completion-git
 %defattr(644,root,root,755)
-/etc/bash_completion.d/git-completion.bash
+%{bash_compdir}/git
 
 %files -n perl-Git
 %defattr(644,root,root,755)
@@ -712,7 +729,6 @@ fi
 
 %files -n python-Git
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
@@ -721,7 +737,7 @@ fi
 %{py_sitescriptdir}/git_remote_helpers*.egg-info
 %endif
 %if %{with doc}
-%{_mandir}/man1/git-remote-helpers.1*
+%{_mandir}/man1/gitremote-helpers.1*
 %endif
 
 %files -n vim-syntax-gitcommit
This page took 0.079888 seconds and 4 git commands to generate.