]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- up to 1.7.6
[packages/git-core.git] / git-core.spec
index c0b4faec57525c6c65040e0f3263851028585b84..2bf5f224978ce3a89ac86c4fc9484d57860159ff 100644 (file)
@@ -1,26 +1,28 @@
 #
 # Conditional build:
-%bcond_without tests   # don't perform make test
-%bcond_with            tests_cvs
-%bcond_without doc     # skip building/packaging docs/manuals (takes some time)
+%bcond_without tests           # don't perform make test
+%bcond_with    tests_cvs       # perform tests which use CVS
+%bcond_without doc             # skip building/packaging docs/manuals (takes some time)
 #
 %include       /usr/lib/rpm/macros.perl
-Summary:       The stupid content tracker
-Summary(pl.UTF-8):     Prymitywne narzędzie do śledzenia treści
+Summary:       Distributed version control system focused on speed, effectivity and usability
+Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       1.7.1.1
 Release:       1
+Version:       1.7.6
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
-# Source0-md5: 1b116a3e2ecce46a89e4272abf0de955
+# Source0-md5: 9e0a438eb71e89eedb61f89470ed32a0
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
-Source3:       %{name}.sysconfig
-Source4:       %{name}.inet
-Source5:       %{name}.init
+Source3:       %{name}-gitweb-lighttpd.conf
+Source4:       %{name}.sysconfig
+Source5:       %{name}.inet
+Source6:       %{name}.init
 Patch0:                %{name}-tests.patch
-Patch1:                %{name}-libcrypto.patch
+Patch1:                %{name}-key-bindings.patch
+Patch2:                %{name}-sysconfdir.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -34,6 +36,7 @@ BuildRequires:        python-devel
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.264
+BuildRequires: tcl
 BuildRequires: zlib-devel
 %if %{with doc}
 BuildRequires: asciidoc >= 7.1.2-3
@@ -54,6 +57,7 @@ Requires:     findutils
 Requires:      grep
 Requires:      openssh-clients
 Requires:      perl-Error
+Requires:      perl-Git = %{version}-%{release}
 Requires:      sed
 Suggests:      git-core-cvs
 Suggests:      git-core-svn
@@ -195,10 +199,12 @@ repozytorium gita.
 
 %package gitweb
 Summary:       Web frontend to git
-Summary(pl.UTF-8):     Webowy frontend do git
+Summary(pl.UTF-8):     Frontend WWW do gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      webapps
+Requires:      webserver(alias)
+Requires:      webserver(cgi)
 
 %description gitweb
 This package provides a web interface for browsing git repositories.
@@ -229,6 +235,8 @@ Summary(pl.UTF-8):  Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      tk
+Requires:      xdg-utils
+Suggests:      meld
 
 %description gui
 Displays changes in a repository or a selected set of commits. This
@@ -251,19 +259,20 @@ repozytorium gita.
 
 %package svn
 Summary:       Subversion support for Git
-Summary(pl.UTF-8):     Obsługa Subversion dla Git
+Summary(pl.UTF-8):     Obsługa Subversion dla Gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
+Requires:      perl-Term-ReadKey
 
 %description svn
 Subversion support for Git.
 
 %description svn -l pl.UTF-8
-Obsługa Subversion dla Git.
+Obsługa Subversion dla Gita.
 
 %package cvs
 Summary:       CVS support for Git
-Summary(pl.UTF-8):     Obsługa CVS dla Git
+Summary(pl.UTF-8):     Obsługa CVS dla Gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      cvsps >= 2.1-2
@@ -273,10 +282,11 @@ Requires: rcs
 CVS support for Git.
 
 %description cvs -l pl.UTF-8
-Obsługa CVS dla Git.
+Obsługa CVS dla Gita.
 
 %package arch
 Summary:       Git tools for importing Arch repositories
+Summary(pl.UTF-8):     Narzędzia Gita do importowania repozytoriów Archa
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      tla
@@ -284,14 +294,21 @@ Requires: tla
 %description arch
 Git tools for importing Arch repositories.
 
+%description arch -l pl.UTF-8
+Narzędzia Gita do importowania repozytoriów Archa.
+
 %package email
 Summary:       Git tools for sending email
+Summary(pl.UTF-8):     Narzędzia Gita do wysyłania poczty
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 
 %description email
 Git tools for sending email.
 
+%description email -l pl.UTF-8
+Narzędzia Gita do wysyłania poczty.
+
 %package -n bash-completion-git
 Summary:       bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
@@ -354,11 +371,13 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %setup -q -n git-%{version}
 %patch0 -p1
 %patch1 -p0
+%patch2 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %configure \
+       --sysconfdir=%{_sysconfdir}/git-core \
        --with-openssl
 
 echo "BLK_SHA1=1" >> config.mak
@@ -369,7 +388,8 @@ echo "BLK_SHA1=1" >> config.mak
        GITWEB_PROJECTROOT="/var/lib/git" \
        GITWEB_CSS="/gitweb/gitweb.css" \
        GITWEB_LOGO="/gitweb/git-logo.png" \
-       GITWEB_FAVICON="/gitweb/git-favicon.png"
+       GITWEB_FAVICON="/gitweb/git-favicon.png" \
+       V=1
 
 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
@@ -386,6 +406,11 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/git-core
+cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
+[init]
+       templatedir = /etc/git-core/templates
+EOF
 
 %{__make} install \
        INSTALLDIRS=vendor \
@@ -396,6 +421,10 @@ install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+# copy templates except sample hooks
+cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
+
 # header files and lib
 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
@@ -424,19 +453,19 @@ autocmd BufNewFile,BufRead *.git/**
 EOF
 
 # gitweb
-install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
-cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
+mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 # gitview
 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
 
 # git-daemon related files
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
-cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
-install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
+cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
+cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
+install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
 
 # paths cleanup
 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
@@ -486,6 +515,12 @@ fi
 %triggerun gitweb -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{webapp}
 
+%triggerin gitweb -- lighttpd
+%webapp_register lighttpd %{webapp}
+
+%triggerun gitweb -- lighttpd
+%webapp_unregister lighttpd %{webapp}
+
 %files
 %defattr(644,root,root,755)
 %doc README contrib
@@ -494,6 +529,7 @@ fi
 %attr(755,root,root) %{_bindir}/git-shell
 %attr(755,root,root) %{_bindir}/git-upload-archive
 %attr(755,root,root) %{_bindir}/git-upload-pack
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/git-core
 
 %if %{with doc}
 %{_mandir}/man1/git-*.1*
@@ -509,6 +545,7 @@ fi
 %{_mandir}/man7/gitcore-tutorial.7*
 %{_mandir}/man7/gitdiffcore.7*
 %{_mandir}/man7/gitglossary.7*
+%{_mandir}/man7/gitrevisions.7*
 %{_mandir}/man7/gittutorial-2.7*
 %{_mandir}/man7/gittutorial.7*
 %{_mandir}/man7/gitworkflows.7*
@@ -565,6 +602,7 @@ fi
 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
+%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
 
@@ -575,6 +613,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
+%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
 %attr(755,root,root) %{cgibindir}/gitweb.cgi
 %{appdir}
 
@@ -600,9 +639,10 @@ fi
 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
+%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
-%lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
+%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
 
 %files svn
 %defattr(644,root,root,755)
@@ -645,11 +685,13 @@ fi
 
 %files -n python-Git
 %defattr(644,root,root,755)
-%{py_sitescriptdir}/git_remote_helpers*.egg-info
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
+%if "%{py_ver}" > "2.4"
+%{py_sitescriptdir}/git_remote_helpers*.egg-info
+%endif
 
 %files -n vim-syntax-gitcommit
 %defattr(644,root,root,755)
This page took 0.049523 seconds and 4 git commands to generate.