]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- up to 1.7.6
[packages/git-core.git] / git-core.spec
index 1b685d20a8f2d90ec8ef638119dac9f59f63e3d2..2bf5f224978ce3a89ac86c4fc9484d57860159ff 100644 (file)
@@ -1,26 +1,28 @@
 #
 # Conditional build:
-%bcond_without tests   # don't perform make test
-%bcond_with            tests_cvs
-%bcond_without doc     # skip building/packaging docs/manuals (takes some time)
+%bcond_without tests           # don't perform make test
+%bcond_with    tests_cvs       # perform tests which use CVS
+%bcond_without doc             # skip building/packaging docs/manuals (takes some time)
 #
 %include       /usr/lib/rpm/macros.perl
-Summary:       The stupid content tracker
-Summary(pl.UTF-8):     Prymitywne narzędzie do śledzenia treści
+Summary:       Distributed version control system focused on speed, effectivity and usability
+Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       1.7.3.1
 Release:       1
+Version:       1.7.6
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
-# Source0-md5: 77e1611498919965fb65fd1f229ee155
+# Source0-md5: 9e0a438eb71e89eedb61f89470ed32a0
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
-Source3:       %{name}.sysconfig
-Source4:       %{name}.inet
-Source5:       %{name}.init
+Source3:       %{name}-gitweb-lighttpd.conf
+Source4:       %{name}.sysconfig
+Source5:       %{name}.inet
+Source6:       %{name}.init
 Patch0:                %{name}-tests.patch
-Patch1:                %{name}-libcrypto.patch
+Patch1:                %{name}-key-bindings.patch
+Patch2:                %{name}-sysconfdir.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -34,6 +36,7 @@ BuildRequires:        python-devel
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.264
+BuildRequires: tcl
 BuildRequires: zlib-devel
 %if %{with doc}
 BuildRequires: asciidoc >= 7.1.2-3
@@ -54,6 +57,7 @@ Requires:     findutils
 Requires:      grep
 Requires:      openssh-clients
 Requires:      perl-Error
+Requires:      perl-Git = %{version}-%{release}
 Requires:      sed
 Suggests:      git-core-cvs
 Suggests:      git-core-svn
@@ -195,10 +199,12 @@ repozytorium gita.
 
 %package gitweb
 Summary:       Web frontend to git
-Summary(pl.UTF-8):     Webowy frontend do git
+Summary(pl.UTF-8):     Frontend WWW do gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      webapps
+Requires:      webserver(alias)
+Requires:      webserver(cgi)
 
 %description gitweb
 This package provides a web interface for browsing git repositories.
@@ -253,7 +259,7 @@ repozytorium gita.
 
 %package svn
 Summary:       Subversion support for Git
-Summary(pl.UTF-8):     Obsługa Subversion dla Git
+Summary(pl.UTF-8):     Obsługa Subversion dla Gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      perl-Term-ReadKey
@@ -262,11 +268,11 @@ Requires: perl-Term-ReadKey
 Subversion support for Git.
 
 %description svn -l pl.UTF-8
-Obsługa Subversion dla Git.
+Obsługa Subversion dla Gita.
 
 %package cvs
 Summary:       CVS support for Git
-Summary(pl.UTF-8):     Obsługa CVS dla Git
+Summary(pl.UTF-8):     Obsługa CVS dla Gita
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      cvsps >= 2.1-2
@@ -276,10 +282,11 @@ Requires: rcs
 CVS support for Git.
 
 %description cvs -l pl.UTF-8
-Obsługa CVS dla Git.
+Obsługa CVS dla Gita.
 
 %package arch
 Summary:       Git tools for importing Arch repositories
+Summary(pl.UTF-8):     Narzędzia Gita do importowania repozytoriów Archa
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      tla
@@ -287,14 +294,21 @@ Requires: tla
 %description arch
 Git tools for importing Arch repositories.
 
+%description arch -l pl.UTF-8
+Narzędzia Gita do importowania repozytoriów Archa.
+
 %package email
 Summary:       Git tools for sending email
+Summary(pl.UTF-8):     Narzędzia Gita do wysyłania poczty
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 
 %description email
 Git tools for sending email.
 
+%description email -l pl.UTF-8
+Narzędzia Gita do wysyłania poczty.
+
 %package -n bash-completion-git
 Summary:       bash-completion for git
 Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla gita
@@ -357,11 +371,13 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %setup -q -n git-%{version}
 %patch0 -p1
 %patch1 -p0
+%patch2 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %configure \
+       --sysconfdir=%{_sysconfdir}/git-core \
        --with-openssl
 
 echo "BLK_SHA1=1" >> config.mak
@@ -372,7 +388,8 @@ echo "BLK_SHA1=1" >> config.mak
        GITWEB_PROJECTROOT="/var/lib/git" \
        GITWEB_CSS="/gitweb/gitweb.css" \
        GITWEB_LOGO="/gitweb/git-logo.png" \
-       GITWEB_FAVICON="/gitweb/git-favicon.png"
+       GITWEB_FAVICON="/gitweb/git-favicon.png" \
+       V=1
 
 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
@@ -389,6 +406,11 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/git-core
+cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
+[init]
+       templatedir = /etc/git-core/templates
+EOF
 
 %{__make} install \
        INSTALLDIRS=vendor \
@@ -399,6 +421,10 @@ install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+# copy templates except sample hooks
+cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
+
 # header files and lib
 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
@@ -427,18 +453,19 @@ autocmd BufNewFile,BufRead *.git/**
 EOF
 
 # gitweb
-install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
+mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 # gitview
 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
 
 # git-daemon related files
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
-cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
-install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
+cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
+cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
+install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
 
 # paths cleanup
 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
@@ -488,6 +515,12 @@ fi
 %triggerun gitweb -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{webapp}
 
+%triggerin gitweb -- lighttpd
+%webapp_register lighttpd %{webapp}
+
+%triggerun gitweb -- lighttpd
+%webapp_unregister lighttpd %{webapp}
+
 %files
 %defattr(644,root,root,755)
 %doc README contrib
@@ -496,6 +529,7 @@ fi
 %attr(755,root,root) %{_bindir}/git-shell
 %attr(755,root,root) %{_bindir}/git-upload-archive
 %attr(755,root,root) %{_bindir}/git-upload-pack
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/git-core
 
 %if %{with doc}
 %{_mandir}/man1/git-*.1*
@@ -568,6 +602,7 @@ fi
 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
+%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
 
@@ -578,6 +613,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
+%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
 %attr(755,root,root) %{cgibindir}/gitweb.cgi
 %{appdir}
 
@@ -603,9 +639,10 @@ fi
 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
+%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
-%lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
+%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
 
 %files svn
 %defattr(644,root,root,755)
@@ -648,11 +685,13 @@ fi
 
 %files -n python-Git
 %defattr(644,root,root,755)
-%{py_sitescriptdir}/git_remote_helpers*.egg-info
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
+%if "%{py_ver}" > "2.4"
+%{py_sitescriptdir}/git_remote_helpers*.egg-info
+%endif
 
 %files -n vim-syntax-gitcommit
 %defattr(644,root,root,755)
This page took 0.050747 seconds and 4 git commands to generate.