]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- verbose make
[packages/git-core.git] / git-core.spec
index c0b4faec57525c6c65040e0f3263851028585b84..267c16b7c9e9583e7f3a1624de533a3fb3d84026 100644 (file)
@@ -1,24 +1,25 @@
 #
 # Conditional build:
-%bcond_without tests   # don't perform make test
-%bcond_with            tests_cvs
-%bcond_without doc     # skip building/packaging docs/manuals (takes some time)
+%bcond_without tests           # don't perform make test
+%bcond_with    tests_cvs       # perform tests which use CVS
+%bcond_without doc             # skip building/packaging docs/manuals (takes some time)
 #
 %include       /usr/lib/rpm/macros.perl
 Summary:       The stupid content tracker
 Summary(pl.UTF-8):     Prymitywne narzędzie do śledzenia treści
 Name:          git-core
-Version:       1.7.1.1
-Release:       1
+Version:       1.7.3.2
+Release:       2
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
-# Source0-md5: 1b116a3e2ecce46a89e4272abf0de955
+# Source0-md5: 902f7f07a789fedc0d2ac03656b85969
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
-Source3:       %{name}.sysconfig
-Source4:       %{name}.inet
-Source5:       %{name}.init
+Source3:       %{name}-gitweb-lighttpd.conf
+Source4:       %{name}.sysconfig
+Source5:       %{name}.inet
+Source6:       %{name}.init
 Patch0:                %{name}-tests.patch
 Patch1:                %{name}-libcrypto.patch
 URL:           http://git-scm.com/
@@ -199,6 +200,8 @@ Summary(pl.UTF-8):  Webowy frontend do git
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      webapps
+Requires:      webserver(alias)
+Requires:      webserver(cgi)
 
 %description gitweb
 This package provides a web interface for browsing git repositories.
@@ -229,6 +232,8 @@ Summary(pl.UTF-8):  Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 Requires:      tk
+Requires:      xdg-utils
+Suggests:      meld
 
 %description gui
 Displays changes in a repository or a selected set of commits. This
@@ -254,6 +259,7 @@ Summary:    Subversion support for Git
 Summary(pl.UTF-8):     Obsługa Subversion dla Git
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
+Requires:      perl-Term-ReadKey
 
 %description svn
 Subversion support for Git.
@@ -369,7 +375,8 @@ echo "BLK_SHA1=1" >> config.mak
        GITWEB_PROJECTROOT="/var/lib/git" \
        GITWEB_CSS="/gitweb/gitweb.css" \
        GITWEB_LOGO="/gitweb/git-logo.png" \
-       GITWEB_FAVICON="/gitweb/git-favicon.png"
+       GITWEB_FAVICON="/gitweb/git-favicon.png" \
+       V=1
 
 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
@@ -425,18 +432,18 @@ EOF
 
 # gitweb
 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
-cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
+cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
 
 # gitview
 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
 
 # git-daemon related files
-cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
-cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
-install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
+cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
+cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
+install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
 
 # paths cleanup
 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
@@ -486,6 +493,12 @@ fi
 %triggerun gitweb -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{webapp}
 
+%triggerin gitweb -- lighttpd
+%webapp_register lighttpd %{webapp}
+
+%triggerun gitweb -- lighttpd
+%webapp_unregister lighttpd %{webapp}
+
 %files
 %defattr(644,root,root,755)
 %doc README contrib
@@ -509,6 +522,7 @@ fi
 %{_mandir}/man7/gitcore-tutorial.7*
 %{_mandir}/man7/gitdiffcore.7*
 %{_mandir}/man7/gitglossary.7*
+%{_mandir}/man7/gitrevisions.7*
 %{_mandir}/man7/gittutorial-2.7*
 %{_mandir}/man7/gittutorial.7*
 %{_mandir}/man7/gitworkflows.7*
@@ -575,6 +589,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
+%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
 %attr(755,root,root) %{cgibindir}/gitweb.cgi
 %{appdir}
 
@@ -645,11 +660,13 @@ fi
 
 %files -n python-Git
 %defattr(644,root,root,755)
-%{py_sitescriptdir}/git_remote_helpers*.egg-info
 %dir %{py_sitescriptdir}/git_remote_helpers
 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
 %dir %{py_sitescriptdir}/git_remote_helpers/git
 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
+%if "%{py_ver}" > "2.4"
+%{py_sitescriptdir}/git_remote_helpers*.egg-info
+%endif
 
 %files -n vim-syntax-gitcommit
 %defattr(644,root,root,755)
This page took 0.179091 seconds and 4 git commands to generate.