]> git.pld-linux.org Git - packages/git-core.git/blobdiff - git-core.spec
- up to 1.8.1.5
[packages/git-core.git] / git-core.spec
index a114636bfb300b395a9fe685f84fb930e293ac30..1e0232da0cd823fc5356aa5954c360e0b7e068b0 100644 (file)
@@ -2,20 +2,19 @@
 # Conditional build:
 %bcond_without tests           # don't perform make test
 %bcond_with    tests_cvs       # perform tests which use CVS
-%bcond_with    tests_svn       # perform tests which use subversion
+%bcond_without tests_svn       # perform tests which use subversion
 %bcond_without doc             # skip building/packaging docs/manuals (takes some time)
 
 %include       /usr/lib/rpm/macros.perl
 Summary:       Distributed version control system focused on speed, effectivity and usability
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
-Version:       1.7.9.2
+Version:       1.8.1.5
 Release:       1
 License:       GPL v2
 Group:         Development/Tools
-# Source0:     http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
 Source0:       http://git-core.googlecode.com/files/git-%{version}.tar.gz
-# Source0-md5: f2f0fc821ab074862c4a96de3f4cefbe
+# Source0-md5: ce168861c23a700b40ffe94475bb1d9e
 Source1:       %{name}-gitweb.conf
 Source2:       %{name}-gitweb-httpd.conf
 Source3:       %{name}-gitweb-lighttpd.conf
@@ -25,6 +24,7 @@ Source6:      %{name}.init
 Patch0:                %{name}-tests.patch
 Patch1:                %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
+Patch3:                cherry-picked-commitlog.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -51,6 +51,7 @@ BuildRequires:        xmlto
 BuildRequires: cvs-gnu-client < 1.13
 BuildRequires: cvs-gnu-client >= 1.12
 %endif
+%{?with_tests_svn:BuildRequires:  subversion}
 Conflicts:     pdksh < 5.2.14-46
 %endif
 Requires:      coreutils
@@ -162,16 +163,16 @@ udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
 do uruchomienia git-daemona w trybie usługi samodzielnej.
 
 %package devel
-Summary:       Header files for git-core
-Summary(pl.UTF-8):     Pliki nagłówkowe dla git-core
+Summary:       Git library with header files
+Summary(pl.UTF-8):     Biblioteka Gita oraz pliki nagłówkowe
 Group:         Development/Libraries
 Requires:      zlib-devel
 
 %description devel
-Header files for git-core.
+Git library with header files.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla git-core.
+Biblioteka Gita oraz pliki nagłówkowe.
 
 %package gitk
 Summary:       Tcl/Tk interface to the Git version control system
@@ -207,6 +208,7 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      webapps
 Requires:      webserver(alias)
 Requires:      webserver(cgi)
+Suggests:      webserver(setenv)
 
 %description gitweb
 This package provides a web interface for browsing git repositories.
@@ -378,6 +380,7 @@ Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
 %patch0 -p1
 %patch1 -p0
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
@@ -397,14 +400,17 @@ echo "BLK_SHA1=1" >> config.mak
        GITWEB_FAVICON="/gitweb/git-favicon.png" \
        V=1
 
-# use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
-%{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
+%if %{with doc}
+%{__make} -C Documentation \
+       MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
+       V=1
+%endif
 
 %if %{with tests}
 %if %{without tests_cvs}
-rm t/t*cvs*.sh || :
+%{__rm} t/t*cvs*.sh || :
 %endif
-%{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
+%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
 %endif
 
 %install
@@ -460,6 +466,7 @@ EOF
 
 # gitweb
 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
+ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
@@ -488,6 +495,7 @@ ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
 %py_postclean
 
+mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
 %find_lang git
 
 %clean
@@ -541,9 +549,11 @@ fi
 
 %if %{with doc}
 %{_mandir}/man1/git-*.1*
+%exclude %{_mandir}/man1/git-archimport.1*
 %exclude %{_mandir}/man1/git-svn.1*
 %exclude %{_mandir}/man1/git-cvs*.1*
-%exclude %{_mandir}/man1/git-remote-helpers.1*
+%exclude %{_mandir}/man1/*email*.1*
+%exclude %{_mandir}/man1/gitremote-helpers.1*
 %{_mandir}/man1/git.1*
 %{_mandir}/man5/gitattributes.5*
 %{_mandir}/man5/githooks.5*
@@ -571,6 +581,7 @@ fi
 %exclude %{_libdir}/%{name}/git-svn
 %exclude %{_libdir}/%{name}/git-archimport
 %exclude %{_libdir}/%{name}/git-cvs*
+%exclude %{_libdir}/%{name}/git-instaweb
 %exclude %{_libdir}/%{name}/git-remote-testgit
 %exclude %{_libdir}/%{name}/*email*
 
@@ -629,8 +640,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
 %attr(755,root,root) %{cgibindir}/gitweb.cgi
 %{appdir}
+%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
+%if %{with doc}
 %{_mandir}/man1/gitweb.1*
 %{_mandir}/man5/gitweb.conf.5*
+%endif
 
 %files gitview
 %defattr(644,root,root,755)
@@ -662,6 +676,8 @@ fi
 %files svn
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/git-svn
+%{perl_vendorlib}/Git/SVN
+%{perl_vendorlib}/Git/SVN.pm
 %if %{with doc}
 %{_mandir}/man1/git-svn.1*
 %endif
@@ -696,7 +712,9 @@ fi
 %files -n perl-Git
 %defattr(644,root,root,755)
 %{perl_vendorlib}/Git.pm
-%{perl_vendorlib}/Git
+%dir %{perl_vendorlib}/Git
+%{perl_vendorlib}/Git/I18N.pm
+%{perl_vendorlib}/Git/IndexInfo.pm
 %{_mandir}/man3/Git*.3pm*
 
 %files -n python-Git
@@ -710,7 +728,7 @@ fi
 %{py_sitescriptdir}/git_remote_helpers*.egg-info
 %endif
 %if %{with doc}
-%{_mandir}/man1/git-remote-helpers.1*
+%{_mandir}/man1/gitremote-helpers.1*
 %endif
 
 %files -n vim-syntax-gitcommit
This page took 0.067418 seconds and 4 git commands to generate.