]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
up to 2.6.3
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        2.6.3
17 Release:        1
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  b711be7628a4a2c25f38d859ee81b423
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  gettext-tools
40 %if %{with gnome_keyring}
41 BuildRequires:  libgnome-keyring-devel
42 BuildRequires:  pkgconfig
43 %endif
44 BuildRequires:  openssl-devel
45 %{?with_pcre:BuildRequires:     pcre-devel}
46 BuildRequires:  perl-Error > 0.15
47 BuildRequires:  perl-base
48 BuildRequires:  python-devel
49 BuildRequires:  rpm-perlprov >= 4.1-13
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.673
52 BuildRequires:  tcl
53 BuildRequires:  zlib-devel
54 %if %{with doc}
55 BuildRequires:  asciidoc >= 7.1.2-3
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  xmlto
58 %endif
59 %if %{with tests}
60 %if %{with tests_cvs}
61 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62 BuildRequires:  cvs-gnu-client < 1.13
63 BuildRequires:  cvs-gnu-client >= 1.12
64 %endif
65 %if %{with tests_svn}
66 BuildRequires:  perl-subversion
67 BuildRequires:  subversion
68 %endif
69 Conflicts:      pdksh < 5.2.14-46
70 %endif
71 # git-sh-setup: sane_grep
72 Requires:       grep
73 # git-pull: printf
74 Requires:       coreutils
75 Requires:       openssh-clients
76 Requires:       perl-Error
77 Requires:       perl-Git = %{version}-%{release}
78 Requires:       sed
79 Suggests:       git-core-bzr
80 Suggests:       git-core-cvs
81 Suggests:       git-core-hg
82 Suggests:       git-core-p4
83 Suggests:       git-core-svn
84 Suggests:       less
85 Suggests:       rsync
86 Obsoletes:      python-Git
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 # html docs have links to txt files
90 %define         _noautocompressdoc      *.txt
91
92 %define         webapp          gitweb
93 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
94 %define         appdir          %{_datadir}/%{webapp}
95 %define         cgibindir       %{_prefix}/lib/cgi-bin
96 %define         gitcoredir      %{_libdir}/%{name}
97
98 %description
99 "git" can mean anything, depending on your mood.
100
101 - random three-letter combination that is pronounceable, and not
102   actually used by any common UNIX command. The fact that it is a
103   mispronunciation of "get" may or may not be relevant.
104 - stupid. contemptible and despicable. simple. Take your pick from the
105   dictionary of slang.
106 - "global information tracker": you're in a good mood, and it actually
107   works for you. Angels sing, and a light suddenly fills the room.
108 - "goddamn idiotic truckload of sh*t": when it breaks
109
110 This is a stupid (but extremely fast) directory content manager. It
111 doesn't do a whole lot, but what it 'does' do is track directory
112 contents efficiently.
113
114 %description -l pl.UTF-8
115 "git" może oznaczać cokolwiek, w zależności od nastroju.
116
117 - losową kombinację trzech liter, która jest wymawialna i właściwie
118   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
119   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
120 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
121 - "global information tracker" (narzędzie do globalnego śledzenia
122   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
123   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
124 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
125   g*) - kiedy się zepsuje.
126
127 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
128 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
129 katalogu.
130
131 %package doc
132 Summary:        Documentation for git-core
133 Summary(pl.UTF-8):      Dokumentacja do git-core
134 Group:          Documentation
135
136 %description doc
137 Documentation for git-core.
138
139 %description doc -l pl.UTF-8
140 Dokumentacja do git-core.
141
142 %description doc -l fr.UTF-8
143 Javadoc pour git-core.
144
145 %package daemon-inetd
146 Summary:        Files necessary to run git-daemon as an inetd service
147 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
148 Group:          Networking/Daemons
149 Requires:       %{name} = %{version}-%{release}
150 Requires:       setup >= 2.4.11-1
151 Provides:       git-core-daemon
152 Obsoletes:      git-core-daemon
153 Obsoletes:      git-core-daemon-standalone
154
155 %description daemon-inetd
156 Git-daemon is a really simple TCP git daemon that can serve git
157 repositories. This package provides all necessarry files to run
158 git-daemon as an inetd service.
159
160 %description daemon-inetd -l pl.UTF-8
161 Git-daemon to prosty demon git korzystający z protokołu TCP do
162 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
163 do uruchomienia git-demona w trybie usługi inetd.
164
165 %package daemon-standalone
166 Summary:        Files necessary to run git-daemon as a standalone service
167 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
168 Group:          Networking/Daemons
169 Requires:       %{name} = %{version}-%{release}
170 Provides:       git-core-daemon
171 Obsoletes:      git-core-daemon
172 Obsoletes:      git-core-daemon-inetd
173
174 %description daemon-standalone
175 Git-daemon is a really simple TCP git daemon that can serve git
176 repositories. This package provides all necessarry files to run
177 git-daemon as an standalone service.
178
179 %description daemon-standalone -l pl.UTF-8
180 Git-daemon to prosty demon git korzystający z protokołu TCP do
181 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
182 do uruchomienia git-daemona w trybie usługi samodzielnej.
183
184 %package devel
185 Summary:        Git library with header files
186 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
187 Group:          Development/Libraries
188 Requires:       zlib-devel
189
190 %description devel
191 Git library with header files.
192
193 %description devel -l pl.UTF-8
194 Biblioteka Gita oraz pliki nagłówkowe.
195
196 %package gitk
197 Summary:        Tcl/Tk interface to the Git version control system
198 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
199 Group:          Development/Tools
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       tk
202
203 %description gitk
204 gitk displays changes in a repository or a selected set of commits.
205 This includes visualizing the commit graph, showing information
206 related to each commit, and the files in the trees of each revision.
207
208 Historically, gitk was the first repository browser. It's written in
209 Tcl/Tk and started off in a separate repository but was later merged
210 into the main git repository.
211
212 %description gitk -l pl.UTF-8
213 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
214 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
215 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
216
217 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
218 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
219 osobnym repozytorium, ale z czasem został włączony do głównego
220 repozytorium gita.
221
222 %package gitweb
223 Summary:        Web frontend to git
224 Summary(pl.UTF-8):      Frontend WWW do gita
225 Group:          Development/Tools
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       webapps
228 Requires:       webserver(access)
229 Requires:       webserver(alias)
230 Requires:       webserver(cgi)
231 Suggests:       webserver(setenv)
232
233 %description gitweb
234 This package provides a web interface for browsing git repositories.
235
236 %description gitweb -l pl.UTF-8
237 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
238
239 %package gitview
240 Summary:        A GTK+ based repository browser for git
241 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
242 Group:          Development/Tools
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       python >= 1:2.4
245 Requires:       python-pycairo >= 1.0
246 Requires:       python-pygobject
247 Requires:       python-pygtk-gtk >= 2:2.8
248 Suggests:       python-gnome-desktop-gtksourceview
249
250 %description gitview
251 A GTK+ based repository browser for git.
252
253 %description gitview -l pl.UTF-8
254 Oparta na GTK+ przeglądarka repozytorium gita.
255
256 %package gui
257 Summary:        Tcl/Tk interface to the Git version control system
258 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
259 Group:          Development/Tools
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       tk
262 Requires:       xdg-utils
263 Suggests:       meld
264
265 %description gui
266 Displays changes in a repository or a selected set of commits. This
267 includes visualizing the commit graph, showing information related to
268 each commit, and the files in the trees of each revision.
269
270 Historically, gitk was the first repository browser. It's written in
271 Tcl/Tk and started off in a separate repository but was later merged
272 into the main git repository.
273
274 %description gui -l pl.UTF-8
275 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
276 to wizualizację grafu commitów, wyświetlanie informacji związanych z
277 każdym z commitów oraz listę plików dla każdej rewizji.
278
279 Z punktu widzenia historii, gitk był pierwszą przeglądarką
280 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
281 osobnym repozytorium, ale z czasem został włączony do głównego
282 repozytorium gita.
283
284 %package arch
285 Summary:        Git tools for importing Arch repositories
286 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       tla
290
291 %description arch
292 Git tools for importing Arch repositories.
293
294 %description arch -l pl.UTF-8
295 Narzędzia Gita do importowania repozytoriów Archa.
296
297 %package bzr
298 Summary:        Git tools for working with bzr repositories
299 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
300 Group:          Development/Tools
301 Requires:       %{name} = %{version}-%{release}
302 Requires:       bzr
303
304 %description bzr
305 Git tools for working with bzr repositories.
306
307 %description bzr -l pl.UTF-8
308 Narzędzia Gita do pracy z repozytoriami bzr.
309
310 %package cvs
311 Summary:        CVS support for Git
312 Summary(pl.UTF-8):      Obsługa CVS dla Gita
313 Group:          Development/Tools
314 Requires:       %{name} = %{version}-%{release}
315 Requires:       cvsps >= 2.1-2
316 Requires:       rcs
317
318 %description cvs
319 CVS support for Git.
320
321 %description cvs -l pl.UTF-8
322 Obsługa CVS dla Gita.
323
324 %package hg
325 Summary:        Git tools for working with mercurial repositories
326 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
327 Group:          Development/Tools
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       mercurial >= 1.8
330
331 %description hg
332 Git tools for working with mercurial repositories.
333
334 %description hg -l pl.UTF-8
335 Narzędzia Gita do pracy z repozytoriami mercuriala.
336
337 %package p4
338 Summary:        Git tools for working with Perforce depots
339 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
340 Group:          Development/Tools
341 Requires:       %{name} = %{version}-%{release}
342
343 %description p4
344 Git tools for working with Perforce depots.
345
346 %description p4 -l pl.UTF-8
347 Narzędzia Gita do pracy z magazynami Perforce'a.
348
349 %package svn
350 Summary:        Subversion support for Git
351 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
352 Group:          Development/Tools
353 Requires:       %{name} = %{version}-%{release}
354 Requires:       perl-Encode
355 Requires:       perl-Term-ReadKey
356
357 %description svn
358 Subversion support for Git.
359
360 %description svn -l pl.UTF-8
361 Obsługa Subversion dla Gita.
362
363 %package email
364 Summary:        Git tools for sending email
365 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
366 Group:          Development/Tools
367 Requires:       %{name} = %{version}-%{release}
368
369 %description email
370 Git tools for sending email.
371
372 %description email -l pl.UTF-8
373 Narzędzia Gita do wysyłania poczty.
374
375 %package -n bash-completion-git
376 Summary:        bash-completion for git
377 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
378 Group:          Applications/Shells
379 Requires:       %{name} = %{version}-%{release}
380 Requires:       bash-completion >= 2.0
381 %if "%{_rpmversion}" >= "5"
382 BuildArch:      noarch
383 %endif
384
385 %description -n bash-completion-git
386 This package provides bash-completion for git.
387
388 %description -n bash-completion-git -l pl.UTF-8
389 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
390
391 %package -n perl-Git
392 Summary:        Perl interface to the Git version control system
393 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
394 Group:          Development/Languages/Perl
395 Obsoletes:      perl-git-core
396
397 %description -n perl-Git
398 This module provides Perl scripts easy way to interface the Git
399 version control system. The modules have an easy and well-tested way
400 to call arbitrary Git commands; in the future, the interface will also
401 provide specialized methods for doing easily operations which are not
402 totally trivial to do over the generic command interface.
403
404 %description -n perl-Git -l pl.UTF-8
405 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
406 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
407 dowolne polecenia Gita; w przyszłości interfejs udostępni także
408 specjalne metody do łatwego wykonywania operacji nietrywialnych do
409 wykonania przy użyciu ogólnego interfejsu poleceń.
410
411 %package -n gnome-keyring-git-core
412 Summary:        GNOME Keyring authentication provider for Git
413 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
414 Group:          X11/Applications
415 URL:            http://git-scm.com/docs/gitcredentials.html
416 Requires:       %{name} = %{version}-%{release}
417
418 %description -n gnome-keyring-git-core
419 Authentication provider module for Git which allows git client to
420 authenticate using GNOME Keyring.
421
422 You need to register it with:
423 - git config --global credential.helper gnome-keyring
424
425 %description -n gnome-keyring-git-core -l pl.UTF-8
426 Moduł uwierzytelniający dla Subversion pozwalający klientom git
427 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
428
429 Moduł trzeba zarejestrować poleceniem:
430 - git config --global credential.helper gnome-keyring
431
432 %prep
433 %setup -q -n git-%{version}
434 %patch0 -p1
435 %patch1 -p0
436 %patch2 -p1
437 %patch3 -p1
438 %patch4 -p1
439
440 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
441
442 # we build things in contrib but want to have it clean for doc purporses, too
443 cp -a contrib contrib-doc
444
445 %build
446 %{__aclocal}
447 %{__autoconf}
448 %configure \
449         --sysconfdir=%{_sysconfdir}/git-core \
450         %{?with_pcre:--with-libpcre} \
451         --with-openssl
452
453 echo "BLK_SHA1=1" >> config.mak
454
455 %{__make} \
456         INSTALLDIRS=vendor \
457         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
458         GITWEB_PROJECTROOT="/var/lib/git" \
459         GITWEB_CSS="/gitweb/gitweb.css" \
460         GITWEB_LOGO="/gitweb/git-logo.png" \
461         GITWEB_FAVICON="/gitweb/git-favicon.png" \
462         V=1
463
464 %{__make} -C contrib/subtree
465
466 %if %{with gnome_keyring}
467 %{__make} -C contrib/credential/gnome-keyring
468 %endif
469
470 %if %{with doc}
471 %{__make} -C Documentation \
472         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
473         V=1
474 %endif
475
476 %if %{with tests}
477 %if %{without tests_cvs}
478 %{__rm} t/t*cvs*.sh || :
479 %endif
480 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
481 %endif
482
483 %install
484 rm -rf $RPM_BUILD_ROOT
485 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
486 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
487 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
488 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
489 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
490 [init]
491         templatedir = %{_sysconfdir}/%{name}/templates
492 EOF
493
494 %{__make} install \
495         INSTALLDIRS=vendor \
496         DESTDIR=$RPM_BUILD_ROOT
497
498 %if %{with doc}
499 %{__make} -C Documentation install \
500         DESTDIR=$RPM_BUILD_ROOT
501 %endif
502
503 # copy templates except sample hooks
504 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
505 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
506
507 # header files and lib
508 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
509 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
510 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
511 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
512 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
513 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
514 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
515 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
516
517 %{__make} -C contrib/subtree install \
518         libexecdir=%{gitcoredir} \
519         DESTDIR=$RPM_BUILD_ROOT
520
521 %if %{with doc}
522 %{__make} -C contrib/subtree install-man \
523         DESTDIR=$RPM_BUILD_ROOT
524 %endif
525
526 %if %{with gnome_keyring}
527 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
528 %endif
529
530 # bash completion
531 install -d $RPM_BUILD_ROOT%{bash_compdir}
532 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
533
534 # Install git-prompt.sh
535 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
536 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
537
538 # Install bzr and hg remote helpers from contrib
539 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
540
541 # gitweb
542 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
543 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
544 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
545 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
546 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
547 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
548 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
549
550 # gitview
551 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
552
553 # git-daemon related files
554 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
555 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
556 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
557
558 # paths cleanup
559 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
560 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
561
562 # hardlink
563 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
564 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
565 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
566 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
567
568 # remove unneeded files
569 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
570 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
571 %py_postclean
572
573 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
574 %find_lang git
575
576 %clean
577 rm -rf $RPM_BUILD_ROOT
578
579 %post daemon-inetd
580 %service -q rc-inetd reload
581
582 %postun daemon-inetd
583 if [ "$1" = "0" ]; then
584         %service -q rc-inetd reload
585 fi
586
587 %post daemon-standalone
588 /sbin/chkconfig --add git-daemon
589 %service git-daemon restart "git-daemon"
590
591 %preun daemon-standalone
592 if [ "$1" = "0" ]; then
593         %service git-daemon stop
594         /sbin/chkconfig --del git-daemon
595 fi
596
597 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
598 %webapp_register apache %{webapp}
599
600 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
601 %webapp_unregister apache %{webapp}
602
603 %triggerin gitweb -- apache < 2.2.0, apache-base
604 %webapp_register httpd %{webapp}
605
606 %triggerun gitweb -- apache < 2.2.0, apache-base
607 %webapp_unregister httpd %{webapp}
608
609 %triggerin gitweb -- lighttpd
610 %webapp_register lighttpd %{webapp}
611
612 %triggerun gitweb -- lighttpd
613 %webapp_unregister lighttpd %{webapp}
614
615 %files -f git.lang
616 %defattr(644,root,root,755)
617 %doc README contrib-doc
618 %attr(755,root,root) %{_bindir}/git
619 %attr(755,root,root) %{_bindir}/git-receive-pack
620 %attr(755,root,root) %{_bindir}/git-shell
621 %attr(755,root,root) %{_bindir}/git-upload-archive
622 %attr(755,root,root) %{_bindir}/git-upload-pack
623 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
624
625 %if %{with doc}
626 %{_mandir}/man1/git-*.1*
627 %exclude %{_mandir}/man1/git-archimport.1*
628 %exclude %{_mandir}/man1/git-svn.1*
629 %exclude %{_mandir}/man1/git-cvs*.1*
630 %exclude %{_mandir}/man1/git-imap-send*.1*
631 %exclude %{_mandir}/man1/*email*.1*
632 %{_mandir}/man1/git.1*
633 %{_mandir}/man1/gitremote-helpers.1*
634 %{_mandir}/man5/gitattributes.5*
635 %{_mandir}/man5/githooks.5*
636 %{_mandir}/man5/gitignore.5*
637 %{_mandir}/man5/gitmodules.5*
638 %{_mandir}/man5/gitrepository-layout.5*
639 %{_mandir}/man7/gitcli.7*
640 %{_mandir}/man7/gitcore-tutorial.7*
641 %{_mandir}/man7/gitcredentials.7*
642 %{_mandir}/man7/gitdiffcore.7*
643 %{_mandir}/man7/giteveryday.7*
644 %{_mandir}/man7/gitglossary.7*
645 %{_mandir}/man7/gitnamespaces.7*
646 %{_mandir}/man7/gitrevisions.7*
647 %{_mandir}/man7/gittutorial-2.7*
648 %{_mandir}/man7/gittutorial.7*
649 %{_mandir}/man7/gitworkflows.7*
650 %endif
651
652 %dir %{gitcoredir}
653 %attr(755,root,root) %{gitcoredir}/*-*
654 %attr(755,root,root) %{gitcoredir}/git
655 %dir %{gitcoredir}/mergetools
656 %{gitcoredir}/mergetools/*
657
658 %{_datadir}/%{name}
659 %{_localstatedir}/lib/git
660
661 # subpackages
662 %exclude %{gitcoredir}/*email*
663 %exclude %{gitcoredir}/*p4*
664 %exclude %{gitcoredir}/git-archimport
665 %exclude %{gitcoredir}/git-cvs*
666 %exclude %{gitcoredir}/git-gui
667 %exclude %{gitcoredir}/git-imap-send
668 %exclude %{gitcoredir}/git-instaweb
669 %exclude %{gitcoredir}/git-remote-bzr
670 %exclude %{gitcoredir}/git-remote-hg
671 %exclude %{gitcoredir}/git-remote-testsvn
672 %exclude %{gitcoredir}/git-svn
673 %exclude %{gitcoredir}/mergetools/p4merge
674 %if %{with gnome_keyring}
675 %exclude %{gitcoredir}/git-credential-gnome-keyring
676 %endif
677
678 %if %{with doc}
679 %files doc
680 %defattr(644,root,root,755)
681 %doc Documentation/RelNotes*
682 %doc Documentation/*.html Documentation/howto Documentation/technical
683 %endif
684
685 %files daemon-inetd
686 %defattr(644,root,root,755)
687 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
688
689 %files daemon-standalone
690 %defattr(644,root,root,755)
691 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
692 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
693
694 %files devel
695 %defattr(644,root,root,755)
696 %{_includedir}/%{name}
697 %{_libdir}/libgit.a
698 %{_libdir}/libgit_xdiff.a
699
700 %files gitk
701 %defattr(644,root,root,755)
702 %if %{with doc}
703 %{_mandir}/man1/gitk.1*
704 %endif
705 %attr(755,root,root) %{_bindir}/gitk
706 %dir %{_datadir}/gitk
707 %dir %{_datadir}/gitk/lib
708 %dir %{_datadir}/gitk/lib/msgs
709 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
710 %lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
711 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
712 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
713 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
714 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
715 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
716 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
717 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
718 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
719 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
720 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
721
722 %files gitweb
723 %defattr(644,root,root,755)
724 %doc gitweb/{README,INSTALL}
725 %dir %{webappdir}
726 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
727 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
728 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
729 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
730 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
731 %attr(755,root,root) %{cgibindir}/gitweb.cgi
732 %{appdir}
733 %attr(755,root,root) %{gitcoredir}/git-instaweb
734 %if %{with doc}
735 %{_mandir}/man1/gitweb.1*
736 %{_mandir}/man5/gitweb.conf.5*
737 %endif
738
739 %files gitview
740 %defattr(644,root,root,755)
741 %doc contrib/gitview/gitview.txt
742 %attr(755,root,root) %{_bindir}/gitview
743
744 %files gui
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{gitcoredir}/git-gui
747 %dir %{_datadir}/git-gui
748 %dir %{_datadir}/git-gui/lib
749 %dir %{_datadir}/git-gui/lib/msgs
750 %{_datadir}/git-gui/lib/git-gui.ico
751 %{_datadir}/git-gui/lib/tclIndex
752 %{_datadir}/git-gui/lib/*.js
753 %{_datadir}/git-gui/lib/*.tcl
754 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
755 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
756 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
757 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
758 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
759 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
760 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
761 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
762 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
763 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
764 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
765 %lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
766 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
767
768 %files arch
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{gitcoredir}/git-archimport
771 %if %{with doc}
772 %{_mandir}/man1/git-archimport.1*
773 %endif
774
775 %files bzr
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{gitcoredir}/git-remote-bzr
778
779 %files cvs
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_bindir}/git-cvsserver
782 %attr(755,root,root) %{gitcoredir}/git-cvs*
783 %if %{with doc}
784 %{_mandir}/man1/git-cvs*.1*
785 %{_mandir}/man7/gitcvs-migration.7*
786 %endif
787
788 %files hg
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{gitcoredir}/git-remote-hg
791
792 %files p4
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{gitcoredir}/git-p4
795 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
796
797 %files svn
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{gitcoredir}/git-svn
800 %attr(755,root,root) %{gitcoredir}/git-remote-testsvn
801 %{perl_vendorlib}/Git/SVN
802 %{perl_vendorlib}/Git/SVN.pm
803 %if %{with doc}
804 %{_mandir}/man1/git-svn.1*
805 %endif
806
807 %files email
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{gitcoredir}/git-imap-send
810 %attr(755,root,root) %{gitcoredir}/*email*
811 %if %{with doc}
812 %{_mandir}/man1/*email*.1*
813 %{_mandir}/man1/*imap-send*.1*
814 %endif
815
816 %files -n bash-completion-git
817 %defattr(644,root,root,755)
818 %{bash_compdir}/git
819
820 %files -n perl-Git
821 %defattr(644,root,root,755)
822 %{perl_vendorlib}/Git.pm
823 %dir %{perl_vendorlib}/Git
824 %{perl_vendorlib}/Git/I18N.pm
825 %{perl_vendorlib}/Git/IndexInfo.pm
826 %{_mandir}/man3/Git*.3pm*
827
828 %if %{with gnome_keyring}
829 %files -n gnome-keyring-git-core
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
832 %endif
This page took 0.080564 seconds and 4 git commands to generate.