]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.8.0-rc1
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_with     tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %define _rc  rc1
9
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        Distributed version control system focused on speed, effectivity and usability
12 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
13 Name:           git-core
14 Version:        1.8.0
15 Release:        0.%{_rc}.1
16 License:        GPL v2
17 Group:          Development/Tools
18 Source0:        http://git-core.googlecode.com/files/git-%{version}.%{_rc}.tar.gz
19 # Source0-md5:  86a034e9c787444c56ef744c1837a676
20 Source1:        %{name}-gitweb.conf
21 Source2:        %{name}-gitweb-httpd.conf
22 Source3:        %{name}-gitweb-lighttpd.conf
23 Source4:        %{name}.sysconfig
24 Source5:        %{name}.inet
25 Source6:        %{name}.init
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 URL:            http://git-scm.com/
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  curl-devel
33 BuildRequires:  expat-devel
34 BuildRequires:  gettext-devel
35 BuildRequires:  openssl-devel
36 BuildRequires:  perl-Error > 0.15
37 BuildRequires:  perl-base
38 BuildRequires:  python-devel
39 BuildRequires:  rpm-perlprov >= 4.1-13
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.264
42 BuildRequires:  tcl
43 BuildRequires:  zlib-devel
44 %if %{with doc}
45 BuildRequires:  asciidoc >= 7.1.2-3
46 BuildRequires:  docbook-dtd45-xml
47 BuildRequires:  xmlto
48 %endif
49 %if %{with tests}
50 %if %{with tests_cvs}
51 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
52 BuildRequires:  cvs-gnu-client < 1.13
53 BuildRequires:  cvs-gnu-client >= 1.12
54 %endif
55 Conflicts:      pdksh < 5.2.14-46
56 %endif
57 Requires:       coreutils
58 Requires:       diffutils
59 Requires:       findutils
60 Requires:       grep
61 Requires:       openssh-clients
62 Requires:       perl-Error
63 Requires:       perl-Git = %{version}-%{release}
64 Requires:       sed
65 Suggests:       git-core-cvs
66 Suggests:       git-core-svn
67 Suggests:       less
68 Suggests:       rsync
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 # html docs have links to txt files
72 %define         _noautocompressdoc      *.txt
73
74 %define         webapp          gitweb
75 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
76 %define         appdir          %{_datadir}/%{webapp}
77 %define         cgibindir       %{_prefix}/lib/cgi-bin
78
79 %description
80 "git" can mean anything, depending on your mood.
81
82 - random three-letter combination that is pronounceable, and not
83   actually used by any common UNIX command. The fact that it is a
84   mispronunciation of "get" may or may not be relevant.
85 - stupid. contemptible and despicable. simple. Take your pick from the
86   dictionary of slang.
87 - "global information tracker": you're in a good mood, and it actually
88   works for you. Angels sing, and a light suddenly fills the room.
89 - "goddamn idiotic truckload of sh*t": when it breaks
90
91 This is a stupid (but extremely fast) directory content manager. It
92 doesn't do a whole lot, but what it 'does' do is track directory
93 contents efficiently.
94
95 %description -l pl.UTF-8
96 "git" może oznaczać cokolwiek, w zależności od nastroju.
97
98 - losową kombinację trzech liter, która jest wymawialna i właściwie
99   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
100   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
101 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
102 - "global information tracker" (narzędzie do globalnego śledzenia
103   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
104   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
105 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
106   g*) - kiedy się zepsuje.
107
108 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
109 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
110 katalogu.
111
112 %package doc
113 Summary:        Documentation for git-core
114 Summary(pl.UTF-8):      Dokumentacja do git-core
115 Group:          Documentation
116
117 %description doc
118 Documentation for git-core.
119
120 %description doc -l pl.UTF-8
121 Dokumentacja do git-core.
122
123 %description doc -l fr.UTF-8
124 Javadoc pour git-core.
125
126 %package daemon-inetd
127 Summary:        Files necessary to run git-daemon as an inetd service
128 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
129 Group:          Networking/Daemons
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       setup >= 2.4.11-1
132 Provides:       git-core-daemon
133 Obsoletes:      git-core-daemon
134 Obsoletes:      git-core-daemon-standalone
135
136 %description daemon-inetd
137 Git-daemon is a really simple TCP git daemon that can serve git
138 repositories. This package provides all necessarry files to run
139 git-daemon as an inetd service.
140
141 %description daemon-inetd -l pl.UTF-8
142 Git-daemon to prosty demon git korzystający z protokołu TCP do
143 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
144 do uruchomienia git-demona w trybie usługi inetd.
145
146 %package daemon-standalone
147 Summary:        Files necessary to run git-daemon as a standalone service
148 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
149 Group:          Networking/Daemons
150 Requires:       %{name} = %{version}-%{release}
151 Provides:       git-core-daemon
152 Obsoletes:      git-core-daemon
153 Obsoletes:      git-core-daemon-inetd
154
155 %description daemon-standalone
156 Git-daemon is a really simple TCP git daemon that can serve git
157 repositories. This package provides all necessarry files to run
158 git-daemon as an standalone service.
159
160 %description daemon-standalone -l pl.UTF-8
161 Git-daemon to prosty demon git korzystający z protokołu TCP do
162 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
163 do uruchomienia git-daemona w trybie usługi samodzielnej.
164
165 %package devel
166 Summary:        Header files for git-core
167 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
168 Group:          Development/Libraries
169 Requires:       zlib-devel
170
171 %description devel
172 Header files for git-core.
173
174 %description devel -l pl.UTF-8
175 Pliki nagłówkowe dla git-core.
176
177 %package gitk
178 Summary:        Tcl/Tk interface to the Git version control system
179 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
180 Group:          Development/Tools
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       tk
183
184 %description gitk
185 gitk displays changes in a repository or a selected set of commits.
186 This includes visualizing the commit graph, showing information
187 related to each commit, and the files in the trees of each revision.
188
189 Historically, gitk was the first repository browser. It's written in
190 Tcl/Tk and started off in a separate repository but was later merged
191 into the main git repository.
192
193 %description gitk -l pl.UTF-8
194 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
195 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
196 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
197
198 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
199 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
200 osobnym repozytorium, ale z czasem został włączony do głównego
201 repozytorium gita.
202
203 %package gitweb
204 Summary:        Web frontend to git
205 Summary(pl.UTF-8):      Frontend WWW do gita
206 Group:          Development/Tools
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       webapps
209 Requires:       webserver(alias)
210 Requires:       webserver(cgi)
211 Suggests:       webserver(setenv)
212
213 %description gitweb
214 This package provides a web interface for browsing git repositories.
215
216 %description gitweb -l pl.UTF-8
217 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
218
219 %package gitview
220 Summary:        A GTK+ based repository browser for git
221 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
222 Group:          Development/Tools
223 Requires:       %{name} = %{version}-%{release}
224 Requires:       python >= 1:2.4
225 Requires:       python-pycairo >= 1.0
226 Requires:       python-pygobject
227 Requires:       python-pygtk-gtk >= 2:2.8
228 Suggests:       python-gnome-desktop-gtksourceview
229
230 %description gitview
231 A GTK+ based repository browser for git.
232
233 %description gitview -l pl.UTF-8
234 Oparta na GTK+ przeglądarka repozytorium gita.
235
236 %package gui
237 Summary:        Tcl/Tk interface to the Git version control system
238 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
239 Group:          Development/Tools
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       tk
242 Requires:       xdg-utils
243 Suggests:       meld
244
245 %description gui
246 Displays changes in a repository or a selected set of commits. This
247 includes visualizing the commit graph, showing information related to
248 each commit, and the files in the trees of each revision.
249
250 Historically, gitk was the first repository browser. It's written in
251 Tcl/Tk and started off in a separate repository but was later merged
252 into the main git repository.
253
254 %description gui -l pl.UTF-8
255 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
256 to wizualizację grafu commitów, wyświetlanie informacji związanych z
257 każdym z commitów oraz listę plików dla każdej rewizji.
258
259 Z punktu widzenia historii, gitk był pierwszą przeglądarką
260 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
261 osobnym repozytorium, ale z czasem został włączony do głównego
262 repozytorium gita.
263
264 %package svn
265 Summary:        Subversion support for Git
266 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
267 Group:          Development/Tools
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       perl-Encode
270 Requires:       perl-Term-ReadKey
271
272 %description svn
273 Subversion support for Git.
274
275 %description svn -l pl.UTF-8
276 Obsługa Subversion dla Gita.
277
278 %package cvs
279 Summary:        CVS support for Git
280 Summary(pl.UTF-8):      Obsługa CVS dla Gita
281 Group:          Development/Tools
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       cvsps >= 2.1-2
284 Requires:       rcs
285
286 %description cvs
287 CVS support for Git.
288
289 %description cvs -l pl.UTF-8
290 Obsługa CVS dla Gita.
291
292 %package arch
293 Summary:        Git tools for importing Arch repositories
294 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
295 Group:          Development/Tools
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       tla
298
299 %description arch
300 Git tools for importing Arch repositories.
301
302 %description arch -l pl.UTF-8
303 Narzędzia Gita do importowania repozytoriów Archa.
304
305 %package email
306 Summary:        Git tools for sending email
307 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
308 Group:          Development/Tools
309 Requires:       %{name} = %{version}-%{release}
310
311 %description email
312 Git tools for sending email.
313
314 %description email -l pl.UTF-8
315 Narzędzia Gita do wysyłania poczty.
316
317 %package -n bash-completion-git
318 Summary:        bash-completion for git
319 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
320 Group:          Applications/Shells
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       bash-completion
323
324 %description -n bash-completion-git
325 This package provides bash-completion for git.
326
327 %description -n bash-completion-git -l pl.UTF-8
328 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
329
330 %package -n perl-Git
331 Summary:        Perl interface to the Git version control system
332 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
333 Group:          Development/Languages/Perl
334 Obsoletes:      perl-git-core
335
336 %description -n perl-Git
337 This module provides Perl scripts easy way to interface the Git
338 version control system. The modules have an easy and well-tested way
339 to call arbitrary Git commands; in the future, the interface will also
340 provide specialized methods for doing easily operations which are not
341 totally trivial to do over the generic command interface.
342
343 %description -n perl-Git -l pl.UTF-8
344 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
345 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
346 dowolne polecenia Gita; w przyszłości interfejs udostępni także
347 specjalne metody do łatwego wykonywania operacji nietrywialnych do
348 wykonania przy użyciu ogólnego interfejsu poleceń.
349
350 %package -n python-Git
351 Summary:        Python Git remote helpers for non-git repositories
352 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
353 Group:          Development/Languages/Python
354 Requires:       %{name} = %{version}-%{release}
355
356 %description -n python-Git
357 This package contains Python git_repote_helpers package - Git remote
358 helpers for non-git repositories.
359
360 %description -n python-Git -l pl.UTF-8
361 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
362 pomocnicze Gita dla repozytoriów niegitowych.
363
364 %package -n vim-syntax-gitcommit
365 Summary:        Vim syntax: gitcommit
366 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
367 Group:          Applications/Editors/Vim
368 Requires:       %{name} = %{version}-%{release}
369 # for _vimdatadir existence
370 Requires:       vim-rt >= 4:6.3.058-3
371
372 %description -n vim-syntax-gitcommit
373 This plugin provides syntax highlighting for git's commit messages.
374
375 %description -n vim-syntax-gitcommit -l pl.UTF-8
376 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
377
378 %prep
379 %setup -q -n git-%{version}.%{_rc}
380 %patch0 -p1
381 %patch1 -p0
382 %patch2 -p1
383
384 %build
385 %{__aclocal}
386 %{__autoconf}
387 %configure \
388         --sysconfdir=%{_sysconfdir}/git-core \
389         --with-openssl
390
391 echo "BLK_SHA1=1" >> config.mak
392
393 %{__make} \
394         INSTALLDIRS=vendor \
395         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
396         GITWEB_PROJECTROOT="/var/lib/git" \
397         GITWEB_CSS="/gitweb/gitweb.css" \
398         GITWEB_LOGO="/gitweb/git-logo.png" \
399         GITWEB_FAVICON="/gitweb/git-favicon.png" \
400         V=1
401
402 %{?with_doc:%{__make} -C Documentation V=1}
403
404 %if %{with tests}
405 %if %{without tests_cvs}
406 rm t/t*cvs*.sh || :
407 %endif
408 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
409 %endif
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
414 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
415 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
416 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
417 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
418 [init]
419         templatedir = %{_sysconfdir}/%{name}/templates
420 EOF
421
422 %{__make} install \
423         INSTALLDIRS=vendor \
424         DESTDIR=$RPM_BUILD_ROOT
425
426 %if %{with doc}
427 %{__make} -C Documentation install \
428         DESTDIR=$RPM_BUILD_ROOT
429 %endif
430
431 # copy templates except sample hooks
432 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
433 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
434
435 # header files and lib
436 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
437 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
438 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
439 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
440 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
441
442 # bash completion
443 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
444 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
445
446 # vim syntax
447 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
448 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
449 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
450 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
451 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
452 autocmd BufNewFile,BufRead .msg.[0-9]*
453         \ if getline(1) =~ '^From.*# This line is ignored.$' |
454         \   setf gitsendemail |
455         \ endif
456 autocmd BufNewFile,BufRead *.git/**
457         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
458         \   setf git |
459         \ endif
460 EOF
461
462 # gitweb
463 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
464 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
465 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
466 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
467 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
468 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
469
470 # gitview
471 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
472
473 # git-daemon related files
474 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
475 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
476 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
477
478 # paths cleanup
479 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
480 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
481
482 # hardlink
483 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
484 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
485 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
486 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
487
488 # remove unneeded files
489 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
490 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
491 %py_postclean
492
493 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
494 %find_lang git
495
496 %clean
497 rm -rf $RPM_BUILD_ROOT
498
499 %post daemon-inetd
500 %service -q rc-inetd reload
501
502 %postun daemon-inetd
503 if [ "$1" = "0" ]; then
504         %service -q rc-inetd reload
505 fi
506
507 %post daemon-standalone
508 /sbin/chkconfig --add git-daemon
509 %service git-daemon restart "git-daemon"
510
511 %preun daemon-standalone
512 if [ "$1" = "0" ]; then
513         %service git-daemon stop
514         /sbin/chkconfig --del git-daemon
515 fi
516
517 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
518 %webapp_register apache %{webapp}
519
520 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
521 %webapp_unregister apache %{webapp}
522
523 %triggerin gitweb -- apache < 2.2.0, apache-base
524 %webapp_register httpd %{webapp}
525
526 %triggerun gitweb -- apache < 2.2.0, apache-base
527 %webapp_unregister httpd %{webapp}
528
529 %triggerin gitweb -- lighttpd
530 %webapp_register lighttpd %{webapp}
531
532 %triggerun gitweb -- lighttpd
533 %webapp_unregister lighttpd %{webapp}
534
535 %files -f git.lang
536 %defattr(644,root,root,755)
537 %doc README contrib
538 %attr(755,root,root) %{_bindir}/git
539 %attr(755,root,root) %{_bindir}/git-receive-pack
540 %attr(755,root,root) %{_bindir}/git-shell
541 %attr(755,root,root) %{_bindir}/git-upload-archive
542 %attr(755,root,root) %{_bindir}/git-upload-pack
543 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
544
545 %if %{with doc}
546 %{_mandir}/man1/git-*.1*
547 %exclude %{_mandir}/man1/git-archimport.1*
548 %exclude %{_mandir}/man1/git-svn.1*
549 %exclude %{_mandir}/man1/git-cvs*.1*
550 %exclude %{_mandir}/man1/*email*.1*
551 %exclude %{_mandir}/man1/git-remote-helpers.1*
552 %{_mandir}/man1/git.1*
553 %{_mandir}/man5/gitattributes.5*
554 %{_mandir}/man5/githooks.5*
555 %{_mandir}/man5/gitignore.5*
556 %{_mandir}/man5/gitmodules.5*
557 %{_mandir}/man5/gitrepository-layout.5*
558 %{_mandir}/man7/gitcli.7*
559 %{_mandir}/man7/gitcore-tutorial.7*
560 %{_mandir}/man7/gitcredentials.7*
561 %{_mandir}/man7/gitdiffcore.7*
562 %{_mandir}/man7/gitglossary.7*
563 %{_mandir}/man7/gitnamespaces.7*
564 %{_mandir}/man7/gitrevisions.7*
565 %{_mandir}/man7/gittutorial-2.7*
566 %{_mandir}/man7/gittutorial.7*
567 %{_mandir}/man7/gitworkflows.7*
568 %endif
569
570 %dir %{_libdir}/%{name}
571 %attr(755,root,root) %{_libdir}/%{name}/*-*
572 %attr(755,root,root) %{_libdir}/%{name}/git
573 %{_libdir}/%{name}/mergetools
574
575 %exclude %{_libdir}/%{name}/git-gui
576 %exclude %{_libdir}/%{name}/git-svn
577 %exclude %{_libdir}/%{name}/git-archimport
578 %exclude %{_libdir}/%{name}/git-cvs*
579 %exclude %{_libdir}/%{name}/git-instaweb
580 %exclude %{_libdir}/%{name}/git-remote-testgit
581 %exclude %{_libdir}/%{name}/*email*
582
583 %{_datadir}/%{name}
584
585 %{_localstatedir}/lib/git
586
587 %if %{with doc}
588 %files doc
589 %defattr(644,root,root,755)
590 %doc Documentation/RelNotes*
591 %doc Documentation/*.html Documentation/howto Documentation/technical
592 %endif
593
594 %files daemon-inetd
595 %defattr(644,root,root,755)
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
597
598 %files daemon-standalone
599 %defattr(644,root,root,755)
600 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
601 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
602
603 %files devel
604 %defattr(644,root,root,755)
605 %{_includedir}/%{name}
606 %{_libdir}/libgit.a
607 %{_libdir}/libgit_xdiff.a
608
609 %files gitk
610 %defattr(644,root,root,755)
611 %if %{with doc}
612 %{_mandir}/man1/gitk.1*
613 %endif
614 %attr(755,root,root) %{_bindir}/gitk
615 %dir %{_datadir}/gitk
616 %dir %{_datadir}/gitk/lib
617 %dir %{_datadir}/gitk/lib/msgs
618 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
619 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
620 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
621 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
622 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
623 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
624 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
625 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
626 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
627
628 %files gitweb
629 %defattr(644,root,root,755)
630 %doc gitweb/{README,INSTALL}
631 %dir %{webappdir}
632 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
633 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
634 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
635 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
636 %attr(755,root,root) %{cgibindir}/gitweb.cgi
637 %{appdir}
638 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
639 %if %{with doc}
640 %{_mandir}/man1/gitweb.1*
641 %{_mandir}/man5/gitweb.conf.5*
642 %endif
643
644 %files gitview
645 %defattr(644,root,root,755)
646 %doc contrib/gitview/gitview.txt
647 %attr(755,root,root) %{_bindir}/gitview
648
649 %files gui
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/%{name}/git-gui
652 %dir %{_datadir}/git-gui
653 %dir %{_datadir}/git-gui/lib
654 %dir %{_datadir}/git-gui/lib/msgs
655 %{_datadir}/git-gui/lib/git-gui.ico
656 %{_datadir}/git-gui/lib/tclIndex
657 %{_datadir}/git-gui/lib/*.js
658 %{_datadir}/git-gui/lib/*.tcl
659 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
660 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
661 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
662 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
663 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
664 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
665 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
666 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
667 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
668 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
669 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
670
671 %files svn
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/%{name}/git-svn
674 %{perl_vendorlib}/Git/SVN
675 %{perl_vendorlib}/Git/SVN.pm
676 %if %{with doc}
677 %{_mandir}/man1/git-svn.1*
678 %endif
679
680 %files cvs
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/git-cvsserver
683 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
684 %if %{with doc}
685 %{_mandir}/man1/git-cvs*.1*
686 %{_mandir}/man7/gitcvs-migration.7*
687 %endif
688
689 %files arch
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
692 %if %{with doc}
693 %{_mandir}/man1/git-archimport.1*
694 %endif
695
696 %files email
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/%{name}/*email*
699 %if %{with doc}
700 %{_mandir}/man1/*email*.1*
701 %endif
702
703 %files -n bash-completion-git
704 %defattr(644,root,root,755)
705 /etc/bash_completion.d/git-completion.bash
706
707 %files -n perl-Git
708 %defattr(644,root,root,755)
709 %{perl_vendorlib}/Git.pm
710 %dir %{perl_vendorlib}/Git
711 %{perl_vendorlib}/Git/I18N.pm
712 %{perl_vendorlib}/Git/IndexInfo.pm
713 %{_mandir}/man3/Git*.3pm*
714
715 %files -n python-Git
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
718 %dir %{py_sitescriptdir}/git_remote_helpers
719 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
720 %dir %{py_sitescriptdir}/git_remote_helpers/git
721 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
722 %if "%{py_ver}" > "2.4"
723 %{py_sitescriptdir}/git_remote_helpers*.egg-info
724 %endif
725 %if %{with doc}
726 %{_mandir}/man1/git-remote-helpers.1*
727 %endif
728
729 %files -n vim-syntax-gitcommit
730 %defattr(644,root,root,755)
731 %doc contrib/vim/README
732 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.099091 seconds and 4 git commands to generate.