]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.5.3.4
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.3.4
10 Release:        1
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  b35fd5abba0e8655733c8e8c470f39cf
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc >= 7.1.2-3
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 %{?with_tests:BuildRequires:    pdksh >= 5.2.14-46}
27 BuildRequires:  python
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRequires:  rpmbuild(macros) >= 1.264
30 BuildRequires:  xmlto
31 BuildRequires:  zlib-devel
32 Requires:       coreutils
33 Requires:       curl
34 Requires:       diffutils
35 Requires:       findutils
36 Requires:       grep
37 Requires:       openssh-clients
38 Requires:       perl-Error
39 Requires:       rcs
40 Requires:       sed
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         webapp          gitweb
44 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
45 %define         appdir          %{_datadir}/%{webapp}
46 %define         cgibindir       %{_prefix}/lib/cgi-bin
47
48 %description
49 "git" can mean anything, depending on your mood.
50
51  - random three-letter combination that is pronounceable, and not
52    actually used by any common UNIX command. The fact that it is a
53    mispronunciation of "get" may or may not be relevant.
54  - stupid. contemptible and despicable. simple. Take your pick from the
55    dictionary of slang.
56  - "global information tracker": you're in a good mood, and it actually
57    works for you. Angels sing, and a light suddenly fills the room.
58  - "goddamn idiotic truckload of sh*t": when it breaks
59
60 This is a stupid (but extremely fast) directory content manager. It
61 doesn't do a whole lot, but what it 'does' do is track directory
62 contents efficiently.
63
64 %description -l pl.UTF-8
65 "git" może oznaczać cokolwiek, w zależności od nastroju.
66
67 - losową kombinację trzech liter, która jest wymawialna i
68   właściwie nie używana przez żadne popularne polecenie uniksowe.
69   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
70   mieć znaczenia.
71 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
72 - "global information tracker" (narzędzie do globalnego śledzenia
73   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
74   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
75 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
76   g*) - kiedy się zepsuje.
77
78 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
79 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
80 katalogu.
81
82 %package devel
83 Summary:        Header files for git-core
84 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
85 Group:          Development/Libraries
86
87 %description devel
88 Header files for git-core.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe dla git-core.
92
93 %package gitk
94 Summary:        Tcl/Tk interface to the Git version control system
95 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
96 Group:          Development/Tools
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       tk
99
100 %description gitk
101 Displays changes in a repository or a selected set of commits. This
102 includes visualizing the commit graph, showing information related to
103 each commit, and the files in the trees of each revision.
104
105 Historically, gitk was the first repository browser. It's written in
106 Tcl/Tk and started off in a separate repository but was later merged
107 into the main git repository.
108
109 %description gitk -l pl.UTF-8
110 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
111 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
112 związanych z każdym z commitów oraz listę plików dla każdej
113 rewizji.
114
115 Z punktu widzenia historii, gitk był pierwszą przeglądarką
116 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
117 w osobnym repozytorium, ale z czasem został włączony do głównego
118 repozytorium gita.
119
120 %package gitweb
121 Summary:        Web frontend to git
122 Summary(pl.UTF-8):      Webowy frontend do git
123 Group:          Development/Tools
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       webapps
126
127 %description gitweb
128 This package provides a web interface for browsing git repositories.
129
130 %description gitweb -l pl.UTF-8
131 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
132
133 %package -n bash-completion-git
134 Summary:        bash-completion for git
135 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
136 Group:          Applications/Shell
137 Requires:       bash-completion
138
139 %description -n bash-completion-git
140 This package provides bash-completion for git.
141
142 %description -n bash-completion-git -l pl.UTF-8
143 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
144
145 %package -n perl-Git
146 Summary:        Perl interface to the Git version control system
147 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
148 Group:          Development/Languages/Perl
149 Requires:       %{name} = %{version}-%{release}
150 Obsoletes:      perl-git-core
151
152 %description -n perl-Git
153 This module provides Perl scripts easy way to interface the Git
154 version control system. The modules have an easy and well-tested way
155 to call arbitrary Git commands; in the future, the interface will also
156 provide specialized methods for doing easily operations which are not
157 totally trivial to do over the generic command interface.
158
159 %description -n perl-Git -l pl.UTF-8
160 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
161 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
162 wywoływać dowolne polecenia Gita; w przyszłości interfejs
163 udostępni także specjalne metody do łatwego wykonywania operacji
164 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
165 poleceń.
166
167 %package -n vim-syntax-gitcommit
168 Summary:        Vim syntax: gitcommit
169 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
170 Group:          Applications/Editors/Vim
171 # for _vimdatadir existence
172 Requires:       vim >= 4:6.3.058-3
173
174 %description -n vim-syntax-gitcommit
175 This plugin provides syntax highlighting for git's commit messages.
176
177 %description -n vim-syntax-gitcommit -l pl.UTF-8
178 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
179
180 %prep
181 %setup -q -n git-%{version}
182
183 %build
184 %{__aclocal}
185 %{__autoconf}
186 %configure \
187         --with-openssl
188
189 %{__make} \
190         INSTALLDIRS=vendor \
191         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
192         GITWEB_PROJECTROOT="/var/lib/git" \
193         GITWEB_CSS="/gitweb/gitweb.css" \
194         GITWEB_LOGO="/gitweb/git-logo.png" \
195         GITWEB_FAVICON="/gitweb/git-favicon.png"
196
197 %{__make} -C Documentation
198
199 %{?with_tests:%{__make} test}
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
204 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
205 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
206 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
207
208 %{__make} install \
209         INSTALLDIRS=vendor \
210         DESTDIR=$RPM_BUILD_ROOT
211
212 %{__make} -C Documentation install \
213         DESTDIR=$RPM_BUILD_ROOT
214
215 # header files and lib
216 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
217 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
218 install libgit.a $RPM_BUILD_ROOT%{_libdir}
219
220 # bash completion
221 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
222
223 # vim syntax
224 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
225
226 # gitweb
227 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
228 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
229 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
230 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
231 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
232
233 # remove unneeded files
234 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
235 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
239
240 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
241 %webapp_register apache %{webapp}
242
243 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
244 %webapp_unregister apache %{webapp}
245
246 %triggerin gitweb -- apache < 2.2.0, apache-base
247 %webapp_register httpd %{webapp}
248
249 %triggerun gitweb -- apache < 2.2.0, apache-base
250 %webapp_unregister httpd %{webapp}
251
252 %files
253 %defattr(644,root,root,755)
254 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
255 %attr(755,root,root) %{_bindir}/git
256 %attr(755,root,root) %{_bindir}/git-*
257 %{_mandir}/man1/git-*.1*
258 %{_mandir}/man5/gitattributes.5*
259 %{_mandir}/man5/gitignore.5*
260 %{_mandir}/man5/gitmodules.5*
261 %{_mandir}/man7/git.7*
262 %{_datadir}/%{name}
263 %{_datadir}/git-gui
264 %{_sharedstatedir}/git
265
266 %files devel
267 %defattr(644,root,root,755)
268 %{_includedir}/*
269 %{_libdir}/*.a
270
271 %files gitk
272 %defattr(644,root,root,755)
273 %doc Documentation/gitk.html
274 %attr(755,root,root) %{_bindir}/gitk
275 %{_mandir}/man1/gitk.1*
276
277 %files gitweb
278 %defattr(644,root,root,755)
279 %doc gitweb/{README,INSTALL}
280 %dir %{webappdir}
281 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
282 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
283 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
284 %attr(755,root,root) %{cgibindir}/gitweb.cgi
285 %{appdir}
286
287 %files -n bash-completion-git
288 %defattr(644,root,root,755)
289 %{_sysconfdir}/bash_completion.d/*
290
291 %files -n perl-Git
292 %defattr(644,root,root,755)
293 %{perl_vendorlib}/Git.pm
294 %{_mandir}/man3/Git.3pm*
295
296 %files -n vim-syntax-gitcommit
297 %defattr(644,root,root,755)
298 %doc contrib/vim/README
299 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.050844 seconds and 4 git commands to generate.