]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.7.12
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_with     tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Distributed version control system focused on speed, effectivity and usability
10 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11 Name:           git-core
12 Version:        1.7.12
13 Release:        1
14 License:        GPL v2
15 Group:          Development/Tools
16 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
17 # Source0-md5:  ceb1a6b17a3e33bbc70eadf8fce5876c
18 Source1:        %{name}-gitweb.conf
19 Source2:        %{name}-gitweb-httpd.conf
20 Source3:        %{name}-gitweb-lighttpd.conf
21 Source4:        %{name}.sysconfig
22 Source5:        %{name}.inet
23 Source6:        %{name}.init
24 Patch0:         %{name}-tests.patch
25 Patch1:         %{name}-key-bindings.patch
26 Patch2:         %{name}-sysconfdir.patch
27 URL:            http://git-scm.com/
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake
30 BuildRequires:  curl-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  gettext-devel
33 BuildRequires:  openssl-devel
34 BuildRequires:  perl-Error > 0.15
35 BuildRequires:  perl-base
36 BuildRequires:  python-devel
37 BuildRequires:  rpm-perlprov >= 4.1-13
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.264
40 BuildRequires:  tcl
41 BuildRequires:  zlib-devel
42 %if %{with doc}
43 BuildRequires:  asciidoc >= 7.1.2-3
44 BuildRequires:  docbook-dtd45-xml
45 BuildRequires:  xmlto
46 %endif
47 %if %{with tests}
48 %if %{with tests_cvs}
49 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
50 BuildRequires:  cvs-gnu-client < 1.13
51 BuildRequires:  cvs-gnu-client >= 1.12
52 %endif
53 Conflicts:      pdksh < 5.2.14-46
54 %endif
55 Requires:       coreutils
56 Requires:       diffutils
57 Requires:       findutils
58 Requires:       grep
59 Requires:       openssh-clients
60 Requires:       perl-Error
61 Requires:       perl-Git = %{version}-%{release}
62 Requires:       sed
63 Suggests:       git-core-cvs
64 Suggests:       git-core-svn
65 Suggests:       less
66 Suggests:       rsync
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 # html docs have links to txt files
70 %define         _noautocompressdoc      *.txt
71
72 %define         webapp          gitweb
73 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
74 %define         appdir          %{_datadir}/%{webapp}
75 %define         cgibindir       %{_prefix}/lib/cgi-bin
76
77 %description
78 "git" can mean anything, depending on your mood.
79
80 - random three-letter combination that is pronounceable, and not
81   actually used by any common UNIX command. The fact that it is a
82   mispronunciation of "get" may or may not be relevant.
83 - stupid. contemptible and despicable. simple. Take your pick from the
84   dictionary of slang.
85 - "global information tracker": you're in a good mood, and it actually
86   works for you. Angels sing, and a light suddenly fills the room.
87 - "goddamn idiotic truckload of sh*t": when it breaks
88
89 This is a stupid (but extremely fast) directory content manager. It
90 doesn't do a whole lot, but what it 'does' do is track directory
91 contents efficiently.
92
93 %description -l pl.UTF-8
94 "git" może oznaczać cokolwiek, w zależności od nastroju.
95
96 - losową kombinację trzech liter, która jest wymawialna i właściwie
97   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
98   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
99 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
100 - "global information tracker" (narzędzie do globalnego śledzenia
101   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
102   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
103 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
104   g*) - kiedy się zepsuje.
105
106 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
107 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
108 katalogu.
109
110 %package doc
111 Summary:        Documentation for git-core
112 Summary(pl.UTF-8):      Dokumentacja do git-core
113 Group:          Documentation
114
115 %description doc
116 Documentation for git-core.
117
118 %description doc -l pl.UTF-8
119 Dokumentacja do git-core.
120
121 %description doc -l fr.UTF-8
122 Javadoc pour git-core.
123
124 %package daemon-inetd
125 Summary:        Files necessary to run git-daemon as an inetd service
126 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
127 Group:          Networking/Daemons
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       setup >= 2.4.11-1
130 Provides:       git-core-daemon
131 Obsoletes:      git-core-daemon
132 Obsoletes:      git-core-daemon-standalone
133
134 %description daemon-inetd
135 Git-daemon is a really simple TCP git daemon that can serve git
136 repositories. This package provides all necessarry files to run
137 git-daemon as an inetd service.
138
139 %description daemon-inetd -l pl.UTF-8
140 Git-daemon to prosty demon git korzystający z protokołu TCP do
141 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
142 do uruchomienia git-demona w trybie usługi inetd.
143
144 %package daemon-standalone
145 Summary:        Files necessary to run git-daemon as a standalone service
146 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
147 Group:          Networking/Daemons
148 Requires:       %{name} = %{version}-%{release}
149 Provides:       git-core-daemon
150 Obsoletes:      git-core-daemon
151 Obsoletes:      git-core-daemon-inetd
152
153 %description daemon-standalone
154 Git-daemon is a really simple TCP git daemon that can serve git
155 repositories. This package provides all necessarry files to run
156 git-daemon as an standalone service.
157
158 %description daemon-standalone -l pl.UTF-8
159 Git-daemon to prosty demon git korzystający z protokołu TCP do
160 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
161 do uruchomienia git-daemona w trybie usługi samodzielnej.
162
163 %package devel
164 Summary:        Header files for git-core
165 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
166 Group:          Development/Libraries
167 Requires:       zlib-devel
168
169 %description devel
170 Header files for git-core.
171
172 %description devel -l pl.UTF-8
173 Pliki nagłówkowe dla git-core.
174
175 %package gitk
176 Summary:        Tcl/Tk interface to the Git version control system
177 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
178 Group:          Development/Tools
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       tk
181
182 %description gitk
183 gitk displays changes in a repository or a selected set of commits.
184 This includes visualizing the commit graph, showing information
185 related to each commit, and the files in the trees of each revision.
186
187 Historically, gitk was the first repository browser. It's written in
188 Tcl/Tk and started off in a separate repository but was later merged
189 into the main git repository.
190
191 %description gitk -l pl.UTF-8
192 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
193 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
194 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
195
196 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
197 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
198 osobnym repozytorium, ale z czasem został włączony do głównego
199 repozytorium gita.
200
201 %package gitweb
202 Summary:        Web frontend to git
203 Summary(pl.UTF-8):      Frontend WWW do gita
204 Group:          Development/Tools
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       webapps
207 Requires:       webserver(alias)
208 Requires:       webserver(cgi)
209 Suggests:       webserver(setenv)
210
211 %description gitweb
212 This package provides a web interface for browsing git repositories.
213
214 %description gitweb -l pl.UTF-8
215 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
216
217 %package gitview
218 Summary:        A GTK+ based repository browser for git
219 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
220 Group:          Development/Tools
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       python >= 1:2.4
223 Requires:       python-pycairo >= 1.0
224 Requires:       python-pygobject
225 Requires:       python-pygtk-gtk >= 2:2.8
226 Suggests:       python-gnome-desktop-gtksourceview
227
228 %description gitview
229 A GTK+ based repository browser for git.
230
231 %description gitview -l pl.UTF-8
232 Oparta na GTK+ przeglądarka repozytorium gita.
233
234 %package gui
235 Summary:        Tcl/Tk interface to the Git version control system
236 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
237 Group:          Development/Tools
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       tk
240 Requires:       xdg-utils
241 Suggests:       meld
242
243 %description gui
244 Displays changes in a repository or a selected set of commits. This
245 includes visualizing the commit graph, showing information related to
246 each commit, and the files in the trees of each revision.
247
248 Historically, gitk was the first repository browser. It's written in
249 Tcl/Tk and started off in a separate repository but was later merged
250 into the main git repository.
251
252 %description gui -l pl.UTF-8
253 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
254 to wizualizację grafu commitów, wyświetlanie informacji związanych z
255 każdym z commitów oraz listę plików dla każdej rewizji.
256
257 Z punktu widzenia historii, gitk był pierwszą przeglądarką
258 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
259 osobnym repozytorium, ale z czasem został włączony do głównego
260 repozytorium gita.
261
262 %package svn
263 Summary:        Subversion support for Git
264 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
265 Group:          Development/Tools
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       perl-Encode
268 Requires:       perl-Term-ReadKey
269
270 %description svn
271 Subversion support for Git.
272
273 %description svn -l pl.UTF-8
274 Obsługa Subversion dla Gita.
275
276 %package cvs
277 Summary:        CVS support for Git
278 Summary(pl.UTF-8):      Obsługa CVS dla Gita
279 Group:          Development/Tools
280 Requires:       %{name} = %{version}-%{release}
281 Requires:       cvsps >= 2.1-2
282 Requires:       rcs
283
284 %description cvs
285 CVS support for Git.
286
287 %description cvs -l pl.UTF-8
288 Obsługa CVS dla Gita.
289
290 %package arch
291 Summary:        Git tools for importing Arch repositories
292 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
293 Group:          Development/Tools
294 Requires:       %{name} = %{version}-%{release}
295 Requires:       tla
296
297 %description arch
298 Git tools for importing Arch repositories.
299
300 %description arch -l pl.UTF-8
301 Narzędzia Gita do importowania repozytoriów Archa.
302
303 %package email
304 Summary:        Git tools for sending email
305 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
306 Group:          Development/Tools
307 Requires:       %{name} = %{version}-%{release}
308
309 %description email
310 Git tools for sending email.
311
312 %description email -l pl.UTF-8
313 Narzędzia Gita do wysyłania poczty.
314
315 %package -n bash-completion-git
316 Summary:        bash-completion for git
317 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
318 Group:          Applications/Shells
319 Requires:       %{name} = %{version}-%{release}
320 Requires:       bash-completion
321
322 %description -n bash-completion-git
323 This package provides bash-completion for git.
324
325 %description -n bash-completion-git -l pl.UTF-8
326 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
327
328 %package -n perl-Git
329 Summary:        Perl interface to the Git version control system
330 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
331 Group:          Development/Languages/Perl
332 Obsoletes:      perl-git-core
333
334 %description -n perl-Git
335 This module provides Perl scripts easy way to interface the Git
336 version control system. The modules have an easy and well-tested way
337 to call arbitrary Git commands; in the future, the interface will also
338 provide specialized methods for doing easily operations which are not
339 totally trivial to do over the generic command interface.
340
341 %description -n perl-Git -l pl.UTF-8
342 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
343 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
344 dowolne polecenia Gita; w przyszłości interfejs udostępni także
345 specjalne metody do łatwego wykonywania operacji nietrywialnych do
346 wykonania przy użyciu ogólnego interfejsu poleceń.
347
348 %package -n python-Git
349 Summary:        Python Git remote helpers for non-git repositories
350 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
351 Group:          Development/Languages/Python
352 Requires:       %{name} = %{version}-%{release}
353
354 %description -n python-Git
355 This package contains Python git_repote_helpers package - Git remote
356 helpers for non-git repositories.
357
358 %description -n python-Git -l pl.UTF-8
359 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
360 pomocnicze Gita dla repozytoriów niegitowych.
361
362 %package -n vim-syntax-gitcommit
363 Summary:        Vim syntax: gitcommit
364 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
365 Group:          Applications/Editors/Vim
366 Requires:       %{name} = %{version}-%{release}
367 # for _vimdatadir existence
368 Requires:       vim-rt >= 4:6.3.058-3
369
370 %description -n vim-syntax-gitcommit
371 This plugin provides syntax highlighting for git's commit messages.
372
373 %description -n vim-syntax-gitcommit -l pl.UTF-8
374 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
375
376 %prep
377 %setup -q -n git-%{version}
378 %patch0 -p1
379 %patch1 -p0
380 %patch2 -p1
381
382 %build
383 %{__aclocal}
384 %{__autoconf}
385 %configure \
386         --sysconfdir=%{_sysconfdir}/git-core \
387         --with-openssl
388
389 echo "BLK_SHA1=1" >> config.mak
390
391 %{__make} \
392         INSTALLDIRS=vendor \
393         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
394         GITWEB_PROJECTROOT="/var/lib/git" \
395         GITWEB_CSS="/gitweb/gitweb.css" \
396         GITWEB_LOGO="/gitweb/git-logo.png" \
397         GITWEB_FAVICON="/gitweb/git-favicon.png" \
398         V=1
399
400 %{?with_doc:%{__make} -C Documentation V=1}
401
402 %if %{with tests}
403 %if %{without tests_cvs}
404 rm t/t*cvs*.sh || :
405 %endif
406 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
407 %endif
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
412 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
413 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
414 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
415 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
416 [init]
417         templatedir = %{_sysconfdir}/%{name}/templates
418 EOF
419
420 %{__make} install \
421         INSTALLDIRS=vendor \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 %if %{with doc}
425 %{__make} -C Documentation install \
426         DESTDIR=$RPM_BUILD_ROOT
427 %endif
428
429 # copy templates except sample hooks
430 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
431 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
432
433 # header files and lib
434 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
435 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
436 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
437 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
438 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
439
440 # bash completion
441 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
442 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
443
444 # vim syntax
445 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
446 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
447 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
448 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
449 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
450 autocmd BufNewFile,BufRead .msg.[0-9]*
451         \ if getline(1) =~ '^From.*# This line is ignored.$' |
452         \   setf gitsendemail |
453         \ endif
454 autocmd BufNewFile,BufRead *.git/**
455         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
456         \   setf git |
457         \ endif
458 EOF
459
460 # gitweb
461 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
462 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
463 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
464 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
465 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
466 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
467
468 # gitview
469 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
470
471 # git-daemon related files
472 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
473 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
474 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
475
476 # paths cleanup
477 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
478 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
479
480 # hardlink
481 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
482 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
483 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
484 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
485
486 # remove unneeded files
487 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
488 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
489 %py_postclean
490
491 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
492 %find_lang git
493
494 %clean
495 rm -rf $RPM_BUILD_ROOT
496
497 %post daemon-inetd
498 %service -q rc-inetd reload
499
500 %postun daemon-inetd
501 if [ "$1" = "0" ]; then
502         %service -q rc-inetd reload
503 fi
504
505 %post daemon-standalone
506 /sbin/chkconfig --add git-daemon
507 %service git-daemon restart "git-daemon"
508
509 %preun daemon-standalone
510 if [ "$1" = "0" ]; then
511         %service git-daemon stop
512         /sbin/chkconfig --del git-daemon
513 fi
514
515 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
516 %webapp_register apache %{webapp}
517
518 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
519 %webapp_unregister apache %{webapp}
520
521 %triggerin gitweb -- apache < 2.2.0, apache-base
522 %webapp_register httpd %{webapp}
523
524 %triggerun gitweb -- apache < 2.2.0, apache-base
525 %webapp_unregister httpd %{webapp}
526
527 %triggerin gitweb -- lighttpd
528 %webapp_register lighttpd %{webapp}
529
530 %triggerun gitweb -- lighttpd
531 %webapp_unregister lighttpd %{webapp}
532
533 %files -f git.lang
534 %defattr(644,root,root,755)
535 %doc README contrib
536 %attr(755,root,root) %{_bindir}/git
537 %attr(755,root,root) %{_bindir}/git-receive-pack
538 %attr(755,root,root) %{_bindir}/git-shell
539 %attr(755,root,root) %{_bindir}/git-upload-archive
540 %attr(755,root,root) %{_bindir}/git-upload-pack
541 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
542
543 %if %{with doc}
544 %{_mandir}/man1/git-*.1*
545 %exclude %{_mandir}/man1/git-archimport.1*
546 %exclude %{_mandir}/man1/git-svn.1*
547 %exclude %{_mandir}/man1/git-cvs*.1*
548 %exclude %{_mandir}/man1/*email*.1*
549 %exclude %{_mandir}/man1/git-remote-helpers.1*
550 %{_mandir}/man1/git.1*
551 %{_mandir}/man5/gitattributes.5*
552 %{_mandir}/man5/githooks.5*
553 %{_mandir}/man5/gitignore.5*
554 %{_mandir}/man5/gitmodules.5*
555 %{_mandir}/man5/gitrepository-layout.5*
556 %{_mandir}/man7/gitcli.7*
557 %{_mandir}/man7/gitcore-tutorial.7*
558 %{_mandir}/man7/gitcredentials.7*
559 %{_mandir}/man7/gitdiffcore.7*
560 %{_mandir}/man7/gitglossary.7*
561 %{_mandir}/man7/gitnamespaces.7*
562 %{_mandir}/man7/gitrevisions.7*
563 %{_mandir}/man7/gittutorial-2.7*
564 %{_mandir}/man7/gittutorial.7*
565 %{_mandir}/man7/gitworkflows.7*
566 %endif
567
568 %dir %{_libdir}/%{name}
569 %attr(755,root,root) %{_libdir}/%{name}/*-*
570 %attr(755,root,root) %{_libdir}/%{name}/git
571 %{_libdir}/%{name}/mergetools
572
573 %exclude %{_libdir}/%{name}/git-gui
574 %exclude %{_libdir}/%{name}/git-svn
575 %exclude %{_libdir}/%{name}/git-archimport
576 %exclude %{_libdir}/%{name}/git-cvs*
577 %exclude %{_libdir}/%{name}/git-instaweb
578 %exclude %{_libdir}/%{name}/git-remote-testgit
579 %exclude %{_libdir}/%{name}/*email*
580
581 %{_datadir}/%{name}
582
583 %{_localstatedir}/lib/git
584
585 %if %{with doc}
586 %files doc
587 %defattr(644,root,root,755)
588 %doc Documentation/RelNotes*
589 %doc Documentation/*.html Documentation/howto Documentation/technical
590 %endif
591
592 %files daemon-inetd
593 %defattr(644,root,root,755)
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
595
596 %files daemon-standalone
597 %defattr(644,root,root,755)
598 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
599 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
600
601 %files devel
602 %defattr(644,root,root,755)
603 %{_includedir}/%{name}
604 %{_libdir}/libgit.a
605 %{_libdir}/libgit_xdiff.a
606
607 %files gitk
608 %defattr(644,root,root,755)
609 %if %{with doc}
610 %{_mandir}/man1/gitk.1*
611 %endif
612 %attr(755,root,root) %{_bindir}/gitk
613 %dir %{_datadir}/gitk
614 %dir %{_datadir}/gitk/lib
615 %dir %{_datadir}/gitk/lib/msgs
616 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
617 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
618 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
619 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
620 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
621 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
622 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
623 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
624 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
625
626 %files gitweb
627 %defattr(644,root,root,755)
628 %doc gitweb/{README,INSTALL}
629 %dir %{webappdir}
630 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
631 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
632 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
633 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
634 %attr(755,root,root) %{cgibindir}/gitweb.cgi
635 %{appdir}
636 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
637 %if %{with doc}
638 %{_mandir}/man1/gitweb.1*
639 %{_mandir}/man5/gitweb.conf.5*
640 %endif
641
642 %files gitview
643 %defattr(644,root,root,755)
644 %doc contrib/gitview/gitview.txt
645 %attr(755,root,root) %{_bindir}/gitview
646
647 %files gui
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/%{name}/git-gui
650 %dir %{_datadir}/git-gui
651 %dir %{_datadir}/git-gui/lib
652 %dir %{_datadir}/git-gui/lib/msgs
653 %{_datadir}/git-gui/lib/git-gui.ico
654 %{_datadir}/git-gui/lib/tclIndex
655 %{_datadir}/git-gui/lib/*.js
656 %{_datadir}/git-gui/lib/*.tcl
657 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
658 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
659 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
660 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
661 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
662 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
663 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
664 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
665 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
666 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
667 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
668
669 %files svn
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/%{name}/git-svn
672 %{perl_vendorlib}/Git/SVN
673 %{perl_vendorlib}/Git/SVN.pm
674 %if %{with doc}
675 %{_mandir}/man1/git-svn.1*
676 %endif
677
678 %files cvs
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_bindir}/git-cvsserver
681 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
682 %if %{with doc}
683 %{_mandir}/man1/git-cvs*.1*
684 %{_mandir}/man7/gitcvs-migration.7*
685 %endif
686
687 %files arch
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
690 %if %{with doc}
691 %{_mandir}/man1/git-archimport.1*
692 %endif
693
694 %files email
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/%{name}/*email*
697 %if %{with doc}
698 %{_mandir}/man1/*email*.1*
699 %endif
700
701 %files -n bash-completion-git
702 %defattr(644,root,root,755)
703 /etc/bash_completion.d/git-completion.bash
704
705 %files -n perl-Git
706 %defattr(644,root,root,755)
707 %{perl_vendorlib}/Git.pm
708 %dir %{perl_vendorlib}/Git
709 %{perl_vendorlib}/Git/I18N.pm
710 %{perl_vendorlib}/Git/IndexInfo.pm
711 %{_mandir}/man3/Git*.3pm*
712
713 %files -n python-Git
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
716 %dir %{py_sitescriptdir}/git_remote_helpers
717 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
718 %dir %{py_sitescriptdir}/git_remote_helpers/git
719 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
720 %if "%{py_ver}" > "2.4"
721 %{py_sitescriptdir}/git_remote_helpers*.egg-info
722 %endif
723 %if %{with doc}
724 %{_mandir}/man1/git-remote-helpers.1*
725 %endif
726
727 %files -n vim-syntax-gitcommit
728 %defattr(644,root,root,755)
729 %doc contrib/vim/README
730 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.082603 seconds and 4 git commands to generate.