]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 2.2.2
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        2.2.2
17 Release:        1
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  4ee47697b6cf5e98f97b2ba44baded79
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  gettext-tools
40 %if %{with gnome_keyring}
41 BuildRequires:  libgnome-keyring-devel
42 BuildRequires:  pkgconfig
43 %endif
44 BuildRequires:  openssl-devel
45 %{?with_pcre:BuildRequires:     pcre-devel}
46 BuildRequires:  perl-Error > 0.15
47 BuildRequires:  perl-base
48 BuildRequires:  python-devel
49 BuildRequires:  rpm-perlprov >= 4.1-13
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.673
52 BuildRequires:  tcl
53 BuildRequires:  zlib-devel
54 %if %{with doc}
55 BuildRequires:  asciidoc >= 7.1.2-3
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  xmlto
58 %endif
59 %if %{with tests}
60 %if %{with tests_cvs}
61 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62 BuildRequires:  cvs-gnu-client < 1.13
63 BuildRequires:  cvs-gnu-client >= 1.12
64 %endif
65 %{?with_tests_svn:BuildRequires:  subversion}
66 Conflicts:      pdksh < 5.2.14-46
67 %endif
68 # git-sh-setup: sane_grep
69 Requires:       grep
70 # git-pull: printf
71 Requires:       coreutils
72 Requires:       openssh-clients
73 Requires:       perl-Error
74 Requires:       perl-Git = %{version}-%{release}
75 Requires:       sed
76 Suggests:       git-core-bzr
77 Suggests:       git-core-cvs
78 Suggests:       git-core-hg
79 Suggests:       git-core-p4
80 Suggests:       git-core-svn
81 Suggests:       less
82 Suggests:       rsync
83 Obsoletes:      python-Git
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 # html docs have links to txt files
87 %define         _noautocompressdoc      *.txt
88
89 %define         webapp          gitweb
90 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
91 %define         appdir          %{_datadir}/%{webapp}
92 %define         cgibindir       %{_prefix}/lib/cgi-bin
93 %define         gitcoredir      %{_libdir}/%{name}
94
95 %description
96 "git" can mean anything, depending on your mood.
97
98 - random three-letter combination that is pronounceable, and not
99   actually used by any common UNIX command. The fact that it is a
100   mispronunciation of "get" may or may not be relevant.
101 - stupid. contemptible and despicable. simple. Take your pick from the
102   dictionary of slang.
103 - "global information tracker": you're in a good mood, and it actually
104   works for you. Angels sing, and a light suddenly fills the room.
105 - "goddamn idiotic truckload of sh*t": when it breaks
106
107 This is a stupid (but extremely fast) directory content manager. It
108 doesn't do a whole lot, but what it 'does' do is track directory
109 contents efficiently.
110
111 %description -l pl.UTF-8
112 "git" może oznaczać cokolwiek, w zależności od nastroju.
113
114 - losową kombinację trzech liter, która jest wymawialna i właściwie
115   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
116   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
117 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
118 - "global information tracker" (narzędzie do globalnego śledzenia
119   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
120   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
121 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
122   g*) - kiedy się zepsuje.
123
124 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
125 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
126 katalogu.
127
128 %package doc
129 Summary:        Documentation for git-core
130 Summary(pl.UTF-8):      Dokumentacja do git-core
131 Group:          Documentation
132
133 %description doc
134 Documentation for git-core.
135
136 %description doc -l pl.UTF-8
137 Dokumentacja do git-core.
138
139 %description doc -l fr.UTF-8
140 Javadoc pour git-core.
141
142 %package daemon-inetd
143 Summary:        Files necessary to run git-daemon as an inetd service
144 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
145 Group:          Networking/Daemons
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       setup >= 2.4.11-1
148 Provides:       git-core-daemon
149 Obsoletes:      git-core-daemon
150 Obsoletes:      git-core-daemon-standalone
151
152 %description daemon-inetd
153 Git-daemon is a really simple TCP git daemon that can serve git
154 repositories. This package provides all necessarry files to run
155 git-daemon as an inetd service.
156
157 %description daemon-inetd -l pl.UTF-8
158 Git-daemon to prosty demon git korzystający z protokołu TCP do
159 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
160 do uruchomienia git-demona w trybie usługi inetd.
161
162 %package daemon-standalone
163 Summary:        Files necessary to run git-daemon as a standalone service
164 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
165 Group:          Networking/Daemons
166 Requires:       %{name} = %{version}-%{release}
167 Provides:       git-core-daemon
168 Obsoletes:      git-core-daemon
169 Obsoletes:      git-core-daemon-inetd
170
171 %description daemon-standalone
172 Git-daemon is a really simple TCP git daemon that can serve git
173 repositories. This package provides all necessarry files to run
174 git-daemon as an standalone service.
175
176 %description daemon-standalone -l pl.UTF-8
177 Git-daemon to prosty demon git korzystający z protokołu TCP do
178 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
179 do uruchomienia git-daemona w trybie usługi samodzielnej.
180
181 %package devel
182 Summary:        Git library with header files
183 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
184 Group:          Development/Libraries
185 Requires:       zlib-devel
186
187 %description devel
188 Git library with header files.
189
190 %description devel -l pl.UTF-8
191 Biblioteka Gita oraz pliki nagłówkowe.
192
193 %package gitk
194 Summary:        Tcl/Tk interface to the Git version control system
195 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
196 Group:          Development/Tools
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       tk
199
200 %description gitk
201 gitk displays changes in a repository or a selected set of commits.
202 This includes visualizing the commit graph, showing information
203 related to each commit, and the files in the trees of each revision.
204
205 Historically, gitk was the first repository browser. It's written in
206 Tcl/Tk and started off in a separate repository but was later merged
207 into the main git repository.
208
209 %description gitk -l pl.UTF-8
210 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
211 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
212 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
213
214 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
215 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
216 osobnym repozytorium, ale z czasem został włączony do głównego
217 repozytorium gita.
218
219 %package gitweb
220 Summary:        Web frontend to git
221 Summary(pl.UTF-8):      Frontend WWW do gita
222 Group:          Development/Tools
223 Requires:       %{name} = %{version}-%{release}
224 Requires:       webapps
225 Requires:       webserver(access)
226 Requires:       webserver(alias)
227 Requires:       webserver(cgi)
228 Suggests:       webserver(setenv)
229
230 %description gitweb
231 This package provides a web interface for browsing git repositories.
232
233 %description gitweb -l pl.UTF-8
234 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
235
236 %package gitview
237 Summary:        A GTK+ based repository browser for git
238 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
239 Group:          Development/Tools
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       python >= 1:2.4
242 Requires:       python-pycairo >= 1.0
243 Requires:       python-pygobject
244 Requires:       python-pygtk-gtk >= 2:2.8
245 Suggests:       python-gnome-desktop-gtksourceview
246
247 %description gitview
248 A GTK+ based repository browser for git.
249
250 %description gitview -l pl.UTF-8
251 Oparta na GTK+ przeglądarka repozytorium gita.
252
253 %package gui
254 Summary:        Tcl/Tk interface to the Git version control system
255 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
256 Group:          Development/Tools
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       tk
259 Requires:       xdg-utils
260 Suggests:       meld
261
262 %description gui
263 Displays changes in a repository or a selected set of commits. This
264 includes visualizing the commit graph, showing information related to
265 each commit, and the files in the trees of each revision.
266
267 Historically, gitk was the first repository browser. It's written in
268 Tcl/Tk and started off in a separate repository but was later merged
269 into the main git repository.
270
271 %description gui -l pl.UTF-8
272 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
273 to wizualizację grafu commitów, wyświetlanie informacji związanych z
274 każdym z commitów oraz listę plików dla każdej rewizji.
275
276 Z punktu widzenia historii, gitk był pierwszą przeglądarką
277 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
278 osobnym repozytorium, ale z czasem został włączony do głównego
279 repozytorium gita.
280
281 %package arch
282 Summary:        Git tools for importing Arch repositories
283 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
284 Group:          Development/Tools
285 Requires:       %{name} = %{version}-%{release}
286 Requires:       tla
287
288 %description arch
289 Git tools for importing Arch repositories.
290
291 %description arch -l pl.UTF-8
292 Narzędzia Gita do importowania repozytoriów Archa.
293
294 %package bzr
295 Summary:        Git tools for working with bzr repositories
296 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
297 Group:          Development/Tools
298 Requires:       %{name} = %{version}-%{release}
299 Requires:       bzr
300
301 %description bzr
302 Git tools for working with bzr repositories.
303
304 %description bzr -l pl.UTF-8
305 Narzędzia Gita do pracy z repozytoriami bzr.
306
307 %package cvs
308 Summary:        CVS support for Git
309 Summary(pl.UTF-8):      Obsługa CVS dla Gita
310 Group:          Development/Tools
311 Requires:       %{name} = %{version}-%{release}
312 Requires:       cvsps >= 2.1-2
313 Requires:       rcs
314
315 %description cvs
316 CVS support for Git.
317
318 %description cvs -l pl.UTF-8
319 Obsługa CVS dla Gita.
320
321 %package hg
322 Summary:        Git tools for working with mercurial repositories
323 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
324 Group:          Development/Tools
325 Requires:       %{name} = %{version}-%{release}
326 Requires:       mercurial >= 1.8
327
328 %description hg
329 Git tools for working with mercurial repositories.
330
331 %description hg -l pl.UTF-8
332 Narzędzia Gita do pracy z repozytoriami mercuriala.
333
334 %package p4
335 Summary:        Git tools for working with Perforce depots
336 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
337 Group:          Development/Tools
338 Requires:       %{name} = %{version}-%{release}
339
340 %description p4
341 Git tools for working with Perforce depots.
342
343 %description p4 -l pl.UTF-8
344 Narzędzia Gita do pracy z magazynami Perforce'a.
345
346 %package svn
347 Summary:        Subversion support for Git
348 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
349 Group:          Development/Tools
350 Requires:       %{name} = %{version}-%{release}
351 Requires:       perl-Encode
352 Requires:       perl-Term-ReadKey
353
354 %description svn
355 Subversion support for Git.
356
357 %description svn -l pl.UTF-8
358 Obsługa Subversion dla Gita.
359
360 %package email
361 Summary:        Git tools for sending email
362 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
363 Group:          Development/Tools
364 Requires:       %{name} = %{version}-%{release}
365
366 %description email
367 Git tools for sending email.
368
369 %description email -l pl.UTF-8
370 Narzędzia Gita do wysyłania poczty.
371
372 %package -n bash-completion-git
373 Summary:        bash-completion for git
374 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
375 Group:          Applications/Shells
376 Requires:       %{name} = %{version}-%{release}
377 Requires:       bash-completion >= 2.0
378 %if "%{_rpmversion}" >= "5"
379 BuildArch:      noarch
380 %endif
381
382 %description -n bash-completion-git
383 This package provides bash-completion for git.
384
385 %description -n bash-completion-git -l pl.UTF-8
386 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
387
388 %package -n perl-Git
389 Summary:        Perl interface to the Git version control system
390 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
391 Group:          Development/Languages/Perl
392 Obsoletes:      perl-git-core
393
394 %description -n perl-Git
395 This module provides Perl scripts easy way to interface the Git
396 version control system. The modules have an easy and well-tested way
397 to call arbitrary Git commands; in the future, the interface will also
398 provide specialized methods for doing easily operations which are not
399 totally trivial to do over the generic command interface.
400
401 %description -n perl-Git -l pl.UTF-8
402 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
403 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
404 dowolne polecenia Gita; w przyszłości interfejs udostępni także
405 specjalne metody do łatwego wykonywania operacji nietrywialnych do
406 wykonania przy użyciu ogólnego interfejsu poleceń.
407
408 %package -n gnome-keyring-git-core
409 Summary:        GNOME Keyring authentication provider for Git
410 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
411 Group:          X11/Applications
412 URL:            http://git-scm.com/docs/gitcredentials.html
413 Requires:       %{name} = %{version}-%{release}
414
415 %description -n gnome-keyring-git-core
416 Authentication provider module for Git which allows git client to
417 authenticate using GNOME Keyring.
418
419 You need to register it with:
420 - git config --global credential.helper gnome-keyring
421
422 %description -n gnome-keyring-git-core -l pl.UTF-8
423 Moduł uwierzytelniający dla Subversion pozwalający klientom git
424 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
425
426 Moduł trzeba zarejestrować poleceniem:
427 - git config --global credential.helper gnome-keyring
428
429 %prep
430 %setup -q -n git-%{version}
431 %patch0 -p1
432 %patch1 -p0
433 %patch2 -p1
434 %patch3 -p1
435 %patch4 -p1
436
437 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
438
439 # we build things in contrib but want to have it clean for doc purporses, too
440 cp -a contrib contrib-doc
441
442 %build
443 %{__aclocal}
444 %{__autoconf}
445 %configure \
446         --sysconfdir=%{_sysconfdir}/git-core \
447         %{?with_pcre:--with-libpcre} \
448         --with-openssl
449
450 echo "BLK_SHA1=1" >> config.mak
451
452 %{__make} \
453         INSTALLDIRS=vendor \
454         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
455         GITWEB_PROJECTROOT="/var/lib/git" \
456         GITWEB_CSS="/gitweb/gitweb.css" \
457         GITWEB_LOGO="/gitweb/git-logo.png" \
458         GITWEB_FAVICON="/gitweb/git-favicon.png" \
459         V=1
460
461 %{__make} -C contrib/subtree
462
463 %if %{with gnome_keyring}
464 %{__make} -C contrib/credential/gnome-keyring
465 %endif
466
467 %if %{with doc}
468 %{__make} -C Documentation \
469         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
470         V=1
471 %endif
472
473 %if %{with tests}
474 %if %{without tests_cvs}
475 %{__rm} t/t*cvs*.sh || :
476 %endif
477 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
478 %endif
479
480 %install
481 rm -rf $RPM_BUILD_ROOT
482 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
483 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
484 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
485 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
486 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
487 [init]
488         templatedir = %{_sysconfdir}/%{name}/templates
489 EOF
490
491 %{__make} install \
492         INSTALLDIRS=vendor \
493         DESTDIR=$RPM_BUILD_ROOT
494
495 %if %{with doc}
496 %{__make} -C Documentation install \
497         DESTDIR=$RPM_BUILD_ROOT
498 %endif
499
500 # copy templates except sample hooks
501 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
502 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
503
504 # header files and lib
505 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
506 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
507 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
508 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
509 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
510 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
511 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
512 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
513
514 %{__make} -C contrib/subtree install \
515         libexecdir=%{gitcoredir} \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 %if %{with doc}
519 %{__make} -C contrib/subtree install-man \
520         DESTDIR=$RPM_BUILD_ROOT
521 %endif
522
523 %if %{with gnome_keyring}
524 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
525 %endif
526
527 # bash completion
528 install -d $RPM_BUILD_ROOT%{bash_compdir}
529 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
530
531 # Install git-prompt.sh
532 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
533 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
534
535 # Install bzr and hg remote helpers from contrib
536 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
537
538 # gitweb
539 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
540 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
541 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
542 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
543 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
544 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
545 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
546
547 # gitview
548 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
549
550 # git-daemon related files
551 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
552 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
553 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
554
555 # paths cleanup
556 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
557 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
558
559 # hardlink
560 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
561 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
562 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
563 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
564
565 # remove unneeded files
566 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
567 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
568 %py_postclean
569
570 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
571 %find_lang git
572
573 %clean
574 rm -rf $RPM_BUILD_ROOT
575
576 %post daemon-inetd
577 %service -q rc-inetd reload
578
579 %postun daemon-inetd
580 if [ "$1" = "0" ]; then
581         %service -q rc-inetd reload
582 fi
583
584 %post daemon-standalone
585 /sbin/chkconfig --add git-daemon
586 %service git-daemon restart "git-daemon"
587
588 %preun daemon-standalone
589 if [ "$1" = "0" ]; then
590         %service git-daemon stop
591         /sbin/chkconfig --del git-daemon
592 fi
593
594 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
595 %webapp_register apache %{webapp}
596
597 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
598 %webapp_unregister apache %{webapp}
599
600 %triggerin gitweb -- apache < 2.2.0, apache-base
601 %webapp_register httpd %{webapp}
602
603 %triggerun gitweb -- apache < 2.2.0, apache-base
604 %webapp_unregister httpd %{webapp}
605
606 %triggerin gitweb -- lighttpd
607 %webapp_register lighttpd %{webapp}
608
609 %triggerun gitweb -- lighttpd
610 %webapp_unregister lighttpd %{webapp}
611
612 %files -f git.lang
613 %defattr(644,root,root,755)
614 %doc README contrib-doc
615 %attr(755,root,root) %{_bindir}/git
616 %attr(755,root,root) %{_bindir}/git-receive-pack
617 %attr(755,root,root) %{_bindir}/git-shell
618 %attr(755,root,root) %{_bindir}/git-upload-archive
619 %attr(755,root,root) %{_bindir}/git-upload-pack
620 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
621
622 %if %{with doc}
623 %{_mandir}/man1/git-*.1*
624 %exclude %{_mandir}/man1/git-archimport.1*
625 %exclude %{_mandir}/man1/git-svn.1*
626 %exclude %{_mandir}/man1/git-cvs*.1*
627 %exclude %{_mandir}/man1/git-imap-send*.1*
628 %exclude %{_mandir}/man1/*email*.1*
629 %{_mandir}/man1/git.1*
630 %{_mandir}/man1/gitremote-helpers.1*
631 %{_mandir}/man5/gitattributes.5*
632 %{_mandir}/man5/githooks.5*
633 %{_mandir}/man5/gitignore.5*
634 %{_mandir}/man5/gitmodules.5*
635 %{_mandir}/man5/gitrepository-layout.5*
636 %{_mandir}/man7/gitcli.7*
637 %{_mandir}/man7/gitcore-tutorial.7*
638 %{_mandir}/man7/gitcredentials.7*
639 %{_mandir}/man7/gitdiffcore.7*
640 %{_mandir}/man7/giteveryday.7*
641 %{_mandir}/man7/gitglossary.7*
642 %{_mandir}/man7/gitnamespaces.7*
643 %{_mandir}/man7/gitrevisions.7*
644 %{_mandir}/man7/gittutorial-2.7*
645 %{_mandir}/man7/gittutorial.7*
646 %{_mandir}/man7/gitworkflows.7*
647 %endif
648
649 %dir %{gitcoredir}
650 %attr(755,root,root) %{gitcoredir}/*-*
651 %attr(755,root,root) %{gitcoredir}/git
652 %dir %{gitcoredir}/mergetools
653 %{gitcoredir}/mergetools/*
654
655 %{_datadir}/%{name}
656 %{_localstatedir}/lib/git
657
658 # subpackages
659 %exclude %{gitcoredir}/*email*
660 %exclude %{gitcoredir}/*p4*
661 %exclude %{gitcoredir}/git-archimport
662 %exclude %{gitcoredir}/git-cvs*
663 %exclude %{gitcoredir}/git-gui
664 %exclude %{gitcoredir}/git-imap-send
665 %exclude %{gitcoredir}/git-instaweb
666 %exclude %{gitcoredir}/git-remote-bzr
667 %exclude %{gitcoredir}/git-remote-hg
668 %exclude %{gitcoredir}/git-remote-testsvn
669 %exclude %{gitcoredir}/git-svn
670 %exclude %{gitcoredir}/mergetools/p4merge
671 %if %{with gnome_keyring}
672 %exclude %{gitcoredir}/git-credential-gnome-keyring
673 %endif
674
675 %if %{with doc}
676 %files doc
677 %defattr(644,root,root,755)
678 %doc Documentation/RelNotes*
679 %doc Documentation/*.html Documentation/howto Documentation/technical
680 %endif
681
682 %files daemon-inetd
683 %defattr(644,root,root,755)
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
685
686 %files daemon-standalone
687 %defattr(644,root,root,755)
688 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
689 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
690
691 %files devel
692 %defattr(644,root,root,755)
693 %{_includedir}/%{name}
694 %{_libdir}/libgit.a
695 %{_libdir}/libgit_xdiff.a
696
697 %files gitk
698 %defattr(644,root,root,755)
699 %if %{with doc}
700 %{_mandir}/man1/gitk.1*
701 %endif
702 %attr(755,root,root) %{_bindir}/gitk
703 %dir %{_datadir}/gitk
704 %dir %{_datadir}/gitk/lib
705 %dir %{_datadir}/gitk/lib/msgs
706 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
707 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
708 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
709 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
710 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
711 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
712 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
713 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
714 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
715 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
716 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
717
718 %files gitweb
719 %defattr(644,root,root,755)
720 %doc gitweb/{README,INSTALL}
721 %dir %{webappdir}
722 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
723 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
724 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
725 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
726 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
727 %attr(755,root,root) %{cgibindir}/gitweb.cgi
728 %{appdir}
729 %attr(755,root,root) %{gitcoredir}/git-instaweb
730 %if %{with doc}
731 %{_mandir}/man1/gitweb.1*
732 %{_mandir}/man5/gitweb.conf.5*
733 %endif
734
735 %files gitview
736 %defattr(644,root,root,755)
737 %doc contrib/gitview/gitview.txt
738 %attr(755,root,root) %{_bindir}/gitview
739
740 %files gui
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{gitcoredir}/git-gui
743 %dir %{_datadir}/git-gui
744 %dir %{_datadir}/git-gui/lib
745 %dir %{_datadir}/git-gui/lib/msgs
746 %{_datadir}/git-gui/lib/git-gui.ico
747 %{_datadir}/git-gui/lib/tclIndex
748 %{_datadir}/git-gui/lib/*.js
749 %{_datadir}/git-gui/lib/*.tcl
750 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
751 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
752 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
753 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
754 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
755 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
756 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
757 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
758 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
759 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
760 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
761 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
762
763 %files arch
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{gitcoredir}/git-archimport
766 %if %{with doc}
767 %{_mandir}/man1/git-archimport.1*
768 %endif
769
770 %files bzr
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{gitcoredir}/git-remote-bzr
773
774 %files cvs
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_bindir}/git-cvsserver
777 %attr(755,root,root) %{gitcoredir}/git-cvs*
778 %if %{with doc}
779 %{_mandir}/man1/git-cvs*.1*
780 %{_mandir}/man7/gitcvs-migration.7*
781 %endif
782
783 %files hg
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{gitcoredir}/git-remote-hg
786
787 %files p4
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{gitcoredir}/git-p4
790 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
791
792 %files svn
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{gitcoredir}/git-svn
795 %attr(755,root,root) %{gitcoredir}/git-remote-testsvn
796 %{perl_vendorlib}/Git/SVN
797 %{perl_vendorlib}/Git/SVN.pm
798 %if %{with doc}
799 %{_mandir}/man1/git-svn.1*
800 %endif
801
802 %files email
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{gitcoredir}/git-imap-send
805 %attr(755,root,root) %{gitcoredir}/*email*
806 %if %{with doc}
807 %{_mandir}/man1/*email*.1*
808 %{_mandir}/man1/*imap-send*.1*
809 %endif
810
811 %files -n bash-completion-git
812 %defattr(644,root,root,755)
813 %{bash_compdir}/git
814
815 %files -n perl-Git
816 %defattr(644,root,root,755)
817 %{perl_vendorlib}/Git.pm
818 %dir %{perl_vendorlib}/Git
819 %{perl_vendorlib}/Git/I18N.pm
820 %{perl_vendorlib}/Git/IndexInfo.pm
821 %{_mandir}/man3/Git*.3pm*
822
823 %if %{with gnome_keyring}
824 %files -n gnome-keyring-git-core
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
827 %endif
This page took 0.099784 seconds and 4 git commands to generate.