]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
package git subtree from contrib
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.9.0
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  e16c14b27c644b8e0dd72bdb5ff77450
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        gitolite.pl
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 Patch4:         %{name}-svn-exit-errors.patch
31 URL:            http://git-scm.com/
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.264
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-bzr
70 Suggests:       git-core-cvs
71 Suggests:       git-core-hg
72 Suggests:       git-core-p4
73 Suggests:       git-core-svn
74 Suggests:       less
75 Suggests:       rsync
76 Obsoletes:      python-Git
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 # html docs have links to txt files
80 %define         _noautocompressdoc      *.txt
81
82 %define         webapp          gitweb
83 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
84 %define         appdir          %{_datadir}/%{webapp}
85 %define         cgibindir       %{_prefix}/lib/cgi-bin
86 %define         bash_compdir    %{_datadir}/bash-completion/completions
87
88 %description
89 "git" can mean anything, depending on your mood.
90
91 - random three-letter combination that is pronounceable, and not
92   actually used by any common UNIX command. The fact that it is a
93   mispronunciation of "get" may or may not be relevant.
94 - stupid. contemptible and despicable. simple. Take your pick from the
95   dictionary of slang.
96 - "global information tracker": you're in a good mood, and it actually
97   works for you. Angels sing, and a light suddenly fills the room.
98 - "goddamn idiotic truckload of sh*t": when it breaks
99
100 This is a stupid (but extremely fast) directory content manager. It
101 doesn't do a whole lot, but what it 'does' do is track directory
102 contents efficiently.
103
104 %description -l pl.UTF-8
105 "git" może oznaczać cokolwiek, w zależności od nastroju.
106
107 - losową kombinację trzech liter, która jest wymawialna i właściwie
108   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
109   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
110 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
111 - "global information tracker" (narzędzie do globalnego śledzenia
112   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
113   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
114 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
115   g*) - kiedy się zepsuje.
116
117 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
118 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
119 katalogu.
120
121 %package doc
122 Summary:        Documentation for git-core
123 Summary(pl.UTF-8):      Dokumentacja do git-core
124 Group:          Documentation
125
126 %description doc
127 Documentation for git-core.
128
129 %description doc -l pl.UTF-8
130 Dokumentacja do git-core.
131
132 %description doc -l fr.UTF-8
133 Javadoc pour git-core.
134
135 %package daemon-inetd
136 Summary:        Files necessary to run git-daemon as an inetd service
137 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
138 Group:          Networking/Daemons
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       setup >= 2.4.11-1
141 Provides:       git-core-daemon
142 Obsoletes:      git-core-daemon
143 Obsoletes:      git-core-daemon-standalone
144
145 %description daemon-inetd
146 Git-daemon is a really simple TCP git daemon that can serve git
147 repositories. This package provides all necessarry files to run
148 git-daemon as an inetd service.
149
150 %description daemon-inetd -l pl.UTF-8
151 Git-daemon to prosty demon git korzystający z protokołu TCP do
152 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
153 do uruchomienia git-demona w trybie usługi inetd.
154
155 %package daemon-standalone
156 Summary:        Files necessary to run git-daemon as a standalone service
157 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
158 Group:          Networking/Daemons
159 Requires:       %{name} = %{version}-%{release}
160 Provides:       git-core-daemon
161 Obsoletes:      git-core-daemon
162 Obsoletes:      git-core-daemon-inetd
163
164 %description daemon-standalone
165 Git-daemon is a really simple TCP git daemon that can serve git
166 repositories. This package provides all necessarry files to run
167 git-daemon as an standalone service.
168
169 %description daemon-standalone -l pl.UTF-8
170 Git-daemon to prosty demon git korzystający z protokołu TCP do
171 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
172 do uruchomienia git-daemona w trybie usługi samodzielnej.
173
174 %package devel
175 Summary:        Git library with header files
176 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
177 Group:          Development/Libraries
178 Requires:       zlib-devel
179
180 %description devel
181 Git library with header files.
182
183 %description devel -l pl.UTF-8
184 Biblioteka Gita oraz pliki nagłówkowe.
185
186 %package gitk
187 Summary:        Tcl/Tk interface to the Git version control system
188 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
189 Group:          Development/Tools
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       tk
192
193 %description gitk
194 gitk displays changes in a repository or a selected set of commits.
195 This includes visualizing the commit graph, showing information
196 related to each commit, and the files in the trees of each revision.
197
198 Historically, gitk was the first repository browser. It's written in
199 Tcl/Tk and started off in a separate repository but was later merged
200 into the main git repository.
201
202 %description gitk -l pl.UTF-8
203 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
204 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
205 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
206
207 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
208 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
209 osobnym repozytorium, ale z czasem został włączony do głównego
210 repozytorium gita.
211
212 %package gitweb
213 Summary:        Web frontend to git
214 Summary(pl.UTF-8):      Frontend WWW do gita
215 Group:          Development/Tools
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       webapps
218 Requires:       webserver(access)
219 Requires:       webserver(alias)
220 Requires:       webserver(cgi)
221 Suggests:       webserver(setenv)
222
223 %description gitweb
224 This package provides a web interface for browsing git repositories.
225
226 %description gitweb -l pl.UTF-8
227 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
228
229 %package gitview
230 Summary:        A GTK+ based repository browser for git
231 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       python >= 1:2.4
235 Requires:       python-pycairo >= 1.0
236 Requires:       python-pygobject
237 Requires:       python-pygtk-gtk >= 2:2.8
238 Suggests:       python-gnome-desktop-gtksourceview
239
240 %description gitview
241 A GTK+ based repository browser for git.
242
243 %description gitview -l pl.UTF-8
244 Oparta na GTK+ przeglądarka repozytorium gita.
245
246 %package gui
247 Summary:        Tcl/Tk interface to the Git version control system
248 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
249 Group:          Development/Tools
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       tk
252 Requires:       xdg-utils
253 Suggests:       meld
254
255 %description gui
256 Displays changes in a repository or a selected set of commits. This
257 includes visualizing the commit graph, showing information related to
258 each commit, and the files in the trees of each revision.
259
260 Historically, gitk was the first repository browser. It's written in
261 Tcl/Tk and started off in a separate repository but was later merged
262 into the main git repository.
263
264 %description gui -l pl.UTF-8
265 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
266 to wizualizację grafu commitów, wyświetlanie informacji związanych z
267 każdym z commitów oraz listę plików dla każdej rewizji.
268
269 Z punktu widzenia historii, gitk był pierwszą przeglądarką
270 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
271 osobnym repozytorium, ale z czasem został włączony do głównego
272 repozytorium gita.
273
274 %package arch
275 Summary:        Git tools for importing Arch repositories
276 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
277 Group:          Development/Tools
278 Requires:       %{name} = %{version}-%{release}
279 Requires:       tla
280
281 %description arch
282 Git tools for importing Arch repositories.
283
284 %description arch -l pl.UTF-8
285 Narzędzia Gita do importowania repozytoriów Archa.
286
287 %package bzr
288 Summary:        Git tools for working with bzr repositories
289 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
290 Group:          Development/Tools
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       bzr
293
294 %description bzr
295 Git tools for working with bzr repositories.
296
297 %description bzr -l pl.UTF-8
298 Narzędzia Gita do pracy z repozytoriami bzr.
299
300 %package cvs
301 Summary:        CVS support for Git
302 Summary(pl.UTF-8):      Obsługa CVS dla Gita
303 Group:          Development/Tools
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       cvsps >= 2.1-2
306 Requires:       rcs
307
308 %description cvs
309 CVS support for Git.
310
311 %description cvs -l pl.UTF-8
312 Obsługa CVS dla Gita.
313
314 %package hg
315 Summary:        Git tools for working with mercurial repositories
316 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
317 Group:          Development/Tools
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       mercurial >= 1.8
320
321 %description hg
322 Git tools for working with mercurial repositories.
323
324 %description hg -l pl.UTF-8
325 Narzędzia Gita do pracy z repozytoriami mercuriala.
326
327 %package p4
328 Summary:        Git tools for working with Perforce depots
329 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
330 Group:          Development/Tools
331 Requires:       %{name} = %{version}-%{release}
332
333 %description p4
334 Git tools for working with Perforce depots.
335
336 %description p4 -l pl.UTF-8
337 Narzędzia Gita do pracy z magazynami Perforce'a.
338
339 %package svn
340 Summary:        Subversion support for Git
341 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
342 Group:          Development/Tools
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       perl-Encode
345 Requires:       perl-Term-ReadKey
346
347 %description svn
348 Subversion support for Git.
349
350 %description svn -l pl.UTF-8
351 Obsługa Subversion dla Gita.
352
353 %package email
354 Summary:        Git tools for sending email
355 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
356 Group:          Development/Tools
357 Requires:       %{name} = %{version}-%{release}
358
359 %description email
360 Git tools for sending email.
361
362 %description email -l pl.UTF-8
363 Narzędzia Gita do wysyłania poczty.
364
365 %package -n bash-completion-git
366 Summary:        bash-completion for git
367 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
368 Group:          Applications/Shells
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       bash-completion >= 2.0
371
372 %description -n bash-completion-git
373 This package provides bash-completion for git.
374
375 %description -n bash-completion-git -l pl.UTF-8
376 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
377
378 %package -n perl-Git
379 Summary:        Perl interface to the Git version control system
380 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
381 Group:          Development/Languages/Perl
382 Obsoletes:      perl-git-core
383
384 %description -n perl-Git
385 This module provides Perl scripts easy way to interface the Git
386 version control system. The modules have an easy and well-tested way
387 to call arbitrary Git commands; in the future, the interface will also
388 provide specialized methods for doing easily operations which are not
389 totally trivial to do over the generic command interface.
390
391 %description -n perl-Git -l pl.UTF-8
392 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
393 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
394 dowolne polecenia Gita; w przyszłości interfejs udostępni także
395 specjalne metody do łatwego wykonywania operacji nietrywialnych do
396 wykonania przy użyciu ogólnego interfejsu poleceń.
397
398 %package -n vim-syntax-gitcommit
399 Summary:        Vim syntax: gitcommit
400 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
401 Group:          Applications/Editors/Vim
402 Requires:       %{name} = %{version}-%{release}
403 # for _vimdatadir existence
404 Requires:       vim-rt >= 4:6.3.058-3
405
406 %description -n vim-syntax-gitcommit
407 This plugin provides syntax highlighting for git's commit messages.
408
409 %description -n vim-syntax-gitcommit -l pl.UTF-8
410 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
411
412 %prep
413 %setup -q -n git-%{version}
414 %patch0 -p1
415 %patch1 -p0
416 %patch2 -p1
417 %patch3 -p1
418 %patch4 -p1
419
420 %build
421 %{__aclocal}
422 %{__autoconf}
423 %configure \
424         --sysconfdir=%{_sysconfdir}/git-core \
425         %{?with_pcre:--with-libpcre} \
426         --with-openssl
427
428 echo "BLK_SHA1=1" >> config.mak
429
430 %{__make} \
431         INSTALLDIRS=vendor \
432         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
433         GITWEB_PROJECTROOT="/var/lib/git" \
434         GITWEB_CSS="/gitweb/gitweb.css" \
435         GITWEB_LOGO="/gitweb/git-logo.png" \
436         GITWEB_FAVICON="/gitweb/git-favicon.png" \
437         V=1
438
439 %{__make} -C contrib/subtree
440
441 %if %{with doc}
442 %{__make} -C Documentation \
443         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
444         V=1
445 %endif
446
447 %if %{with tests}
448 %if %{without tests_cvs}
449 %{__rm} t/t*cvs*.sh || :
450 %endif
451 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
452 %endif
453
454 %install
455 rm -rf $RPM_BUILD_ROOT
456 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
457 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
458 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
459 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
460 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
461 [init]
462         templatedir = %{_sysconfdir}/%{name}/templates
463 EOF
464
465 %{__make} install \
466         INSTALLDIRS=vendor \
467         DESTDIR=$RPM_BUILD_ROOT
468
469 %if %{with doc}
470 %{__make} -C Documentation install \
471         DESTDIR=$RPM_BUILD_ROOT
472 %endif
473
474 # copy templates except sample hooks
475 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
476 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
477
478 # header files and lib
479 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
480 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
481 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
482 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
483 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
484 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
485 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
486 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
487
488 %{__make} -C contrib/subtree install \
489         libexecdir=%{_libdir}/%{name} \
490         DESTDIR=$RPM_BUILD_ROOT
491
492 %if %{with doc}
493 %{__make} -C contrib/subtree install-doc \
494         DESTDIR=$RPM_BUILD_ROOT
495 %endif
496
497 # bash completion
498 install -d $RPM_BUILD_ROOT%{bash_compdir}
499 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
500
501 # Install bzr and hg remote helpers from contrib
502 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
503
504 # vim syntax
505 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
506 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
507 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
508 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
509 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
510 autocmd BufNewFile,BufRead .msg.[0-9]*
511         \ if getline(1) =~ '^From.*# This line is ignored.$' |
512         \   setf gitsendemail |
513         \ endif
514 autocmd BufNewFile,BufRead *.git/**
515         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
516         \   setf git |
517         \ endif
518 EOF
519
520 # gitweb
521 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
522 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
523 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
524 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
525 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
526 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
527 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
528
529 # gitview
530 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
531
532 # git-daemon related files
533 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
534 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
535 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
536
537 # paths cleanup
538 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
539 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
540
541 # hardlink
542 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
543 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
544 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
545 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
546
547 # remove unneeded files
548 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
549 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
550 %py_postclean
551
552 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
553 %find_lang git
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %post daemon-inetd
559 %service -q rc-inetd reload
560
561 %postun daemon-inetd
562 if [ "$1" = "0" ]; then
563         %service -q rc-inetd reload
564 fi
565
566 %post daemon-standalone
567 /sbin/chkconfig --add git-daemon
568 %service git-daemon restart "git-daemon"
569
570 %preun daemon-standalone
571 if [ "$1" = "0" ]; then
572         %service git-daemon stop
573         /sbin/chkconfig --del git-daemon
574 fi
575
576 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
577 %webapp_register apache %{webapp}
578
579 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
580 %webapp_unregister apache %{webapp}
581
582 %triggerin gitweb -- apache < 2.2.0, apache-base
583 %webapp_register httpd %{webapp}
584
585 %triggerun gitweb -- apache < 2.2.0, apache-base
586 %webapp_unregister httpd %{webapp}
587
588 %triggerin gitweb -- lighttpd
589 %webapp_register lighttpd %{webapp}
590
591 %triggerun gitweb -- lighttpd
592 %webapp_unregister lighttpd %{webapp}
593
594 %files -f git.lang
595 %defattr(644,root,root,755)
596 %doc README contrib
597 %attr(755,root,root) %{_bindir}/git
598 %attr(755,root,root) %{_bindir}/git-receive-pack
599 %attr(755,root,root) %{_bindir}/git-shell
600 %attr(755,root,root) %{_bindir}/git-upload-archive
601 %attr(755,root,root) %{_bindir}/git-upload-pack
602 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
603
604 %if %{with doc}
605 %{_mandir}/man1/git-*.1*
606 %exclude %{_mandir}/man1/git-archimport.1*
607 %exclude %{_mandir}/man1/git-svn.1*
608 %exclude %{_mandir}/man1/git-cvs*.1*
609 %exclude %{_mandir}/man1/git-imap-send*.1*
610 %exclude %{_mandir}/man1/*email*.1*
611 %{_mandir}/man1/git.1*
612 %{_mandir}/man1/gitremote-helpers.1*
613 %{_mandir}/man5/gitattributes.5*
614 %{_mandir}/man5/githooks.5*
615 %{_mandir}/man5/gitignore.5*
616 %{_mandir}/man5/gitmodules.5*
617 %{_mandir}/man5/gitrepository-layout.5*
618 %{_mandir}/man7/gitcli.7*
619 %{_mandir}/man7/gitcore-tutorial.7*
620 %{_mandir}/man7/gitcredentials.7*
621 %{_mandir}/man7/gitdiffcore.7*
622 %{_mandir}/man7/gitglossary.7*
623 %{_mandir}/man7/gitnamespaces.7*
624 %{_mandir}/man7/gitrevisions.7*
625 %{_mandir}/man7/gittutorial-2.7*
626 %{_mandir}/man7/gittutorial.7*
627 %{_mandir}/man7/gitworkflows.7*
628 %endif
629
630 %dir %{_libdir}/%{name}
631 %attr(755,root,root) %{_libdir}/%{name}/*-*
632 %attr(755,root,root) %{_libdir}/%{name}/git
633 %dir %{_libdir}/%{name}/mergetools
634 %{_libdir}/%{name}/mergetools/*
635
636 %{_datadir}/%{name}
637 %{_localstatedir}/lib/git
638
639 # subpackages
640 %exclude %{_libdir}/%{name}/*email*
641 %exclude %{_libdir}/%{name}/*p4*
642 %exclude %{_libdir}/%{name}/git-archimport
643 %exclude %{_libdir}/%{name}/git-cvs*
644 %exclude %{_libdir}/%{name}/git-gui
645 %exclude %{_libdir}/%{name}/git-imap-send
646 %exclude %{_libdir}/%{name}/git-instaweb
647 %exclude %{_libdir}/%{name}/git-remote-bzr
648 %exclude %{_libdir}/%{name}/git-remote-hg
649 %exclude %{_libdir}/%{name}/git-remote-testsvn
650 %exclude %{_libdir}/%{name}/git-svn
651 %exclude %{_libdir}/%{name}/mergetools/p4merge
652
653 %if %{with doc}
654 %files doc
655 %defattr(644,root,root,755)
656 %doc Documentation/RelNotes*
657 %doc Documentation/*.html Documentation/howto Documentation/technical
658 %endif
659
660 %files daemon-inetd
661 %defattr(644,root,root,755)
662 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
663
664 %files daemon-standalone
665 %defattr(644,root,root,755)
666 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
667 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
668
669 %files devel
670 %defattr(644,root,root,755)
671 %{_includedir}/%{name}
672 %{_libdir}/libgit.a
673 %{_libdir}/libgit_xdiff.a
674
675 %files gitk
676 %defattr(644,root,root,755)
677 %if %{with doc}
678 %{_mandir}/man1/gitk.1*
679 %endif
680 %attr(755,root,root) %{_bindir}/gitk
681 %dir %{_datadir}/gitk
682 %dir %{_datadir}/gitk/lib
683 %dir %{_datadir}/gitk/lib/msgs
684 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
685 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
686 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
687 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
688 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
689 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
690 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
691 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
692 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
693 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
694
695 %files gitweb
696 %defattr(644,root,root,755)
697 %doc gitweb/{README,INSTALL}
698 %dir %{webappdir}
699 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
700 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
701 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
702 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
703 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
704 %attr(755,root,root) %{cgibindir}/gitweb.cgi
705 %{appdir}
706 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
707 %if %{with doc}
708 %{_mandir}/man1/gitweb.1*
709 %{_mandir}/man5/gitweb.conf.5*
710 %endif
711
712 %files gitview
713 %defattr(644,root,root,755)
714 %doc contrib/gitview/gitview.txt
715 %attr(755,root,root) %{_bindir}/gitview
716
717 %files gui
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/%{name}/git-gui
720 %dir %{_datadir}/git-gui
721 %dir %{_datadir}/git-gui/lib
722 %dir %{_datadir}/git-gui/lib/msgs
723 %{_datadir}/git-gui/lib/git-gui.ico
724 %{_datadir}/git-gui/lib/tclIndex
725 %{_datadir}/git-gui/lib/*.js
726 %{_datadir}/git-gui/lib/*.tcl
727 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
728 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
729 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
730 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
731 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
732 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
733 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
734 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
735 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
736 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
737 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
738 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
739
740 %files arch
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
743 %if %{with doc}
744 %{_mandir}/man1/git-archimport.1*
745 %endif
746
747 %files bzr
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
750
751 %files cvs
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_bindir}/git-cvsserver
754 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
755 %if %{with doc}
756 %{_mandir}/man1/git-cvs*.1*
757 %{_mandir}/man7/gitcvs-migration.7*
758 %endif
759
760 %files hg
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
763
764 %files p4
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/%{name}/git-p4
767 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
768
769 %files svn
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/%{name}/git-svn
772 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
773 %{perl_vendorlib}/Git/SVN
774 %{perl_vendorlib}/Git/SVN.pm
775 %if %{with doc}
776 %{_mandir}/man1/git-svn.1*
777 %endif
778
779 %files email
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
782 %attr(755,root,root) %{_libdir}/%{name}/*email*
783 %if %{with doc}
784 %{_mandir}/man1/*email*.1*
785 %{_mandir}/man1/*imap-send*.1*
786 %endif
787
788 %files -n bash-completion-git
789 %defattr(644,root,root,755)
790 %{bash_compdir}/git
791
792 %files -n perl-Git
793 %defattr(644,root,root,755)
794 %{perl_vendorlib}/Git.pm
795 %dir %{perl_vendorlib}/Git
796 %{perl_vendorlib}/Git/I18N.pm
797 %{perl_vendorlib}/Git/IndexInfo.pm
798 %{_mandir}/man3/Git*.3pm*
799
800 %files -n vim-syntax-gitcommit
801 %defattr(644,root,root,755)
802 %doc contrib/vim/README
803 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.150125 seconds and 4 git commands to generate.