]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
fix git-svn fetching from svn servers that use serf library
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.3.2
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  83b792fd06066c77e1d4911ebba2d701
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-apache.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        %{name}-gitweb-httpd.conf
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 Patch4:         %{name}-svn-serf.patch
31 URL:            http://git-scm.com/
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.264
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-cvs
70 Suggests:       git-core-svn
71 Suggests:       less
72 Suggests:       rsync
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # html docs have links to txt files
76 %define         _noautocompressdoc      *.txt
77
78 %define         webapp          gitweb
79 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
80 %define         appdir          %{_datadir}/%{webapp}
81 %define         cgibindir       %{_prefix}/lib/cgi-bin
82 %define         bash_compdir    %{_datadir}/bash-completion/completions
83
84 %description
85 "git" can mean anything, depending on your mood.
86
87 - random three-letter combination that is pronounceable, and not
88   actually used by any common UNIX command. The fact that it is a
89   mispronunciation of "get" may or may not be relevant.
90 - stupid. contemptible and despicable. simple. Take your pick from the
91   dictionary of slang.
92 - "global information tracker": you're in a good mood, and it actually
93   works for you. Angels sing, and a light suddenly fills the room.
94 - "goddamn idiotic truckload of sh*t": when it breaks
95
96 This is a stupid (but extremely fast) directory content manager. It
97 doesn't do a whole lot, but what it 'does' do is track directory
98 contents efficiently.
99
100 %description -l pl.UTF-8
101 "git" może oznaczać cokolwiek, w zależności od nastroju.
102
103 - losową kombinację trzech liter, która jest wymawialna i właściwie
104   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
105   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
106 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
107 - "global information tracker" (narzędzie do globalnego śledzenia
108   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
109   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
110 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
111   g*) - kiedy się zepsuje.
112
113 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
114 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
115 katalogu.
116
117 %package doc
118 Summary:        Documentation for git-core
119 Summary(pl.UTF-8):      Dokumentacja do git-core
120 Group:          Documentation
121
122 %description doc
123 Documentation for git-core.
124
125 %description doc -l pl.UTF-8
126 Dokumentacja do git-core.
127
128 %description doc -l fr.UTF-8
129 Javadoc pour git-core.
130
131 %package daemon-inetd
132 Summary:        Files necessary to run git-daemon as an inetd service
133 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
134 Group:          Networking/Daemons
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       setup >= 2.4.11-1
137 Provides:       git-core-daemon
138 Obsoletes:      git-core-daemon
139 Obsoletes:      git-core-daemon-standalone
140
141 %description daemon-inetd
142 Git-daemon is a really simple TCP git daemon that can serve git
143 repositories. This package provides all necessarry files to run
144 git-daemon as an inetd service.
145
146 %description daemon-inetd -l pl.UTF-8
147 Git-daemon to prosty demon git korzystający z protokołu TCP do
148 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
149 do uruchomienia git-demona w trybie usługi inetd.
150
151 %package daemon-standalone
152 Summary:        Files necessary to run git-daemon as a standalone service
153 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
154 Group:          Networking/Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Provides:       git-core-daemon
157 Obsoletes:      git-core-daemon
158 Obsoletes:      git-core-daemon-inetd
159
160 %description daemon-standalone
161 Git-daemon is a really simple TCP git daemon that can serve git
162 repositories. This package provides all necessarry files to run
163 git-daemon as an standalone service.
164
165 %description daemon-standalone -l pl.UTF-8
166 Git-daemon to prosty demon git korzystający z protokołu TCP do
167 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
168 do uruchomienia git-daemona w trybie usługi samodzielnej.
169
170 %package devel
171 Summary:        Git library with header files
172 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
173 Group:          Development/Libraries
174 Requires:       zlib-devel
175
176 %description devel
177 Git library with header files.
178
179 %description devel -l pl.UTF-8
180 Biblioteka Gita oraz pliki nagłówkowe.
181
182 %package gitk
183 Summary:        Tcl/Tk interface to the Git version control system
184 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
185 Group:          Development/Tools
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       tk
188
189 %description gitk
190 gitk displays changes in a repository or a selected set of commits.
191 This includes visualizing the commit graph, showing information
192 related to each commit, and the files in the trees of each revision.
193
194 Historically, gitk was the first repository browser. It's written in
195 Tcl/Tk and started off in a separate repository but was later merged
196 into the main git repository.
197
198 %description gitk -l pl.UTF-8
199 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
200 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
201 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
202
203 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
204 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
205 osobnym repozytorium, ale z czasem został włączony do głównego
206 repozytorium gita.
207
208 %package gitweb
209 Summary:        Web frontend to git
210 Summary(pl.UTF-8):      Frontend WWW do gita
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       webapps
214 Requires:       webserver(alias)
215 Requires:       webserver(cgi)
216 Suggests:       webserver(setenv)
217 Conflicts:      apache-base < 2.4.0-1
218
219 %description gitweb
220 This package provides a web interface for browsing git repositories.
221
222 %description gitweb -l pl.UTF-8
223 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
224
225 %package gitview
226 Summary:        A GTK+ based repository browser for git
227 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
228 Group:          Development/Tools
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       python >= 1:2.4
231 Requires:       python-pycairo >= 1.0
232 Requires:       python-pygobject
233 Requires:       python-pygtk-gtk >= 2:2.8
234 Suggests:       python-gnome-desktop-gtksourceview
235
236 %description gitview
237 A GTK+ based repository browser for git.
238
239 %description gitview -l pl.UTF-8
240 Oparta na GTK+ przeglądarka repozytorium gita.
241
242 %package gui
243 Summary:        Tcl/Tk interface to the Git version control system
244 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
245 Group:          Development/Tools
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       tk
248 Requires:       xdg-utils
249 Suggests:       meld
250
251 %description gui
252 Displays changes in a repository or a selected set of commits. This
253 includes visualizing the commit graph, showing information related to
254 each commit, and the files in the trees of each revision.
255
256 Historically, gitk was the first repository browser. It's written in
257 Tcl/Tk and started off in a separate repository but was later merged
258 into the main git repository.
259
260 %description gui -l pl.UTF-8
261 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
262 to wizualizację grafu commitów, wyświetlanie informacji związanych z
263 każdym z commitów oraz listę plików dla każdej rewizji.
264
265 Z punktu widzenia historii, gitk był pierwszą przeglądarką
266 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
267 osobnym repozytorium, ale z czasem został włączony do głównego
268 repozytorium gita.
269
270 %package svn
271 Summary:        Subversion support for Git
272 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
273 Group:          Development/Tools
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       perl-Encode
276 Requires:       perl-Term-ReadKey
277
278 %description svn
279 Subversion support for Git.
280
281 %description svn -l pl.UTF-8
282 Obsługa Subversion dla Gita.
283
284 %package cvs
285 Summary:        CVS support for Git
286 Summary(pl.UTF-8):      Obsługa CVS dla Gita
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       cvsps >= 2.1-2
290 Requires:       rcs
291
292 %description cvs
293 CVS support for Git.
294
295 %description cvs -l pl.UTF-8
296 Obsługa CVS dla Gita.
297
298 %package arch
299 Summary:        Git tools for importing Arch repositories
300 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
301 Group:          Development/Tools
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       tla
304
305 %description arch
306 Git tools for importing Arch repositories.
307
308 %description arch -l pl.UTF-8
309 Narzędzia Gita do importowania repozytoriów Archa.
310
311 %package email
312 Summary:        Git tools for sending email
313 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
314 Group:          Development/Tools
315 Requires:       %{name} = %{version}-%{release}
316
317 %description email
318 Git tools for sending email.
319
320 %description email -l pl.UTF-8
321 Narzędzia Gita do wysyłania poczty.
322
323 %package -n bash-completion-git
324 Summary:        bash-completion for git
325 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
326 Group:          Applications/Shells
327 Requires:       %{name} = %{version}-%{release}
328 Requires:       bash-completion >= 2.0
329
330 %description -n bash-completion-git
331 This package provides bash-completion for git.
332
333 %description -n bash-completion-git -l pl.UTF-8
334 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
335
336 %package -n perl-Git
337 Summary:        Perl interface to the Git version control system
338 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
339 Group:          Development/Languages/Perl
340 Obsoletes:      perl-git-core
341
342 %description -n perl-Git
343 This module provides Perl scripts easy way to interface the Git
344 version control system. The modules have an easy and well-tested way
345 to call arbitrary Git commands; in the future, the interface will also
346 provide specialized methods for doing easily operations which are not
347 totally trivial to do over the generic command interface.
348
349 %description -n perl-Git -l pl.UTF-8
350 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
351 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
352 dowolne polecenia Gita; w przyszłości interfejs udostępni także
353 specjalne metody do łatwego wykonywania operacji nietrywialnych do
354 wykonania przy użyciu ogólnego interfejsu poleceń.
355
356 %package -n python-Git
357 Summary:        Python Git remote helpers for non-git repositories
358 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
359 Group:          Development/Languages/Python
360 Requires:       %{name} = %{version}-%{release}
361
362 %description -n python-Git
363 This package contains Python git_repote_helpers package - Git remote
364 helpers for non-git repositories.
365
366 %description -n python-Git -l pl.UTF-8
367 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
368 pomocnicze Gita dla repozytoriów niegitowych.
369
370 %package -n vim-syntax-gitcommit
371 Summary:        Vim syntax: gitcommit
372 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
373 Group:          Applications/Editors/Vim
374 Requires:       %{name} = %{version}-%{release}
375 # for _vimdatadir existence
376 Requires:       vim-rt >= 4:6.3.058-3
377
378 %description -n vim-syntax-gitcommit
379 This plugin provides syntax highlighting for git's commit messages.
380
381 %description -n vim-syntax-gitcommit -l pl.UTF-8
382 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
383
384 %prep
385 %setup -q -n git-%{version}
386 %patch0 -p1
387 %patch1 -p0
388 %patch2 -p1
389 %patch3 -p1
390 %patch4 -p1
391
392 %build
393 %{__aclocal}
394 %{__autoconf}
395 %configure \
396         --sysconfdir=%{_sysconfdir}/git-core \
397         %{?with_pcre:--with-libpcre} \
398         --with-openssl
399
400 echo "BLK_SHA1=1" >> config.mak
401
402 %{__make} \
403         INSTALLDIRS=vendor \
404         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
405         GITWEB_PROJECTROOT="/var/lib/git" \
406         GITWEB_CSS="/gitweb/gitweb.css" \
407         GITWEB_LOGO="/gitweb/git-logo.png" \
408         GITWEB_FAVICON="/gitweb/git-favicon.png" \
409         V=1
410
411 %if %{with doc}
412 %{__make} -C Documentation \
413         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
414         V=1
415 %endif
416
417 %if %{with tests}
418 %if %{without tests_cvs}
419 %{__rm} t/t*cvs*.sh || :
420 %endif
421 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
422 %endif
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
427 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
428 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
429 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
430 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
431 [init]
432         templatedir = %{_sysconfdir}/%{name}/templates
433 EOF
434
435 %{__make} install \
436         INSTALLDIRS=vendor \
437         DESTDIR=$RPM_BUILD_ROOT
438
439 %if %{with doc}
440 %{__make} -C Documentation install \
441         DESTDIR=$RPM_BUILD_ROOT
442 %endif
443
444 # copy templates except sample hooks
445 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
446 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
447
448 # header files and lib
449 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
450 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
451 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
452 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
453 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
454
455 # bash completion
456 install -d $RPM_BUILD_ROOT%{bash_compdir}
457 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
458
459 # vim syntax
460 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
461 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
462 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
463 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
464 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
465 autocmd BufNewFile,BufRead .msg.[0-9]*
466         \ if getline(1) =~ '^From.*# This line is ignored.$' |
467         \   setf gitsendemail |
468         \ endif
469 autocmd BufNewFile,BufRead *.git/**
470         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
471         \   setf git |
472         \ endif
473 EOF
474
475 # gitweb
476 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
477 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
478 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
479 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
480 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
481 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
482
483 # gitview
484 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
485
486 # git-daemon related files
487 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
488 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
489 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
490
491 # paths cleanup
492 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
493 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
494
495 # hardlink
496 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
497 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
498 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
499 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
500
501 # remove unneeded files
502 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
503 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
504 %py_postclean
505
506 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
507 %find_lang git
508
509 %clean
510 rm -rf $RPM_BUILD_ROOT
511
512 %post daemon-inetd
513 %service -q rc-inetd reload
514
515 %postun daemon-inetd
516 if [ "$1" = "0" ]; then
517         %service -q rc-inetd reload
518 fi
519
520 %post daemon-standalone
521 /sbin/chkconfig --add git-daemon
522 %service git-daemon restart "git-daemon"
523
524 %preun daemon-standalone
525 if [ "$1" = "0" ]; then
526         %service git-daemon stop
527         /sbin/chkconfig --del git-daemon
528 fi
529
530 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
531 %webapp_register apache %{webapp}
532
533 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
534 %webapp_unregister apache %{webapp}
535
536 %triggerin gitweb -- apache-base
537 %webapp_register httpd %{webapp}
538
539 %triggerun gitweb -- apache-base
540 %webapp_unregister httpd %{webapp}
541
542 %triggerin gitweb -- lighttpd
543 %webapp_register lighttpd %{webapp}
544
545 %triggerun gitweb -- lighttpd
546 %webapp_unregister lighttpd %{webapp}
547
548 %files -f git.lang
549 %defattr(644,root,root,755)
550 %doc README contrib
551 %attr(755,root,root) %{_bindir}/git
552 %attr(755,root,root) %{_bindir}/git-receive-pack
553 %attr(755,root,root) %{_bindir}/git-shell
554 %attr(755,root,root) %{_bindir}/git-upload-archive
555 %attr(755,root,root) %{_bindir}/git-upload-pack
556 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
557
558 %if %{with doc}
559 %{_mandir}/man1/git-*.1*
560 %exclude %{_mandir}/man1/git-archimport.1*
561 %exclude %{_mandir}/man1/git-svn.1*
562 %exclude %{_mandir}/man1/git-cvs*.1*
563 %exclude %{_mandir}/man1/*email*.1*
564 %exclude %{_mandir}/man1/gitremote-helpers.1*
565 %{_mandir}/man1/git.1*
566 %{_mandir}/man5/gitattributes.5*
567 %{_mandir}/man5/githooks.5*
568 %{_mandir}/man5/gitignore.5*
569 %{_mandir}/man5/gitmodules.5*
570 %{_mandir}/man5/gitrepository-layout.5*
571 %{_mandir}/man7/gitcli.7*
572 %{_mandir}/man7/gitcore-tutorial.7*
573 %{_mandir}/man7/gitcredentials.7*
574 %{_mandir}/man7/gitdiffcore.7*
575 %{_mandir}/man7/gitglossary.7*
576 %{_mandir}/man7/gitnamespaces.7*
577 %{_mandir}/man7/gitrevisions.7*
578 %{_mandir}/man7/gittutorial-2.7*
579 %{_mandir}/man7/gittutorial.7*
580 %{_mandir}/man7/gitworkflows.7*
581 %endif
582
583 %dir %{_libdir}/%{name}
584 %attr(755,root,root) %{_libdir}/%{name}/*-*
585 %attr(755,root,root) %{_libdir}/%{name}/git
586 %{_libdir}/%{name}/mergetools
587
588 %exclude %{_libdir}/%{name}/git-gui
589 %exclude %{_libdir}/%{name}/git-svn
590 %exclude %{_libdir}/%{name}/git-archimport
591 %exclude %{_libdir}/%{name}/git-cvs*
592 %exclude %{_libdir}/%{name}/git-instaweb
593 %exclude %{_libdir}/%{name}/git-remote-testpy
594 %exclude %{_libdir}/%{name}/git-remote-testsvn
595 %exclude %{_libdir}/%{name}/*email*
596
597 %{_datadir}/%{name}
598
599 %{_localstatedir}/lib/git
600
601 %if %{with doc}
602 %files doc
603 %defattr(644,root,root,755)
604 %doc Documentation/RelNotes*
605 %doc Documentation/*.html Documentation/howto Documentation/technical
606 %endif
607
608 %files daemon-inetd
609 %defattr(644,root,root,755)
610 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
611
612 %files daemon-standalone
613 %defattr(644,root,root,755)
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
615 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
616
617 %files devel
618 %defattr(644,root,root,755)
619 %{_includedir}/%{name}
620 %{_libdir}/libgit.a
621 %{_libdir}/libgit_xdiff.a
622
623 %files gitk
624 %defattr(644,root,root,755)
625 %if %{with doc}
626 %{_mandir}/man1/gitk.1*
627 %endif
628 %attr(755,root,root) %{_bindir}/gitk
629 %dir %{_datadir}/gitk
630 %dir %{_datadir}/gitk/lib
631 %dir %{_datadir}/gitk/lib/msgs
632 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
633 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
634 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
635 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
636 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
637 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
638 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
639 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
640 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
641
642 %files gitweb
643 %defattr(644,root,root,755)
644 %doc gitweb/{README,INSTALL}
645 %dir %{webappdir}
646 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
647 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
648 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
649 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
650 %attr(755,root,root) %{cgibindir}/gitweb.cgi
651 %{appdir}
652 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
653 %if %{with doc}
654 %{_mandir}/man1/gitweb.1*
655 %{_mandir}/man5/gitweb.conf.5*
656 %endif
657
658 %files gitview
659 %defattr(644,root,root,755)
660 %doc contrib/gitview/gitview.txt
661 %attr(755,root,root) %{_bindir}/gitview
662
663 %files gui
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/%{name}/git-gui
666 %dir %{_datadir}/git-gui
667 %dir %{_datadir}/git-gui/lib
668 %dir %{_datadir}/git-gui/lib/msgs
669 %{_datadir}/git-gui/lib/git-gui.ico
670 %{_datadir}/git-gui/lib/tclIndex
671 %{_datadir}/git-gui/lib/*.js
672 %{_datadir}/git-gui/lib/*.tcl
673 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
674 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
675 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
676 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
677 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
678 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
679 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
680 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
681 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
682 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
683 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
684
685 %files svn
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/%{name}/git-svn
688 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
689 %{perl_vendorlib}/Git/SVN
690 %{perl_vendorlib}/Git/SVN.pm
691 %if %{with doc}
692 %{_mandir}/man1/git-svn.1*
693 %endif
694
695 %files cvs
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_bindir}/git-cvsserver
698 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
699 %if %{with doc}
700 %{_mandir}/man1/git-cvs*.1*
701 %{_mandir}/man7/gitcvs-migration.7*
702 %endif
703
704 %files arch
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
707 %if %{with doc}
708 %{_mandir}/man1/git-archimport.1*
709 %endif
710
711 %files email
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/%{name}/*email*
714 %if %{with doc}
715 %{_mandir}/man1/*email*.1*
716 %endif
717
718 %files -n bash-completion-git
719 %defattr(644,root,root,755)
720 %{bash_compdir}/git
721
722 %files -n perl-Git
723 %defattr(644,root,root,755)
724 %{perl_vendorlib}/Git.pm
725 %dir %{perl_vendorlib}/Git
726 %{perl_vendorlib}/Git/I18N.pm
727 %{perl_vendorlib}/Git/IndexInfo.pm
728 %{_mandir}/man3/Git*.3pm*
729
730 %files -n python-Git
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
733 %dir %{py_sitescriptdir}/git_remote_helpers
734 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
735 %dir %{py_sitescriptdir}/git_remote_helpers/git
736 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
737 %if "%{py_ver}" > "2.4"
738 %{py_sitescriptdir}/git_remote_helpers*.egg-info
739 %endif
740 %if %{with doc}
741 %{_mandir}/man1/gitremote-helpers.1*
742 %endif
743
744 %files -n vim-syntax-gitcommit
745 %defattr(644,root,root,755)
746 %doc contrib/vim/README
747 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.093389 seconds and 4 git commands to generate.