]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
vim hiliting is included in vim distribution as of vim 7.2
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.9.0
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  e16c14b27c644b8e0dd72bdb5ff77450
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        gitolite.pl
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 Patch4:         %{name}-svn-exit-errors.patch
31 URL:            http://git-scm.com/
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.264
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-bzr
70 Suggests:       git-core-cvs
71 Suggests:       git-core-hg
72 Suggests:       git-core-p4
73 Suggests:       git-core-svn
74 Suggests:       less
75 Suggests:       rsync
76 Obsoletes:      python-Git
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 # html docs have links to txt files
80 %define         _noautocompressdoc      *.txt
81
82 %define         webapp          gitweb
83 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
84 %define         appdir          %{_datadir}/%{webapp}
85 %define         cgibindir       %{_prefix}/lib/cgi-bin
86 %define         bash_compdir    %{_datadir}/bash-completion/completions
87
88 %description
89 "git" can mean anything, depending on your mood.
90
91 - random three-letter combination that is pronounceable, and not
92   actually used by any common UNIX command. The fact that it is a
93   mispronunciation of "get" may or may not be relevant.
94 - stupid. contemptible and despicable. simple. Take your pick from the
95   dictionary of slang.
96 - "global information tracker": you're in a good mood, and it actually
97   works for you. Angels sing, and a light suddenly fills the room.
98 - "goddamn idiotic truckload of sh*t": when it breaks
99
100 This is a stupid (but extremely fast) directory content manager. It
101 doesn't do a whole lot, but what it 'does' do is track directory
102 contents efficiently.
103
104 %description -l pl.UTF-8
105 "git" może oznaczać cokolwiek, w zależności od nastroju.
106
107 - losową kombinację trzech liter, która jest wymawialna i właściwie
108   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
109   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
110 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
111 - "global information tracker" (narzędzie do globalnego śledzenia
112   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
113   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
114 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
115   g*) - kiedy się zepsuje.
116
117 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
118 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
119 katalogu.
120
121 %package doc
122 Summary:        Documentation for git-core
123 Summary(pl.UTF-8):      Dokumentacja do git-core
124 Group:          Documentation
125
126 %description doc
127 Documentation for git-core.
128
129 %description doc -l pl.UTF-8
130 Dokumentacja do git-core.
131
132 %description doc -l fr.UTF-8
133 Javadoc pour git-core.
134
135 %package daemon-inetd
136 Summary:        Files necessary to run git-daemon as an inetd service
137 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
138 Group:          Networking/Daemons
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       setup >= 2.4.11-1
141 Provides:       git-core-daemon
142 Obsoletes:      git-core-daemon
143 Obsoletes:      git-core-daemon-standalone
144
145 %description daemon-inetd
146 Git-daemon is a really simple TCP git daemon that can serve git
147 repositories. This package provides all necessarry files to run
148 git-daemon as an inetd service.
149
150 %description daemon-inetd -l pl.UTF-8
151 Git-daemon to prosty demon git korzystający z protokołu TCP do
152 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
153 do uruchomienia git-demona w trybie usługi inetd.
154
155 %package daemon-standalone
156 Summary:        Files necessary to run git-daemon as a standalone service
157 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
158 Group:          Networking/Daemons
159 Requires:       %{name} = %{version}-%{release}
160 Provides:       git-core-daemon
161 Obsoletes:      git-core-daemon
162 Obsoletes:      git-core-daemon-inetd
163
164 %description daemon-standalone
165 Git-daemon is a really simple TCP git daemon that can serve git
166 repositories. This package provides all necessarry files to run
167 git-daemon as an standalone service.
168
169 %description daemon-standalone -l pl.UTF-8
170 Git-daemon to prosty demon git korzystający z protokołu TCP do
171 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
172 do uruchomienia git-daemona w trybie usługi samodzielnej.
173
174 %package devel
175 Summary:        Git library with header files
176 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
177 Group:          Development/Libraries
178 Requires:       zlib-devel
179
180 %description devel
181 Git library with header files.
182
183 %description devel -l pl.UTF-8
184 Biblioteka Gita oraz pliki nagłówkowe.
185
186 %package gitk
187 Summary:        Tcl/Tk interface to the Git version control system
188 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
189 Group:          Development/Tools
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       tk
192
193 %description gitk
194 gitk displays changes in a repository or a selected set of commits.
195 This includes visualizing the commit graph, showing information
196 related to each commit, and the files in the trees of each revision.
197
198 Historically, gitk was the first repository browser. It's written in
199 Tcl/Tk and started off in a separate repository but was later merged
200 into the main git repository.
201
202 %description gitk -l pl.UTF-8
203 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
204 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
205 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
206
207 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
208 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
209 osobnym repozytorium, ale z czasem został włączony do głównego
210 repozytorium gita.
211
212 %package gitweb
213 Summary:        Web frontend to git
214 Summary(pl.UTF-8):      Frontend WWW do gita
215 Group:          Development/Tools
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       webapps
218 Requires:       webserver(access)
219 Requires:       webserver(alias)
220 Requires:       webserver(cgi)
221 Suggests:       webserver(setenv)
222
223 %description gitweb
224 This package provides a web interface for browsing git repositories.
225
226 %description gitweb -l pl.UTF-8
227 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
228
229 %package gitview
230 Summary:        A GTK+ based repository browser for git
231 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       python >= 1:2.4
235 Requires:       python-pycairo >= 1.0
236 Requires:       python-pygobject
237 Requires:       python-pygtk-gtk >= 2:2.8
238 Suggests:       python-gnome-desktop-gtksourceview
239
240 %description gitview
241 A GTK+ based repository browser for git.
242
243 %description gitview -l pl.UTF-8
244 Oparta na GTK+ przeglądarka repozytorium gita.
245
246 %package gui
247 Summary:        Tcl/Tk interface to the Git version control system
248 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
249 Group:          Development/Tools
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       tk
252 Requires:       xdg-utils
253 Suggests:       meld
254
255 %description gui
256 Displays changes in a repository or a selected set of commits. This
257 includes visualizing the commit graph, showing information related to
258 each commit, and the files in the trees of each revision.
259
260 Historically, gitk was the first repository browser. It's written in
261 Tcl/Tk and started off in a separate repository but was later merged
262 into the main git repository.
263
264 %description gui -l pl.UTF-8
265 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
266 to wizualizację grafu commitów, wyświetlanie informacji związanych z
267 każdym z commitów oraz listę plików dla każdej rewizji.
268
269 Z punktu widzenia historii, gitk był pierwszą przeglądarką
270 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
271 osobnym repozytorium, ale z czasem został włączony do głównego
272 repozytorium gita.
273
274 %package arch
275 Summary:        Git tools for importing Arch repositories
276 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
277 Group:          Development/Tools
278 Requires:       %{name} = %{version}-%{release}
279 Requires:       tla
280
281 %description arch
282 Git tools for importing Arch repositories.
283
284 %description arch -l pl.UTF-8
285 Narzędzia Gita do importowania repozytoriów Archa.
286
287 %package bzr
288 Summary:        Git tools for working with bzr repositories
289 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
290 Group:          Development/Tools
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       bzr
293
294 %description bzr
295 Git tools for working with bzr repositories.
296
297 %description bzr -l pl.UTF-8
298 Narzędzia Gita do pracy z repozytoriami bzr.
299
300 %package cvs
301 Summary:        CVS support for Git
302 Summary(pl.UTF-8):      Obsługa CVS dla Gita
303 Group:          Development/Tools
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       cvsps >= 2.1-2
306 Requires:       rcs
307
308 %description cvs
309 CVS support for Git.
310
311 %description cvs -l pl.UTF-8
312 Obsługa CVS dla Gita.
313
314 %package hg
315 Summary:        Git tools for working with mercurial repositories
316 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
317 Group:          Development/Tools
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       mercurial >= 1.8
320
321 %description hg
322 Git tools for working with mercurial repositories.
323
324 %description hg -l pl.UTF-8
325 Narzędzia Gita do pracy z repozytoriami mercuriala.
326
327 %package p4
328 Summary:        Git tools for working with Perforce depots
329 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
330 Group:          Development/Tools
331 Requires:       %{name} = %{version}-%{release}
332
333 %description p4
334 Git tools for working with Perforce depots.
335
336 %description p4 -l pl.UTF-8
337 Narzędzia Gita do pracy z magazynami Perforce'a.
338
339 %package svn
340 Summary:        Subversion support for Git
341 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
342 Group:          Development/Tools
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       perl-Encode
345 Requires:       perl-Term-ReadKey
346
347 %description svn
348 Subversion support for Git.
349
350 %description svn -l pl.UTF-8
351 Obsługa Subversion dla Gita.
352
353 %package email
354 Summary:        Git tools for sending email
355 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
356 Group:          Development/Tools
357 Requires:       %{name} = %{version}-%{release}
358
359 %description email
360 Git tools for sending email.
361
362 %description email -l pl.UTF-8
363 Narzędzia Gita do wysyłania poczty.
364
365 %package -n bash-completion-git
366 Summary:        bash-completion for git
367 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
368 Group:          Applications/Shells
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       bash-completion >= 2.0
371
372 %description -n bash-completion-git
373 This package provides bash-completion for git.
374
375 %description -n bash-completion-git -l pl.UTF-8
376 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
377
378 %package -n perl-Git
379 Summary:        Perl interface to the Git version control system
380 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
381 Group:          Development/Languages/Perl
382 Obsoletes:      perl-git-core
383
384 %description -n perl-Git
385 This module provides Perl scripts easy way to interface the Git
386 version control system. The modules have an easy and well-tested way
387 to call arbitrary Git commands; in the future, the interface will also
388 provide specialized methods for doing easily operations which are not
389 totally trivial to do over the generic command interface.
390
391 %description -n perl-Git -l pl.UTF-8
392 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
393 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
394 dowolne polecenia Gita; w przyszłości interfejs udostępni także
395 specjalne metody do łatwego wykonywania operacji nietrywialnych do
396 wykonania przy użyciu ogólnego interfejsu poleceń.
397
398 %prep
399 %setup -q -n git-%{version}
400 %patch0 -p1
401 %patch1 -p0
402 %patch2 -p1
403 %patch3 -p1
404 %patch4 -p1
405
406 %build
407 %{__aclocal}
408 %{__autoconf}
409 %configure \
410         --sysconfdir=%{_sysconfdir}/git-core \
411         %{?with_pcre:--with-libpcre} \
412         --with-openssl
413
414 echo "BLK_SHA1=1" >> config.mak
415
416 %{__make} \
417         INSTALLDIRS=vendor \
418         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
419         GITWEB_PROJECTROOT="/var/lib/git" \
420         GITWEB_CSS="/gitweb/gitweb.css" \
421         GITWEB_LOGO="/gitweb/git-logo.png" \
422         GITWEB_FAVICON="/gitweb/git-favicon.png" \
423         V=1
424
425 %{__make} -C contrib/subtree
426
427 %if %{with doc}
428 %{__make} -C Documentation \
429         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
430         V=1
431 %endif
432
433 %if %{with tests}
434 %if %{without tests_cvs}
435 %{__rm} t/t*cvs*.sh || :
436 %endif
437 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
438 %endif
439
440 %install
441 rm -rf $RPM_BUILD_ROOT
442 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
443 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
444 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
445 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
446 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
447 [init]
448         templatedir = %{_sysconfdir}/%{name}/templates
449 EOF
450
451 %{__make} install \
452         INSTALLDIRS=vendor \
453         DESTDIR=$RPM_BUILD_ROOT
454
455 %if %{with doc}
456 %{__make} -C Documentation install \
457         DESTDIR=$RPM_BUILD_ROOT
458 %endif
459
460 # copy templates except sample hooks
461 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
462 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
463
464 # header files and lib
465 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
466 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
467 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
468 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
469 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
470 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
471 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
472 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
473
474 %{__make} -C contrib/subtree install \
475         libexecdir=%{_libdir}/%{name} \
476         DESTDIR=$RPM_BUILD_ROOT
477
478 %if %{with doc}
479 %{__make} -C contrib/subtree install-doc \
480         DESTDIR=$RPM_BUILD_ROOT
481 %endif
482
483 # bash completion
484 install -d $RPM_BUILD_ROOT%{bash_compdir}
485 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
486
487 # Install bzr and hg remote helpers from contrib
488 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
489
490 # gitweb
491 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
492 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
493 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
494 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
495 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
496 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
497 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
498
499 # gitview
500 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
501
502 # git-daemon related files
503 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
504 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
505 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
506
507 # paths cleanup
508 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
509 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
510
511 # hardlink
512 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
513 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
514 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
515 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
516
517 # remove unneeded files
518 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
519 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
520 %py_postclean
521
522 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
523 %find_lang git
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %post daemon-inetd
529 %service -q rc-inetd reload
530
531 %postun daemon-inetd
532 if [ "$1" = "0" ]; then
533         %service -q rc-inetd reload
534 fi
535
536 %post daemon-standalone
537 /sbin/chkconfig --add git-daemon
538 %service git-daemon restart "git-daemon"
539
540 %preun daemon-standalone
541 if [ "$1" = "0" ]; then
542         %service git-daemon stop
543         /sbin/chkconfig --del git-daemon
544 fi
545
546 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
547 %webapp_register apache %{webapp}
548
549 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
550 %webapp_unregister apache %{webapp}
551
552 %triggerin gitweb -- apache < 2.2.0, apache-base
553 %webapp_register httpd %{webapp}
554
555 %triggerun gitweb -- apache < 2.2.0, apache-base
556 %webapp_unregister httpd %{webapp}
557
558 %triggerin gitweb -- lighttpd
559 %webapp_register lighttpd %{webapp}
560
561 %triggerun gitweb -- lighttpd
562 %webapp_unregister lighttpd %{webapp}
563
564 %files -f git.lang
565 %defattr(644,root,root,755)
566 %doc README contrib
567 %attr(755,root,root) %{_bindir}/git
568 %attr(755,root,root) %{_bindir}/git-receive-pack
569 %attr(755,root,root) %{_bindir}/git-shell
570 %attr(755,root,root) %{_bindir}/git-upload-archive
571 %attr(755,root,root) %{_bindir}/git-upload-pack
572 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
573
574 %if %{with doc}
575 %{_mandir}/man1/git-*.1*
576 %exclude %{_mandir}/man1/git-archimport.1*
577 %exclude %{_mandir}/man1/git-svn.1*
578 %exclude %{_mandir}/man1/git-cvs*.1*
579 %exclude %{_mandir}/man1/git-imap-send*.1*
580 %exclude %{_mandir}/man1/*email*.1*
581 %{_mandir}/man1/git.1*
582 %{_mandir}/man1/gitremote-helpers.1*
583 %{_mandir}/man5/gitattributes.5*
584 %{_mandir}/man5/githooks.5*
585 %{_mandir}/man5/gitignore.5*
586 %{_mandir}/man5/gitmodules.5*
587 %{_mandir}/man5/gitrepository-layout.5*
588 %{_mandir}/man7/gitcli.7*
589 %{_mandir}/man7/gitcore-tutorial.7*
590 %{_mandir}/man7/gitcredentials.7*
591 %{_mandir}/man7/gitdiffcore.7*
592 %{_mandir}/man7/gitglossary.7*
593 %{_mandir}/man7/gitnamespaces.7*
594 %{_mandir}/man7/gitrevisions.7*
595 %{_mandir}/man7/gittutorial-2.7*
596 %{_mandir}/man7/gittutorial.7*
597 %{_mandir}/man7/gitworkflows.7*
598 %endif
599
600 %dir %{_libdir}/%{name}
601 %attr(755,root,root) %{_libdir}/%{name}/*-*
602 %attr(755,root,root) %{_libdir}/%{name}/git
603 %dir %{_libdir}/%{name}/mergetools
604 %{_libdir}/%{name}/mergetools/*
605
606 %{_datadir}/%{name}
607 %{_localstatedir}/lib/git
608
609 # subpackages
610 %exclude %{_libdir}/%{name}/*email*
611 %exclude %{_libdir}/%{name}/*p4*
612 %exclude %{_libdir}/%{name}/git-archimport
613 %exclude %{_libdir}/%{name}/git-cvs*
614 %exclude %{_libdir}/%{name}/git-gui
615 %exclude %{_libdir}/%{name}/git-imap-send
616 %exclude %{_libdir}/%{name}/git-instaweb
617 %exclude %{_libdir}/%{name}/git-remote-bzr
618 %exclude %{_libdir}/%{name}/git-remote-hg
619 %exclude %{_libdir}/%{name}/git-remote-testsvn
620 %exclude %{_libdir}/%{name}/git-svn
621 %exclude %{_libdir}/%{name}/mergetools/p4merge
622
623 %if %{with doc}
624 %files doc
625 %defattr(644,root,root,755)
626 %doc Documentation/RelNotes*
627 %doc Documentation/*.html Documentation/howto Documentation/technical
628 %endif
629
630 %files daemon-inetd
631 %defattr(644,root,root,755)
632 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
633
634 %files daemon-standalone
635 %defattr(644,root,root,755)
636 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
637 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
638
639 %files devel
640 %defattr(644,root,root,755)
641 %{_includedir}/%{name}
642 %{_libdir}/libgit.a
643 %{_libdir}/libgit_xdiff.a
644
645 %files gitk
646 %defattr(644,root,root,755)
647 %if %{with doc}
648 %{_mandir}/man1/gitk.1*
649 %endif
650 %attr(755,root,root) %{_bindir}/gitk
651 %dir %{_datadir}/gitk
652 %dir %{_datadir}/gitk/lib
653 %dir %{_datadir}/gitk/lib/msgs
654 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
655 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
656 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
657 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
658 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
659 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
660 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
661 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
662 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
663 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
664
665 %files gitweb
666 %defattr(644,root,root,755)
667 %doc gitweb/{README,INSTALL}
668 %dir %{webappdir}
669 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
670 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
671 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
672 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
673 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
674 %attr(755,root,root) %{cgibindir}/gitweb.cgi
675 %{appdir}
676 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
677 %if %{with doc}
678 %{_mandir}/man1/gitweb.1*
679 %{_mandir}/man5/gitweb.conf.5*
680 %endif
681
682 %files gitview
683 %defattr(644,root,root,755)
684 %doc contrib/gitview/gitview.txt
685 %attr(755,root,root) %{_bindir}/gitview
686
687 %files gui
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/%{name}/git-gui
690 %dir %{_datadir}/git-gui
691 %dir %{_datadir}/git-gui/lib
692 %dir %{_datadir}/git-gui/lib/msgs
693 %{_datadir}/git-gui/lib/git-gui.ico
694 %{_datadir}/git-gui/lib/tclIndex
695 %{_datadir}/git-gui/lib/*.js
696 %{_datadir}/git-gui/lib/*.tcl
697 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
698 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
699 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
700 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
701 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
702 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
703 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
704 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
705 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
706 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
707 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
708 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
709
710 %files arch
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
713 %if %{with doc}
714 %{_mandir}/man1/git-archimport.1*
715 %endif
716
717 %files bzr
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
720
721 %files cvs
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_bindir}/git-cvsserver
724 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
725 %if %{with doc}
726 %{_mandir}/man1/git-cvs*.1*
727 %{_mandir}/man7/gitcvs-migration.7*
728 %endif
729
730 %files hg
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
733
734 %files p4
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/%{name}/git-p4
737 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
738
739 %files svn
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/%{name}/git-svn
742 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
743 %{perl_vendorlib}/Git/SVN
744 %{perl_vendorlib}/Git/SVN.pm
745 %if %{with doc}
746 %{_mandir}/man1/git-svn.1*
747 %endif
748
749 %files email
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
752 %attr(755,root,root) %{_libdir}/%{name}/*email*
753 %if %{with doc}
754 %{_mandir}/man1/*email*.1*
755 %{_mandir}/man1/*imap-send*.1*
756 %endif
757
758 %files -n bash-completion-git
759 %defattr(644,root,root,755)
760 %{bash_compdir}/git
761
762 %files -n perl-Git
763 %defattr(644,root,root,755)
764 %{perl_vendorlib}/Git.pm
765 %dir %{perl_vendorlib}/Git
766 %{perl_vendorlib}/Git/I18N.pm
767 %{perl_vendorlib}/Git/IndexInfo.pm
768 %{_mandir}/man3/Git*.3pm*
This page took 0.123948 seconds and 4 git commands to generate.