]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
updated to 1.8.4.1
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.4.1
14 Release:        1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  5d8c89ad312ca0b0e603259c9357e6b8
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-svn-exit-errors.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-cvs
69 Suggests:       git-core-svn
70 Suggests:       less
71 Suggests:       rsync
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # html docs have links to txt files
75 %define         _noautocompressdoc      *.txt
76
77 %define         webapp          gitweb
78 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
79 %define         appdir          %{_datadir}/%{webapp}
80 %define         cgibindir       %{_prefix}/lib/cgi-bin
81 %define         bash_compdir    %{_datadir}/bash-completion/completions
82
83 %description
84 "git" can mean anything, depending on your mood.
85
86 - random three-letter combination that is pronounceable, and not
87   actually used by any common UNIX command. The fact that it is a
88   mispronunciation of "get" may or may not be relevant.
89 - stupid. contemptible and despicable. simple. Take your pick from the
90   dictionary of slang.
91 - "global information tracker": you're in a good mood, and it actually
92   works for you. Angels sing, and a light suddenly fills the room.
93 - "goddamn idiotic truckload of sh*t": when it breaks
94
95 This is a stupid (but extremely fast) directory content manager. It
96 doesn't do a whole lot, but what it 'does' do is track directory
97 contents efficiently.
98
99 %description -l pl.UTF-8
100 "git" może oznaczać cokolwiek, w zależności od nastroju.
101
102 - losową kombinację trzech liter, która jest wymawialna i właściwie
103   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
104   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
105 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
106 - "global information tracker" (narzędzie do globalnego śledzenia
107   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
108   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
109 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
110   g*) - kiedy się zepsuje.
111
112 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
113 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
114 katalogu.
115
116 %package doc
117 Summary:        Documentation for git-core
118 Summary(pl.UTF-8):      Dokumentacja do git-core
119 Group:          Documentation
120
121 %description doc
122 Documentation for git-core.
123
124 %description doc -l pl.UTF-8
125 Dokumentacja do git-core.
126
127 %description doc -l fr.UTF-8
128 Javadoc pour git-core.
129
130 %package daemon-inetd
131 Summary:        Files necessary to run git-daemon as an inetd service
132 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
133 Group:          Networking/Daemons
134 Requires:       %{name} = %{version}-%{release}
135 Requires:       setup >= 2.4.11-1
136 Provides:       git-core-daemon
137 Obsoletes:      git-core-daemon
138 Obsoletes:      git-core-daemon-standalone
139
140 %description daemon-inetd
141 Git-daemon is a really simple TCP git daemon that can serve git
142 repositories. This package provides all necessarry files to run
143 git-daemon as an inetd service.
144
145 %description daemon-inetd -l pl.UTF-8
146 Git-daemon to prosty demon git korzystający z protokołu TCP do
147 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
148 do uruchomienia git-demona w trybie usługi inetd.
149
150 %package daemon-standalone
151 Summary:        Files necessary to run git-daemon as a standalone service
152 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
153 Group:          Networking/Daemons
154 Requires:       %{name} = %{version}-%{release}
155 Provides:       git-core-daemon
156 Obsoletes:      git-core-daemon
157 Obsoletes:      git-core-daemon-inetd
158
159 %description daemon-standalone
160 Git-daemon is a really simple TCP git daemon that can serve git
161 repositories. This package provides all necessarry files to run
162 git-daemon as an standalone service.
163
164 %description daemon-standalone -l pl.UTF-8
165 Git-daemon to prosty demon git korzystający z protokołu TCP do
166 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
167 do uruchomienia git-daemona w trybie usługi samodzielnej.
168
169 %package devel
170 Summary:        Git library with header files
171 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
172 Group:          Development/Libraries
173 Requires:       zlib-devel
174
175 %description devel
176 Git library with header files.
177
178 %description devel -l pl.UTF-8
179 Biblioteka Gita oraz pliki nagłówkowe.
180
181 %package gitk
182 Summary:        Tcl/Tk interface to the Git version control system
183 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
184 Group:          Development/Tools
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       tk
187
188 %description gitk
189 gitk displays changes in a repository or a selected set of commits.
190 This includes visualizing the commit graph, showing information
191 related to each commit, and the files in the trees of each revision.
192
193 Historically, gitk was the first repository browser. It's written in
194 Tcl/Tk and started off in a separate repository but was later merged
195 into the main git repository.
196
197 %description gitk -l pl.UTF-8
198 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
199 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
200 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
201
202 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
203 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
204 osobnym repozytorium, ale z czasem został włączony do głównego
205 repozytorium gita.
206
207 %package gitweb
208 Summary:        Web frontend to git
209 Summary(pl.UTF-8):      Frontend WWW do gita
210 Group:          Development/Tools
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       webapps
213 Requires:       webserver(alias)
214 Requires:       webserver(cgi)
215 Suggests:       webserver(setenv)
216
217 %description gitweb
218 This package provides a web interface for browsing git repositories.
219
220 %description gitweb -l pl.UTF-8
221 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
222
223 %package gitview
224 Summary:        A GTK+ based repository browser for git
225 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
226 Group:          Development/Tools
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       python >= 1:2.4
229 Requires:       python-pycairo >= 1.0
230 Requires:       python-pygobject
231 Requires:       python-pygtk-gtk >= 2:2.8
232 Suggests:       python-gnome-desktop-gtksourceview
233
234 %description gitview
235 A GTK+ based repository browser for git.
236
237 %description gitview -l pl.UTF-8
238 Oparta na GTK+ przeglądarka repozytorium gita.
239
240 %package gui
241 Summary:        Tcl/Tk interface to the Git version control system
242 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
243 Group:          Development/Tools
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       tk
246 Requires:       xdg-utils
247 Suggests:       meld
248
249 %description gui
250 Displays changes in a repository or a selected set of commits. This
251 includes visualizing the commit graph, showing information related to
252 each commit, and the files in the trees of each revision.
253
254 Historically, gitk was the first repository browser. It's written in
255 Tcl/Tk and started off in a separate repository but was later merged
256 into the main git repository.
257
258 %description gui -l pl.UTF-8
259 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
260 to wizualizację grafu commitów, wyświetlanie informacji związanych z
261 każdym z commitów oraz listę plików dla każdej rewizji.
262
263 Z punktu widzenia historii, gitk był pierwszą przeglądarką
264 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
265 osobnym repozytorium, ale z czasem został włączony do głównego
266 repozytorium gita.
267
268 %package svn
269 Summary:        Subversion support for Git
270 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
271 Group:          Development/Tools
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       perl-Encode
274 Requires:       perl-Term-ReadKey
275
276 %description svn
277 Subversion support for Git.
278
279 %description svn -l pl.UTF-8
280 Obsługa Subversion dla Gita.
281
282 %package cvs
283 Summary:        CVS support for Git
284 Summary(pl.UTF-8):      Obsługa CVS dla Gita
285 Group:          Development/Tools
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       cvsps >= 2.1-2
288 Requires:       rcs
289
290 %description cvs
291 CVS support for Git.
292
293 %description cvs -l pl.UTF-8
294 Obsługa CVS dla Gita.
295
296 %package arch
297 Summary:        Git tools for importing Arch repositories
298 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
299 Group:          Development/Tools
300 Requires:       %{name} = %{version}-%{release}
301 Requires:       tla
302
303 %description arch
304 Git tools for importing Arch repositories.
305
306 %description arch -l pl.UTF-8
307 Narzędzia Gita do importowania repozytoriów Archa.
308
309 %package email
310 Summary:        Git tools for sending email
311 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
312 Group:          Development/Tools
313 Requires:       %{name} = %{version}-%{release}
314
315 %description email
316 Git tools for sending email.
317
318 %description email -l pl.UTF-8
319 Narzędzia Gita do wysyłania poczty.
320
321 %package -n bash-completion-git
322 Summary:        bash-completion for git
323 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
324 Group:          Applications/Shells
325 Requires:       %{name} = %{version}-%{release}
326 Requires:       bash-completion >= 2.0
327
328 %description -n bash-completion-git
329 This package provides bash-completion for git.
330
331 %description -n bash-completion-git -l pl.UTF-8
332 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
333
334 %package -n perl-Git
335 Summary:        Perl interface to the Git version control system
336 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
337 Group:          Development/Languages/Perl
338 Obsoletes:      perl-git-core
339
340 %description -n perl-Git
341 This module provides Perl scripts easy way to interface the Git
342 version control system. The modules have an easy and well-tested way
343 to call arbitrary Git commands; in the future, the interface will also
344 provide specialized methods for doing easily operations which are not
345 totally trivial to do over the generic command interface.
346
347 %description -n perl-Git -l pl.UTF-8
348 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
349 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
350 dowolne polecenia Gita; w przyszłości interfejs udostępni także
351 specjalne metody do łatwego wykonywania operacji nietrywialnych do
352 wykonania przy użyciu ogólnego interfejsu poleceń.
353
354 %package -n python-Git
355 Summary:        Python Git remote helpers for non-git repositories
356 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
357 Group:          Development/Languages/Python
358 Requires:       %{name} = %{version}-%{release}
359
360 %description -n python-Git
361 This package contains Python git_repote_helpers package - Git remote
362 helpers for non-git repositories.
363
364 %description -n python-Git -l pl.UTF-8
365 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
366 pomocnicze Gita dla repozytoriów niegitowych.
367
368 %package -n vim-syntax-gitcommit
369 Summary:        Vim syntax: gitcommit
370 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
371 Group:          Applications/Editors/Vim
372 Requires:       %{name} = %{version}-%{release}
373 # for _vimdatadir existence
374 Requires:       vim-rt >= 4:6.3.058-3
375
376 %description -n vim-syntax-gitcommit
377 This plugin provides syntax highlighting for git's commit messages.
378
379 %description -n vim-syntax-gitcommit -l pl.UTF-8
380 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
381
382 %prep
383 %setup -q -n git-%{version}
384 %patch0 -p1
385 %patch1 -p0
386 %patch2 -p1
387 %patch3 -p1
388 %patch4 -p1
389
390 %build
391 %{__aclocal}
392 %{__autoconf}
393 %configure \
394         --sysconfdir=%{_sysconfdir}/git-core \
395         %{?with_pcre:--with-libpcre} \
396         --with-openssl
397
398 echo "BLK_SHA1=1" >> config.mak
399
400 %{__make} \
401         INSTALLDIRS=vendor \
402         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
403         GITWEB_PROJECTROOT="/var/lib/git" \
404         GITWEB_CSS="/gitweb/gitweb.css" \
405         GITWEB_LOGO="/gitweb/git-logo.png" \
406         GITWEB_FAVICON="/gitweb/git-favicon.png" \
407         V=1
408
409 %if %{with doc}
410 %{__make} -C Documentation \
411         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
412         V=1
413 %endif
414
415 %if %{with tests}
416 %if %{without tests_cvs}
417 %{__rm} t/t*cvs*.sh || :
418 %endif
419 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
420 %endif
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
425 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
426 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
427 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
428 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
429 [init]
430         templatedir = %{_sysconfdir}/%{name}/templates
431 EOF
432
433 %{__make} install \
434         INSTALLDIRS=vendor \
435         DESTDIR=$RPM_BUILD_ROOT
436
437 %if %{with doc}
438 %{__make} -C Documentation install \
439         DESTDIR=$RPM_BUILD_ROOT
440 %endif
441
442 # copy templates except sample hooks
443 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
444 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
445
446 # header files and lib
447 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
448 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
449 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
450 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
451 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
452 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
453 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
454 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
455
456 # bash completion
457 install -d $RPM_BUILD_ROOT%{bash_compdir}
458 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
459
460 # vim syntax
461 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
462 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
463 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
464 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
465 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
466 autocmd BufNewFile,BufRead .msg.[0-9]*
467         \ if getline(1) =~ '^From.*# This line is ignored.$' |
468         \   setf gitsendemail |
469         \ endif
470 autocmd BufNewFile,BufRead *.git/**
471         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
472         \   setf git |
473         \ endif
474 EOF
475
476 # gitweb
477 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
478 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
479 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
480 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
481 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
482 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
483
484 # gitview
485 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
486
487 # git-daemon related files
488 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
489 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
490 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
491
492 # paths cleanup
493 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
494 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
495
496 # hardlink
497 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
498 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
499 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
500 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
501
502 # remove unneeded files
503 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
504 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
505 %py_postclean
506
507 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
508 %find_lang git
509
510 %clean
511 rm -rf $RPM_BUILD_ROOT
512
513 %post daemon-inetd
514 %service -q rc-inetd reload
515
516 %postun daemon-inetd
517 if [ "$1" = "0" ]; then
518         %service -q rc-inetd reload
519 fi
520
521 %post daemon-standalone
522 /sbin/chkconfig --add git-daemon
523 %service git-daemon restart "git-daemon"
524
525 %preun daemon-standalone
526 if [ "$1" = "0" ]; then
527         %service git-daemon stop
528         /sbin/chkconfig --del git-daemon
529 fi
530
531 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
532 %webapp_register apache %{webapp}
533
534 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
535 %webapp_unregister apache %{webapp}
536
537 %triggerin gitweb -- apache < 2.2.0, apache-base
538 %webapp_register httpd %{webapp}
539
540 %triggerun gitweb -- apache < 2.2.0, apache-base
541 %webapp_unregister httpd %{webapp}
542
543 %triggerin gitweb -- lighttpd
544 %webapp_register lighttpd %{webapp}
545
546 %triggerun gitweb -- lighttpd
547 %webapp_unregister lighttpd %{webapp}
548
549 %files -f git.lang
550 %defattr(644,root,root,755)
551 %doc README contrib
552 %attr(755,root,root) %{_bindir}/git
553 %attr(755,root,root) %{_bindir}/git-receive-pack
554 %attr(755,root,root) %{_bindir}/git-shell
555 %attr(755,root,root) %{_bindir}/git-upload-archive
556 %attr(755,root,root) %{_bindir}/git-upload-pack
557 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
558
559 %if %{with doc}
560 %{_mandir}/man1/git-*.1*
561 %exclude %{_mandir}/man1/git-archimport.1*
562 %exclude %{_mandir}/man1/git-svn.1*
563 %exclude %{_mandir}/man1/git-cvs*.1*
564 %exclude %{_mandir}/man1/git-imap-send*.1*
565 %exclude %{_mandir}/man1/*email*.1*
566 %exclude %{_mandir}/man1/gitremote-helpers.1*
567 %{_mandir}/man1/git.1*
568 %{_mandir}/man5/gitattributes.5*
569 %{_mandir}/man5/githooks.5*
570 %{_mandir}/man5/gitignore.5*
571 %{_mandir}/man5/gitmodules.5*
572 %{_mandir}/man5/gitrepository-layout.5*
573 %{_mandir}/man7/gitcli.7*
574 %{_mandir}/man7/gitcore-tutorial.7*
575 %{_mandir}/man7/gitcredentials.7*
576 %{_mandir}/man7/gitdiffcore.7*
577 %{_mandir}/man7/gitglossary.7*
578 %{_mandir}/man7/gitnamespaces.7*
579 %{_mandir}/man7/gitrevisions.7*
580 %{_mandir}/man7/gittutorial-2.7*
581 %{_mandir}/man7/gittutorial.7*
582 %{_mandir}/man7/gitworkflows.7*
583 %endif
584
585 %dir %{_libdir}/%{name}
586 %attr(755,root,root) %{_libdir}/%{name}/*-*
587 %attr(755,root,root) %{_libdir}/%{name}/git
588 %{_libdir}/%{name}/mergetools
589
590 %exclude %{_libdir}/%{name}/git-gui
591 %exclude %{_libdir}/%{name}/git-svn
592 %exclude %{_libdir}/%{name}/git-archimport
593 %exclude %{_libdir}/%{name}/git-cvs*
594 %exclude %{_libdir}/%{name}/git-imap-send
595 %exclude %{_libdir}/%{name}/git-instaweb
596 %exclude %{_libdir}/%{name}/git-remote-testsvn
597 %exclude %{_libdir}/%{name}/*email*
598
599 %{_datadir}/%{name}
600
601 %{_localstatedir}/lib/git
602
603 %if %{with doc}
604 %files doc
605 %defattr(644,root,root,755)
606 %doc Documentation/RelNotes*
607 %doc Documentation/*.html Documentation/howto Documentation/technical
608 %endif
609
610 %files daemon-inetd
611 %defattr(644,root,root,755)
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
613
614 %files daemon-standalone
615 %defattr(644,root,root,755)
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
617 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
618
619 %files devel
620 %defattr(644,root,root,755)
621 %{_includedir}/%{name}
622 %{_libdir}/libgit.a
623 %{_libdir}/libgit_xdiff.a
624
625 %files gitk
626 %defattr(644,root,root,755)
627 %if %{with doc}
628 %{_mandir}/man1/gitk.1*
629 %endif
630 %attr(755,root,root) %{_bindir}/gitk
631 %dir %{_datadir}/gitk
632 %dir %{_datadir}/gitk/lib
633 %dir %{_datadir}/gitk/lib/msgs
634 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
635 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
636 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
637 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
638 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
639 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
640 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
641 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
642 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
643
644 %files gitweb
645 %defattr(644,root,root,755)
646 %doc gitweb/{README,INSTALL}
647 %dir %{webappdir}
648 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
649 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
650 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
651 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
652 %attr(755,root,root) %{cgibindir}/gitweb.cgi
653 %{appdir}
654 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
655 %if %{with doc}
656 %{_mandir}/man1/gitweb.1*
657 %{_mandir}/man5/gitweb.conf.5*
658 %endif
659
660 %files gitview
661 %defattr(644,root,root,755)
662 %doc contrib/gitview/gitview.txt
663 %attr(755,root,root) %{_bindir}/gitview
664
665 %files gui
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/%{name}/git-gui
668 %dir %{_datadir}/git-gui
669 %dir %{_datadir}/git-gui/lib
670 %dir %{_datadir}/git-gui/lib/msgs
671 %{_datadir}/git-gui/lib/git-gui.ico
672 %{_datadir}/git-gui/lib/tclIndex
673 %{_datadir}/git-gui/lib/*.js
674 %{_datadir}/git-gui/lib/*.tcl
675 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
676 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
677 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
678 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
679 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
680 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
681 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
682 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
683 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
684 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
685 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
686
687 %files svn
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/%{name}/git-svn
690 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
691 %{perl_vendorlib}/Git/SVN
692 %{perl_vendorlib}/Git/SVN.pm
693 %if %{with doc}
694 %{_mandir}/man1/git-svn.1*
695 %endif
696
697 %files cvs
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/git-cvsserver
700 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
701 %if %{with doc}
702 %{_mandir}/man1/git-cvs*.1*
703 %{_mandir}/man7/gitcvs-migration.7*
704 %endif
705
706 %files arch
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
709 %if %{with doc}
710 %{_mandir}/man1/git-archimport.1*
711 %endif
712
713 %files email
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
716 %attr(755,root,root) %{_libdir}/%{name}/*email*
717 %if %{with doc}
718 %{_mandir}/man1/*email*.1*
719 %{_mandir}/man1/*imap-send*.1*
720 %endif
721
722 %files -n bash-completion-git
723 %defattr(644,root,root,755)
724 %{bash_compdir}/git
725
726 %files -n perl-Git
727 %defattr(644,root,root,755)
728 %{perl_vendorlib}/Git.pm
729 %dir %{perl_vendorlib}/Git
730 %{perl_vendorlib}/Git/I18N.pm
731 %{perl_vendorlib}/Git/IndexInfo.pm
732 %{_mandir}/man3/Git*.3pm*
733
734 %files -n python-Git
735 %defattr(644,root,root,755)
736 %dir %{py_sitescriptdir}/git_remote_helpers
737 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
738 %dir %{py_sitescriptdir}/git_remote_helpers/git
739 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
740 %if "%{py_ver}" > "2.4"
741 %{py_sitescriptdir}/git_remote_helpers*.egg-info
742 %endif
743 %if %{with doc}
744 %{_mandir}/man1/gitremote-helpers.1*
745 %endif
746
747 %files -n vim-syntax-gitcommit
748 %defattr(644,root,root,755)
749 %doc contrib/vim/README
750 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.209402 seconds and 4 git commands to generate.