]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.4.4.2
[packages/git-core.git] / git-core.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        The stupid content tracker
3 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
4 Name:           git-core
5 Version:        1.4.4.2
6 Release:        1
7 License:        GPL v2
8 Group:          Development/Tools
9 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
10 # Source0-md5:  c4f72d96f62ae97c6e8d5cdb4afd55ca
11 URL:            http://git.or.cz/
12 BuildRequires:  asciidoc
13 BuildRequires:  curl-devel
14 BuildRequires:  expat-devel
15 BuildRequires:  openssl-devel
16 BuildRequires:  perl-Error
17 BuildRequires:  perl-base
18 BuildRequires:  python
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  xmlto
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 "git" can mean anything, depending on your mood.
26
27  - random three-letter combination that is pronounceable, and not
28    actually used by any common UNIX command. The fact that it is a
29    mispronunciation of "get" may or may not be relevant.
30  - stupid. contemptible and despicable. simple. Take your pick from the
31    dictionary of slang.
32  - "global information tracker": you're in a good mood, and it actually
33    works for you. Angels sing, and a light suddenly fills the room.
34  - "goddamn idiotic truckload of sh*t": when it breaks
35
36 This is a stupid (but extremely fast) directory content manager. It
37 doesn't do a whole lot, but what it 'does' do is track directory
38 contents efficiently.
39
40 %description -l pl
41 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
42
43 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
44   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
45   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
46 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
47 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
48   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
49   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
50 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
51   g*) - kiedy siê zepsuje.
52
53 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
54 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
55 katalogu.
56
57 %package devel
58 Summary:        Header files for git-core
59 Summary(pl):    Pliki nag³ówkowe dla git-core
60 Group:          Development/Libraries
61
62 %description devel
63 Header files for git-core.
64
65 %description devel
66 Pliki nag³ówkowe dla git-core.
67
68 %package -n perl-Git
69 Summary:        Perl interface to the Git version control system
70 Summary(pl):    Perlowy interfejs do systemu kontroli wersji Git
71 Group:          Development/Languages/Perl
72 Requires:       %{name} = %{version}-%{release}
73 Obsoletes:      perl-git-core
74
75 %description -n perl-Git
76 This module provides Perl scripts easy way to interface the Git
77 version control system. The modules have an easy and well-tested way
78 to call arbitrary Git commands; in the future, the interface will also
79 provide specialized methods for doing easily operations which are not
80 totally trivial to do over the generic command interface.
81
82 %description -n perl-Git -l pl
83 Ten modu³ umo¿liwia skryptom Perla wspó³pracê z systemem kontroli
84 wersji Git. W ³atwy i dobrze przetestowany sposób pozwala wywo³ywaæ
85 dowolne polecenia Gita; w przysz³o¶ci interfejs udostêpni tak¿e
86 specjalne metody do ³atwego wykonywania operacji nietrywialnych do
87 wykonania przy u¿yciu ogólnego interfejsu poleceñ.
88
89 %prep
90 %setup -q -n git-%{version}
91
92 %build
93 %{__make} \
94         prefix=%{_prefix} \
95         CC="%{__cc}" \
96         CFLAGS="%{rpmcflags}" \
97         LDFLAGS="%{rpmldflags}"
98
99 # once again to get perl paths stright
100 cd perl
101 %{__perl} Makefile.PL \
102         INSTALLDIRS=vendor
103 %{__make}
104 cd ..
105
106 %{__make} -C Documentation
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
111
112 %{__make} install \
113         prefix=%{_prefix} \
114         CFLAGS="%{rpmcflags}" \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %{__make} -C Documentation install \
118         prefix=%{_prefix} \
119         mandir=%{_mandir} \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
123 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
124
125 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
126 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc README Documentation/*.html Documentation/howto Documentation/technical
134 %attr(755,root,root) %{_bindir}/*
135 %{_mandir}/man*/*
136 %dir %{_datadir}/%{name}
137 %{_datadir}/%{name}/*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %{_includedir}/*
142
143 %files -n perl-Git
144 %defattr(644,root,root,755)
145 %{perl_vendorlib}/Git.pm
146 %{_mandir}/man3/*
This page took 0.075454 seconds and 4 git commands to generate.